Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity Store Checkout Issue


Recommended Posts

Hiya,

I am attempting to purchase Affinity Photo and when it finally gets to the section where I am required to fill in my card details for payment, the whole screen is suddenly filled with the "processing your order" page even though I have not yet entered any payment details and it has been like this for 10 mins now and it is still stuck on the same page.

I have tried refreshing the page and even gone back to the homepage from Google to go through the process again and still nothing.

Any help?

EDIT: I have managed to get around this issue by simply using my phone's browser to complete the purchase. However, this is an issue that should not be ignored for desktop users.

Edited by hb8991
Link to comment
Share on other sites

Welcome to the Serif Affinity forums, @hb8991.

What OS and browser are you using? Do you have any extensions that you've added to your browser? If so, which ones?

Have you tried a different browser?

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

  • 4 months later...

Hello!

I am also trying to purchase Affinity Publisher. Once I'm in the checkout page, creating my account, it doesn't load. I've used my laptop, ipad, phone. I've use Google Chrome and and Microsoft Edge. Still, it's not working. Can you help me out here, please. Your assistance is very much appreciated.

Link to comment
Share on other sites

  • 4 months later...

@AidanW

Welcome to the Affinity forums.

Have you tried the suggestion made earlier in this thread, to try purchasing using a different browser?  On a completely different forum for totally unrelated (to Serif) products a number of users have experienced similar problems (unable to complete purchase or unable to download the software) where the "common element" has been the use of MS Edge.  Suggesting they try a different browser has almost always resolved the problem!

Win 10 Pro, i7 6700K, 32Gb RAM, NVidia GTX1660 Ti and Intel HD530 Graphics

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher, version 1 and now version 2.

iPad Pro (12.9") (iOS 17.4) running Affinity Photo and Designer version 1 and all three version 2 apps.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.