Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Recommended Posts

Hello,

I am new to this and need help. Everytime I create something in Affinity Desginer and export as SVG for blender nothing shows up. Another problem I have is that with Affinity Designer the whole APP lags when using the Selection brush tool and when I click on EXPORT my whole PC lags (not while exporting just when on the tab). SPECS: I7 12700K, 32GB DDR4 3600MHZ, RTX 3070, WINDOWS 11, ONLY SSD's

 

Hope someone here can help me thanks

Link to comment
Share on other sites

Hi and welcome!

See this video which explains how to export SVGs in order to reuse them in Blender then. Though they use Ai there the same applies to AD here then when exporting as SVG, aka convert to curves and merge together etc.

For the Designer/Win 11 lagging, check and try out what happens when you instead set "disable OpenCL" and use "WARP" under the AD Preferences performace settings, see if that changes anything in behavior here or not. The Affinity products often have problems with certain GPU drivers in this regard.

☛ Affinity Designer 1.10.5 ◆ Affinity Photo 1.10.5 ◆ OSX El Capitan

Link to comment
Share on other sites

Hi,

Perhaps the imported item is too small and you can't see it. What does Outliner show in Blender?

To get the imported shape in real physical units, set it to 90 DPI when exporting, or use a 90 DPI document initially:
Affinity_SVG_Export.png.fadf2e84fe20d2c0d80a0885eb810c57.png
 

If you want to extrude your shape, use the second SVG import option:
Blender_SVG_Import.png.78def8294cfd2970fadf3fb382f8fa59.png

 

Link to comment
Share on other sites

4 hours ago, v_kyr said:

Hi and welcome!

See this video which explains how to export SVGs in order to reuse them in Blender then. Though they use Ai there the same applies to AD here then when exporting as SVG, aka convert to curves and merge together etc.

For the Designer/Win 11 lagging, check and try out what happens when you instead set "disable OpenCL" and use "WARP" under the AD Preferences performace settings, see if that changes anything in behavior here or not. The Affinity products often have problems with certain GPU drivers in this regard.

The OpenGL idea did fix my second issue so thank you! 

Link to comment
Share on other sites

54 minutes ago, telemax said:

Hi,

Perhaps the imported item is too small and you can't see it. What does Outliner show in Blender?

To get the imported shape in real physical units, set it to 90 DPI when exporting, or use a 90 DPI document initially:
Affinity_SVG_Export.png.fadf2e84fe20d2c0d80a0885eb810c57.png
 

If you want to extrude your shape, use the second SVG import option:
Blender_SVG_Import.png.78def8294cfd2970fadf3fb382f8fa59.png

 

Thanks for the tips I didnt know this! I found the issue why it wouldnt show in blender and the reason was because I grouped all layers to the main one in Affinity designer for SVG and it seems like layer effects like outline dont work either. Now I have a new issue maybe you know how to fix this. When imported into blender (see screenshot) the layers are inside of eachother any way to fix this in affinity? thanks

blender_TEyr1af4Vh.png

Link to comment
Share on other sites

A lot of objects are gathered into one location? In my case, it doesn't happen.

A screenshot of the Layers panel, or the file you provided, may clarify the cause.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.