Jump to content

Last version of Topaz Denoise that works as a plugin for Affinity Photo


Recommended Posts

Last November I updated my Topaz Bundle. From this, Adjust v106, Sharpen v335 and Studio are working fine as plugin in Affinity Photo (on Windows 10).

DeNoise v342 did not work, its log-file says 'Boost shim not ready:  The system cannot find the file specified.'

I contacted Topaz Support, but they stopped responding some weeks ago.

So I tried which version would still work: v302 gave the same error, but version 236 works. This version is from December 2020.

Is there something wrong with my configuration and should a more recent version work also ?

 

Link to comment
Share on other sites

Hi, @John Pelgrane and welcome to the forums.

Since it works with a previous version and now not with a current one, Topaz is clearly the right contact here.

Many of the Photoshop plugins do not work with Affinity Photo, or only to a limited extent, because they often use Photoshop APIs that are logically not available in APhoto.

AMD Ryzen 5 5600G | 32 GB DDR4 3200MHz | Sapphire RX 5600 XT 6 GB | Windows 11 Pro (22H2 Build 22622.586)
Affinity Suite V1.10.5.1342
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

It's nice to be important, but it's more important to be nice.

Link to comment
Share on other sites

Topaz DeNoise  always worked for me without any issues at all. Also the current version (V. 3.4.2) works perfectly fine with my Affintiy Photo—also current version—as plugin. Windows 10 system here, too. For me, the only Topaz app, which doesn't work as plugin in Affinity, is Topaz GigaPixel.

»A designer's job is to improve the general quality of life. In fact, it's the only reason for our existence.«
Paul Rand (1914-1996)

Link to comment
Share on other sites

3 hours ago, Andy05 said:

For me, the only Topaz app, which doesn't work as plugin in Affinity, is Topaz GigaPixel.

I think that you will find that plugins that alter the size of the image (such as GigaPixel or DxO ViewPoint) will not work with Affinity.

John

Windows 10, Affinity Photo 1.10.5 Designer 1.10.5 and Publisher 1.10.5 (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.