Jump to content

Setting dash/dot size in Stroke Panel


Recommended Posts

Why is the width and length of dashes/dots defined solely relative to stroke thickness? This lack of precision makes no sense. I specify stroke thickness as specific units, why do I not set dash dimensions in the same way? I can set the dimensions to scale -- or not -- when the stroke is scaled: this ensures relative size remains the same when the object is scaled.

When actually creating the original stroked objects (railway lines) life would be so.much.easier. if I could just set dash length to 0.25pt, interval 3pt (or whatever) instead of having to work this out as proportion of the stroke width. 

ETA: I think the dash/dot setting is broken. And I am using the current (new) release. See the attached image. I am trying to create a map of railway lines. There are three stacked lines, the bottom a wide black line, the middle a narrower white line (these two create the parallel tracks) and a third that should symbolize the ties, reasonably closely-placed narrow parallel lines. I create this third line by setting the line width wider than the bottom black line, then setting narrow spaced dashes (square ends) to create the narrow parallel lines. 

I don't seem able to do this in Designer. Look at the dash setting in the attached images. The first has a line width 2.5mm, dash length of 1, so dash of 2.5mm. The second has a line width of 2.5mm, dash length of 0.005 (so should be 0.0125mm), and it clearly is not. That was teh last of an increasingly frustrated series of reductions in dash length, *none of which* significantly reduced the length of the dash.
These lines are part of a large group on a large map (the artboard is in the third pic). If the size of the group or the artboard is breaking the functionality, that's not good either.
Tracks1.thumb.png.37976729e84e00860f25a4dff26fff27.png

 

 

1642402443_ScreenShot2021-10-26at13_57_50.thumb.png.f4f1c4abd70daf33dec9a9d228b067f1.png

 

235346299_ScreenShot2021-10-26at13_58_17.thumb.png.c3277a0721691cf11d33e08944f5fd9f.png

Link to comment
Share on other sites

1 hour ago, aizome said:

I don't seem able to do this in Designer. Look at the dash setting in the attached images. The first has a line width 2.5mm, dash length of 1, so dash of 2.5mm. The second has a line width of 2.5mm, dash length of 0.005 (so should be 0.0125mm), and it clearly is not. That was teh last of an increasingly frustrated series of reductions in dash length, *none of which* significantly reduced the length of the dash.

One of the issues you are running into is that you have selected a square cap which adds 1/2 the thickness of the line to the front and end of the dash.  Resulting in a minimum (0) length being a square.  Change it to a butt cap and you will find your 0.005 will work correctly.

 

 

 

 

iMac (27-inch, Late 2009) with macOS Sierra

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.