Jump to content

Affinity photo won't even open in safe mode

Recommended Posts

I am having the same issues with AP that a lot of people are having and it has made it unusable. Constantly " NOT RESPONDING".  I have the newest version 1.10. However it was doing it with previous versions as well. I have unchecked the Enable open cl and that did not change anything. Then I switched to safe mode and the app starts to open and then disappears.  I can open any other app including Krita and lightroom 5.

Should I delete the app and reinstall. Will my log in reregister me? 

Link to comment
Share on other sites

Hello @gmckay60 and welcome to the forums.

Can you give more details about what hardware are you using?  When you say that the APhoto is not responding, do you mean that it doesn't load completely and that you can't do anything, or that you try a few things and then it stops?  If APhoto was also hanging with a previous version then one thing you should check is that your graphics drivers are up to date.  This may possibly mean bypassing the computer/laptop manufacturer's latest offerings and installing the drivers direct from the graphics card maker.  If all else fails you might consider reverting to APhoto 1.9.2

Link to comment
Share on other sites

Asus laptop  Intel(R) core( TM) i7  CPU 2.50GHZ-2.59 GHZ 12GB ram   64bit windows 10 1 TB hard drive

I can open affinity Photo, but as I try to make adjustments to the photo the app constantly freezes and shows" not responding" at the top of the window. eventually it starts working again, but it will do it almost every adjustment I try to make. I watched the task manager and the CPU maxes out during the Not Responding and when the CPU finally drops the app starts working again. I have tried reinstalling the drivers. The graphics card is a GEForce 940M. 

It has been doing this with older versions too, but seems worse now.

I tried opening AP in safe mode, but the start window pops up and then disappears. All other apps open fine.

Thanks for answering.

Link to comment
Share on other sites

I haven't tried changing to warp. I had tried using AP before while making sure there were no other apps opened, but as I said previously it wasn't opening at all in safe mode.

However, I tried the holding down control while opening the app and reset account data and the app worked better. I initially got a " not responding " issue when I tried to denoise a photo, but after that it never came up again. However, although I realize  denoise is demanding ( I guess) the app as a whole is very slow. This may be my computer. quite a bit of sitting a waiting for task to complete. But definitely better with fewer " not responding" hick ups! Not fast enough for me to do anything much more than working on a few photos for HDR or stitching. I could not do batch editing at this speed. Lightroom 5 still performs great for my sports freelance work.

Thanks again! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.