Jump to content

Af.Publisher PDF export - Type is rasterized instead of vector

Recommended Posts

I'm trying to figure out what's going wrong. Every time i export a PDF for my printing service provider (PDF-X4), type is rasterized instead of staying vector. Usually i convert fonts to shapes on export, but i tried embedding the used fonts - same issue.

As a last resort i got rid of the drop shadows i had on the type, and behold - type was indeed vector after export.

Is this a bug? Why does using shadows forces type to be rasterized? Usually you rasterize only the shadows onto the image layer and retain the vector shapes of the type - at least that's what i did when i exported PDFs manually from Photoshop. I hoped that Publisher would do it automatically for me, but obviously it doesn't. Am i missing something? Or doing something completely wrong?

Link to comment
Share on other sites

I just did a test like yours, on a new document, and had exactly the same result as yours - text is vector!

When i export the document i did with the previous version, the text is rasterized in the PDF.

Same settings for both tests.

What do you mean by "PDF placed for passthrough"?

I don't know how to proceed. I need to find the issue, so it doesn't happen in the future. Could you please suggest some ideas what to look for?


UPDATE: Using an image background and grouping the type layers don't seem to affect the result. Text is still exported as vector.

Link to comment
Share on other sites

Thanks! Yes, i used the term wrong. By "vector" i mean "not rasterized". I usually don't embed fonts, but export text as shapes, just to be sure nothing changes at the printer's side.

And yeah, all my objects are done natively in Publisher. No passthrough.

BTW, opening the PDF back in Publisher shows the text blurry (rasterized) like it does in Acrobat Reader.

Link to comment
Share on other sites

  • Moderators

Hi @sveto,

Sorry to hear you're having trouble! Can you please provide a copy of the .afpub file (this can be reduced down to the text layer that isn't exporting correctly for you) and a screenshot showing your PDF export settings (including the More... dialog) for me?

As Lagarto has confirmed, this is working correctly for me here, so I'd like to investigate your file further. Many thanks in advance :)

Link to comment
Share on other sites

Hey Dan, i appreciate your help.

Here's the situation: When i remove the background image, the text exports as text. When i remove some of the text, the remaining text exports as text as well. So i need to send you the file mostly intact. I just changed the background image, removed the names and shuffled the text together.

The ZIP file contains the screenshots as well.

I'm very curious about your opinion.


Link to comment
Share on other sites

12 minutes ago, Lagarto said:

It is this setting that causes type to become rasterized:


Check if you really need the feature, and if you, if you could replace the background color with a vector shape on those parts where you have the dropshadow effect applied. 

Thank you so much, Lagarto! That was exactly the culprit for the problem. I don't even know what this feature does, and don't understand why it is enabled by default in the first place, if it does so much damage. :shrug:

Never could've found this on my own...

Link to comment
Share on other sites

Very useful info, thx!

I have the feeling this is one of those Affinity bugs quirks we have to live with, for now. I remember my disappointment when i discovered that APhoto can't show the backside of a 2D transform like Photoshop does... But still, for now Designer/Publisher save me upgrading to the big Adobe subscription, and this is welcome. :)


Link to comment
Share on other sites

SHORT UPDATE: I revisited another flyer that i had this problem with. I unticked the "fill knocks out..." in every layer with drop shadow, but still the problem with unwanted rasterizing of type persisted!

It turned out, that on two vector logos i had enabled outer glow, but set it to 0% opacity (didn't use it at all :). Once disabled, the issue was completely solved.

What a headscratcher, ey?

Link to comment
Share on other sites

  • 6 months later...

When you export the PDF, on the EXPORT... dialog, choose PDF, and next to the Export button you have More button, for further options.

It opens a new window, and there you have the option Rasterize, that probably is set to "everything". Set it to "Nothing". You should be good to go.


It worked for me :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.