Jump to content

Blur on layer with blend ranges


Recommended Posts

  • Create document with Document/Transparent Background set, and a layer with black and white.
    • Set Blend Ranges, adjust left graph so you can see transparent background checkerboard.
  • Add Gaussian Blur as child layer.
    • Adjust radius. 
    • The moment radius goes off zero, the transparent background goes white.

This effect does not happen when blur layer is above pixel layer.

Example file attached.

blend ranges and blur.afphoto

Dave Straker

Cameras: Sony A7R2, RX100V

Computers: Win10: Chillblast i9 Custom + Philips 40in 4K & Benq 23in; Surface Pro 4 i5; iPad Pro 11"

Favourite word: Aha. For me and for others.

Link to comment
Share on other sites

I think this might be another symptom of the known bug handling alpha channel with nested layers targeting alpha channel. Did you try on latest beta?

Currently traveling with iPad only, there (1.9.2) i cannot reproduce this issue because of the older bug overshadows your issue.

Workaround: adding a group to the pixel layer, and applying the blur to the group.

 

Edited by NotMyFault
Link to comment
Share on other sites

9 hours ago, NotMyFault said:

I think this might be another symptom of the known bug handling alpha channel with nested layers targeting alpha channel. Did you try on latest beta?

Currently traveling with iPad only, there (1.9.2) i cannot reproduce this issue because of the older bug overshadows your issue.

I tried it with 1.10.0.1127 and it's still happening.

Dave Straker

Cameras: Sony A7R2, RX100V

Computers: Win10: Chillblast i9 Custom + Philips 40in 4K & Benq 23in; Surface Pro 4 i5; iPad Pro 11"

Favourite word: Aha. For me and for others.

Link to comment
Share on other sites

Just now, MEB said:

Hi @dmstraker,
Thanks. There's currently a few reports that may be related with this issue. Let me check their status. I will make sure this is logged in case it's a different issue.

See also other report I've recently added -- also still happening in latest beta.

Dave Straker

Cameras: Sony A7R2, RX100V

Computers: Win10: Chillblast i9 Custom + Philips 40in 4K & Benq 23in; Surface Pro 4 i5; iPad Pro 11"

Favourite word: Aha. For me and for others.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.