Jump to content

Affinity Designer doesn't load up since I updated it


Recommended Posts

Hi there,

I recently updated my affinity designer after being prompted to every I booted up the software. I lazily ignored it for some time and the other day decided to go for the bullet and update the software.

When I click on the application, it shows the loading blue screen near my cursor and then nothing. I have tried restarting my PC and it hasn't changed anything. 

I don't know what to do and require some assistance.

Best wishes,

Amin

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.