Jump to content

All my Affinity programs will not start / load


Recommended Posts

Since I installed the latest version of all 3 programs none of them will start. I get the splash screen for a few seconds then it disappears. I un-installed and re-installed all 3 programs and it's still a problem. I checked for similar issues in the Forum and saw a thread about color management. That's not the problem either. Of course my Windows 10 is up to date along with all drivers. Using the Acer Intel Laptop, i7, with integrated Intel HD Graphics 520.

Please advise.

Also, is there a link to the previous Affinity program install versions that I could use? I can't find a link.

Thank you.

-Frank

Link to post
Share on other sites

Welcome to the Serif Affinity forums.

I would first try the suggestions in the FAQ, if you haven't done so already:

You might also try renaming your user-related application data folders: %AppData%\Affinity\<application>\1.0\ to %AppData%\Affinity\<application>\1.0-x where <application> is Photo, Designer, or Publisher. If they then start, you can recover some of your things like brushes, assets, styles, etc. from the "user" folder within the 1.0-x folder.

If those don't help, and if you purchased directly from Serif via the Affinity Store (not from the Microsoft Store) then you can find older versions of the programs to download and install (after you uninstall the current version you have):

Note that installing an earlier version may cause deletion of assets, brushes, etc. that you have installed, and reversion to the factory-installed set of content. So you may also need to reinstall some of those items from a backup (or make a copy before you do the uninstall, just in case).

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

Thank you for the prompt response. I do not have any of those 3rd party programs and my drivers are current. The log.txt file is never created, it doesn't get that far. I'm going to try previous Affinity installs to see if I can isolate it to a specific version. I have Affinity for about 18 months, but didn't upgrade the versions until recently.

Link to post
Share on other sites

You're welcome.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

I did a few things to isolate the problem. I un-installed all 3 programs, and re-installed previous editions.

All 3 programs work at version 1.8.5 and none of them will start / load at version 1.9.0. That's the threshold that causes the problem. I'll see the splash screen for a few seconds, it disappears, and no log file is created.

What was changed in release 1.9.0 that would cause this?

I can't believe I'm the only user having this problem.

Thanks.

Link to post
Share on other sites

@Frank Asci, Just a couple of throw-away thoughts:

  1.  on the splash screen do you get the message "Loading fonts..."?  I was wondering if it has anything to do with a font issue
  2. I take it that you have tried disabling Hardware Acceleration (OpenCL)?  I realise you can't actually open the program to do it, but you can edit the file %appdata%\Affinity\Photo\1.0\Settings\PerformancePreferences.xml in Notepad for example
Link to post
Share on other sites

What if you install the latest version 1.9.2.1035?

System: AMD Ryzen 5 1600 - 16 GB DDR4 3000MHz - Sapphire RX 5600 XT 6 GB | Windows 10 Pro (21H1 Build 19043.964)
Using Photo, Designer and Publisher V1.9.2.1035
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

If olive oil is made from olives and sunflower oil from sunflower seeds, what is baby oil made from?

Link to post
Share on other sites

1.9.2 fixed my problem, thank you.

Note that when I started this thread 6 days ago, I was using version 1.9.1.979 for all 3 programs. That version was my startup problem. At that time, I believed it was the most current. But I'm not really sure. When I go to your previous versions page, https://store.serif.com/en-us/update/windows/photo/1/, it does not list the dates these version were released. It would be helpful in isolating problems like mine if you included that information on the page.

I installed version 1.9.2.1035 and all 3 programs are working.

For me, 1.9.0 and 1.9.1 caused my startup problem.

Link to post
Share on other sites

If you get the programs from the webstore, they are always the latest retail versions. If you are offered an update in the programs, this is / will be the current retail version. It is actually irrelevant when a version was made available.

And when you go to the update page, the next to last release is always on top.

System: AMD Ryzen 5 1600 - 16 GB DDR4 3000MHz - Sapphire RX 5600 XT 6 GB | Windows 10 Pro (21H1 Build 19043.964)
Using Photo, Designer and Publisher V1.9.2.1035
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

If olive oil is made from olives and sunflower oil from sunflower seeds, what is baby oil made from?

Link to post
Share on other sites

Buenas noches:

 

He comprado los tres programas de vuestra compañía y aunque alguna vez me tienen dado problemas, nunca me había pasado algo como esto. Los he tenido que desinstalar varias veces y aunque ahora, "parece" que el Publisher y el Design funcionan como deberían, es imposible manejar en ningún sentido el Photo, lo único que hace es bloquearse y quedar completamente inútil desde que me descargué la última versión del mismo, y por lo que veo, a varios usuarios más les ha pasado lo mismo.

Tengo todas las actualizaciones de windows instaladas y también he probado a reiniciar el ordenador, ejecutar el instalador como administrador y hacer todo lo que se me ha pasado por la mente, pero no hay manera de hacer que el programa funcione como debería y que sea funcional. Dado que actualmente estoy estudiando una carrera que es de diseño digital, el caracer de este programa en mi portátil me frusta y me dificulta enormemente todos los trabajos y exámenes, por eso quería saber si vais a sacar una actualización que solucione los problemas que está dando Affinity Photo a varios usuarios debido a que ahora se hace imposible trabajar con el mismo, o que solución tengo para tratar de que funcione, porque no se a que más recurrir y estoy bastante desquiciado con el asunto.

Link to post
Share on other sites

Hello @Adrian Villamarín García welcome,

can you please give information about the hardware used and the Windows version? Are all drivers up to date? Is Windows up to date? 

Please press the Windows key + R once and enter %appdata%\affinity\photo\1.0\crashreports\reports. Dump files should be visible here in the event of a crash.
If there are several files, just attach the last two,
 

System: AMD Ryzen 5 1600 - 16 GB DDR4 3000MHz - Sapphire RX 5600 XT 6 GB | Windows 10 Pro (21H1 Build 19043.964)
Using Photo, Designer and Publisher V1.9.2.1035
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

If olive oil is made from olives and sunflower oil from sunflower seeds, what is baby oil made from?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.