Jump to content

Urgent help please with masking problem


Recommended Posts

Hi all

In Photo I quite often create a mask by using the pen tool and clicking on the Mask button in the toolbar but something has gone wrong - every time I do this now, instead of giving me a mask layer like I was expecting, it gives me some other sort of layer.  It says 'Curve' by it and it looks like a mask but it doesn't work like a mask, I can't paint onto it to reveal etc.  I have no clue what is going on, please help!!!  This has broken. my workflow completely and I don't know what I've done - or is it the 1.9.1 upgrade that's broken it?

 

Thanks!

1285895992_ScreenShot2021-03-31at11_54_10AM.png.36c3280875029762d4dda3c5e378fb88.png

Link to comment
Share on other sites

The pen tool is a vector tool and what you got there shown above is a vector cropping mask, thus (Curve). Switch to the arrow selection tool and apply a mask the usual way as a pixel mask (Pixel) then! - See also here this thread (top to bottom) for mask types etc.

 

☛ Affinity Designer 1.10.5 ◆ Affinity Photo 1.10.5 ◆ OSX El Capitan

Link to comment
Share on other sites

49 minutes ago, v_kyr said:

The pen tool is a vector tool and what you got there shown above is a vector cropping mask, thus (Curve). Switch to the arrow selection tool and apply a mask the usual way as a pixel mask (Pixel) then! - See also here this thread (top to bottom) for mask types etc.

 

If I switch to the arrow selection tool the Mask / Selection buttons disappear.  This is really annoying!!  OK thanks for your help

Link to comment
Share on other sites

58 minutes ago, v_kyr said:

The pen tool is a vector tool and what you got there shown above is a vector cropping mask, thus (Curve). Switch to the arrow selection tool and apply a mask the usual way as a pixel mask (Pixel) then! - See also here this thread (top to bottom) for mask types etc.

 

OK so thinking about it more, I feel pretty stupid now.  I have been away from work for a couple of weeks holiday and got my own workflow confused when I got back.  Oops.  Thanks 🙂

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.