Jump to content

Recommended Posts

Hello, 

I have problem with upgrade I cannot solve.

I am trying to upgrade from version 1.7.3 to 1.9.1. This is impossible on my laptop as I get setup failed.

Logs say nothing to me (6 lines tail of the 😞

+Starting MsiOperation
+MsiOperation result: 2
+Setting result page message: Setup failed
+Switching to page: Result
+Operation finished
+Main window close requested

I was able to catch minidump of the upgrade executable (I unpacked the distribution and manually ran App.exe file).

I tried to upgrade .Net framework (install SDK) as well as install new graphic card drivers with no result.

Could you please give me any hint I can use to be able to upgrade?

 

 

SetupUI_2021-03-24_22-38-15.png

App_exe.5948_minidump.dmp

Edited by Forseti
no signature needed
Link to post
Share on other sites
Posted (edited)

Hi, all

The update from me is I managed to run App.exe (from unpacked installer file affinity-photo-1.9.1.exe) without crashing. It means I have now standalone version of Affinity Photo 1.9.1 but I am unable to run setup in the form of: SetupUI.exe /x=544 /y=257 /Operation=Install /InstallPath="C:\Program Files\Affinity\Photo" /WantShortcut=True which is invoked during normal update process.

I was thinking about uninstalling previous version I have: 1.7.3 but I am bit afraid 1.9.1 will stop working for some reason (some registry settings?) and I will stay with nothing...

Still, I would appreciate any hints or ideas from your side

(I am aware of this section in FAQ: [FAQ] Installer Errors, Setup Failed & Installer Windows UI Issues but this didn't help me).
(I am using Windows 7 Home Premium OS)

Edited by Forseti
Link to post
Share on other sites
  • Moderators

We've just released 1.9.2. I would download this update and see if you get the same issue. If you do, please sent me your setup log files or use the Microsoft's Uninstall Troubleshooter app to remove the old version first: https://support.microsoft.com/en-us/topic/fix-problems-that-block-programs-from-being-installed-or-removed-cca7d1b6-65a9-3d98-426b-e9f927e1eb4d

Link to post
Share on other sites

Hello, thank you for the information.

 

The problem with 1.9.2 version is the same. 

1. I used trouble shooter to uninstall previous version of Affinity.

2. I chose default location for installing Affinity as it cannot find any Affinity Photo app installed in the system (also chose non-default location C:/Affinity; also tried to turn antivirus off during installation).

3. Setup failed.

I am attaching setup log file.

I can still unpack the distribution and run App.exe which works fine - I have kind of standalone distribution then.

SetupUI.log

Link to post
Share on other sites

Hmm, your system version is listed as VER_PLATFORM_WIN32_NT, so Windows 7 with SP1 (...according to the dmp file), is it a 64-bit Windows 7 version you are running? - If yes, you probably may need to update your Windows 7, with the Windows 7 Service Pack 2 (64 Bit) and then give the installation a retry.

☛ Affinity Designer 1.9.3 ◆ Affinity Photo 1.9.3 ◆ OSX El Capitan

Link to post
Share on other sites
34 minutes ago, v_kyr said:

you probably may need to update your Windows 7, with the Windows 7 Service Pack 2

I don’t think there’s anything named ‘Service Pack 2’ for Windows 7 (not officially, anyway).

Users of Windows 7 need not only SP1 but also the Platform Update in order to be able to install and run recent versions of the Affinity apps.

Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows 1.9.2 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.9.2 • Designer for iPad 1.9.2 • iPadOS 14.4.2 (iPad Air 2)

Link to post
Share on other sites
  • 4 weeks later...

Hi,

(Sorry for a long pause but I didn't want to mess up with Windows when remote school was in place...)

I installed windows7 "service pack 2" (file: windows6.1-kb3125574-v4-x64_2dafb1d203c8964239af3048b5dd4b1264cd93b9) but it doesn't change anything. I still get the same error as usually: setup failed. I am attaching log file. 

Are you really supporting Windows7 installation ? Did you try to install Affinity on Windows 7 computer by yourself anytime recently using version 1.9.x ? Maybe Windows7 is unsupported as for today and you are just unaware of it ?

SetupUI.log

Link to post
Share on other sites
7 minutes ago, Forseti said:

I installed windows7 "service pack 2" (file: windows6.1-kb3125574-v4-x64_2dafb1d203c8964239af3048b5dd4b1264cd93b9) but it doesn't change anything.

From https://support.microsoft.com/en-us/topic/convenience-rollup-update-for-windows-7-sp1-and-windows-server-2008-r2-sp1-da9b2435-2a1c-e7fa-43f5-6bfb34767d65:

Quote

We intentionally did not include any specific post-Service Pack 1 updates in convenience rollup 3125574 for which the following conditions are true:

  • They don’t have broad applicability.
  • They introduce behavior changes.
  • They require additional user actions, such as making registry settings.

You may download and install such fixes manually after you determine whether they apply to your deployment scenarios.

 

Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows 1.9.2 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.9.2 • Designer for iPad 1.9.2 • iPadOS 14.4.2 (iPad Air 2)

Link to post
Share on other sites
  • Moderators
On 5/3/2021 at 12:09 PM, Forseti said:

Hi,

(Sorry for a long pause but I didn't want to mess up with Windows when remote school was in place...)

I installed windows7 "service pack 2" (file: windows6.1-kb3125574-v4-x64_2dafb1d203c8964239af3048b5dd4b1264cd93b9) but it doesn't change anything. I still get the same error as usually: setup failed. I am attaching log file. 

Are you really supporting Windows7 installation ? Did you try to install Affinity on Windows 7 computer by yourself anytime recently using version 1.9.x ? Maybe Windows7 is unsupported as for today and you are just unaware of it ?

SetupUI.log 7.68 kB · 4 downloads

Our apps should install on Window 7 without any issues. I know it sounds simple but have you tried restarting your machine and trying again? The log points to PendingFileRenameOperations which often get resolved by restarting the machine.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.