Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts

  • Staff

My apologies for the delayed response here @Washishu, it appears as though I did not receive a notification for your last reply!

2 hours ago, Washishu said:

As told above, I placed the afreg(1).cfg file in the Support folder and it changed nothing—still get the We're sorry… screen.

Can you please provide a screenshot of the exact folder you have moved/copied this file into? As mentioned in my previous post -

On 2/22/2022 at 10:38 AM, Dan C said:

I can confirm the folder location is -

~/Library/Application Support/Affinity Designer/

You should also try rename the file to be afreg.cfg, removing the (1) from the file name, as this may be interfering with the Affinity apps ability to read the file.

Many thanks in advance :)

Link to comment
Share on other sites

  • Staff

Hi @MLE,

Welcome to the Affinity Forums :)

Sorry to hear you're having trouble!

In regards to registering the Affinity app, we'll need to move the attached .cfg file into the correct hidden folder for Affinity to detect this.

If you open Finder, you should see the top menu bar on your Mac now has Finder options, if you hover over the Go menu, and hold down the Alt key, you should see that Library appears as an option in the list. Selecting this with the Alt key held down should launch an 'elevated' version of Finder, with no folders hidden.

Once opened, navigate to the below folder -

~/Library/Application Support/Affinity Publisher/

You should see other files/folders here already, such as a 'user' folder. Simply copy and paste the afreg.cfg file into the 'Affinity Publisher' folder and restart the app.

In regards to our tutorials, these are hosted on Vimeo.com, which I believe is blocked in certain geolocations. Can you please confirm for me, what region are you currently in? Does the below page display correctly and allow you to view any tutorials?

https://affinity.serif.com/tutorials/publisher/desktop/

Many thanks in advance!

afreg.cfg

Link to comment
Share on other sites

  • 3 weeks later...

I try and try...but I cannot get Affinity Designer to be able to register..

Although putting the afreg.cfg file in place the app won't let me register. 

System: Mac OS 12.3.1, Affinity Designer 1.10.5 (Mac App Store) on a M1 Max MacBook Pro. By the way - I also use the apps on my Intel iMac Desktop without issues in registering....

Also on the system Affinity Photo 1.10.5 (Mac App Store) and Affinity Publisher 1.10.5 (Serif store). they both work without issues in registering!

Any help?

Application_Support.jpg

My_Account.jpg

Link to comment
Share on other sites

  • Staff

Hi @Nightshade,

This indicates a problem with the data file used for this service. Looking in the "user" folder (visible at the far right of your screenshot), is there a file named ws.dat? If so, please close the app, rename the file to ws.dat.bak, then re-open the app and try again.

If this fixes the problem, would you be willing to send over the ws.dat.bak file for analysis if we provide a Dropbox link?

If not, please provide the full path to the Application Support directory shown so we can work out why that data file isn't being created properly.

Thanks :)

Link to comment
Share on other sites

  • 2 months later...

I have a similar problem with Affinity Designer, on the Mac OS X 12.4 only have a different structure of the path. of the program Affinity Designer version 1.10.5
with Affinity Photo, Publisher I have no problems with the login. 
Where can be buried the error ?

Thanks a lot
with kind regards
 

Link to comment
Share on other sites

I bought the software through your website. My operating system is OS X 12.4
The registration error mentioned here in the forum, with the designer still exists with the software version 1.10.5. here is one of the known screenshots

 

Where can I register Affinity Designer online?
to see if it works ?

CCEC18F8-BB59-4755-BD46-5CFD028AC7B3.png

Bildschirmfoto 2022-06-30 um 21.26.01.png

Link to comment
Share on other sites

  • Staff

Hi @Schuberth - I'd like to try checking something in your system installation.

Could you do the following:

  1. Go to Designer's Preferences
  2. Under "General", click the button to open the Lens Profiles folder in Finder
  3. Type ⌥ + ⌘ + C to copy the full path of the folder to the clipboard
  4. Post that path here, or you can PM it to me

Cheers

Link to comment
Share on other sites

  • 1 year later...

Try Creating Missing Folder if Missing

I purchased Affinity software many years ago and installed it on an older Mac Book. I wanted to install it on a newer device, but I had to sign in first. I couldn't sign in because I never registered my purchase/product. I fired up my old Mac where it's installed, and I received the same error messages in this thread--Hello. My old Mac runs High Sierra and can't be updated any further than that. For me, the "Affinity Photo" folder, where this thread says to copy the file "afreg.cfg" (where in other cases the file might need to be copied to "Affinity Publisher," "Affinity Designer," etc.), didn't exist--so, I created the folder "Affinity Photo", then I copied the "afreg.cfg" to it. I started my Affinity Photo software, tried to register, and this time it worked!

I see missing folders in some of these previous posts too, and hope that this might help someone in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.