Jump to content

Recommended Posts

On a printout from a PDF created in Designer, the art graphics are more clear and have deeper color where a .PNG image with transparency is than other areas beyond the edge of the .PNG image. In the .afphoto file, line art is in a layer below the .PNG image. I have version 1.9.1 on PC desktop running Win 10 and printing with an HP Laser Jet Pro. I've attached a detail image taken of the printout. What's going on? Is this a bug?

Roger

Print of PDF card.jpg

Link to post
Share on other sites

Does the image look correct in Affinity Photo, are the darker areas not present in the .afphoto file?

Are you sure those darker areas are completely transparent?

iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to post
Share on other sites
4 hours ago, sharpart said:

What's going on?

The image/portrait shines through circular segments. Set their opacity to 100%.

Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.5.703.
Windows 10 Pro, Version 20H2, Build 19042.610.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Link to post
Share on other sites

Use a Mask for the image rather than relying on PNG's transparencies. Latter very, very often causes trouble—that's not an Affinity problem. PNG was initially meant to be used for digital purposes only, not for print (i. e. one of the problems is that PNGs don't support CMYK).

»A designer's job is to improve the general quality of life. In fact, it's the only reason for our existence.«
Paul Rand (1914-1996)

[DISCLAIMER: Don't wonder about me probably giving the same answer as user R C-R. I blocked his comments, so my reply is not an intentional copied answer as I couldn't see his posts.]

Link to post
Share on other sites

Thanks Firstdefence, the segmented border is not in afphoto it is in afdesign. So, no, the artifact is not visible on-screen.

Thanks Psenda, all layers are at 100%.

Thanks Andy05, I have tried what you suggested. I used a mask to create the transparent area, exported a new .png, placed it into afdesign, print has same issue. I tried exporting image as a .tiff vs. .png, same issue. Also imported the afphoto, same issue.  What I finally had to do was, remove the segmented border from afdesign, paste it into the afphoto under the portrait, then place that afphoto into the afdesign. The downside is that the segmented border is now a raster image vs. vector graphics.

Link to post
Share on other sites

I'm not sure if I understood you correctly. You masked the circle with the image, exported it as PNG and imported it again? That doesn't help, it'll cause the same issues as it's again a PNG with transparent areas.

Instead, mask the image and put it—inclusive mask—into your designer file. There's no need to export it as PNG as additional step in between.

 

»A designer's job is to improve the general quality of life. In fact, it's the only reason for our existence.«
Paul Rand (1914-1996)

[DISCLAIMER: Don't wonder about me probably giving the same answer as user R C-R. I blocked his comments, so my reply is not an intentional copied answer as I couldn't see his posts.]

Link to post
Share on other sites

Like Andy05 says...
image.png.27116f4c696dc3f8cc3f8835376081b2.png

Girl.afdesign

iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to post
Share on other sites
4 hours ago, sharpart said:

...Also imported the afphoto, same issue.

Yes, I was importing the PNG before I got smart. However, even after importing the AFPHOTO directly, and then exporting a PDF and printing, it displayed the same artifact. 

Nice job, Firstdefence. That's what my AFDESIGN and PDF look like. The printout, not so. 

Link to post
Share on other sites
1 hour ago, sharpart said:

That's what my AFDESIGN and PDF look like. The printout, not so. 

Don't want to insert a *.afdesign file here?

Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.5.703.
Windows 10 Pro, Version 20H2, Build 19042.610.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Link to post
Share on other sites

I open your afdesign file, and export to png.
Except for the poorly erased corner in the photo, it looks good - no transparency on the segments.
image.png.9a44dc31bde66468af26ff2b3e56b499.png

But from the position of the GOLD text compared to the photo, it is a different image than the one in the first screenshot.

Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.5.703.
Windows 10 Pro, Version 20H2, Build 19042.610.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Link to post
Share on other sites
14 hours ago, sharpart said:

Yes, I was importing the PNG before I got smart. However, even after importing the AFPHOTO directly, and then exporting a PDF and printing, it displayed the same artifact. 

Nice job, Firstdefence. That's what my AFDESIGN and PDF look like. The printout, not so. 

If you print that out it won’t show the marks you see in yours because of the clipping shape

iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to post
Share on other sites

Sorry, I don't follow. 

6 hours ago, firstdefence said:

If you print that out it won’t show the marks you see in yours...

If I print what out?

6 hours ago, firstdefence said:

...because of the clipping shape

The clipping shape is circular in mine (and yours it appears).  HOWEVER, I do see something I missed in your post with the image of the girl. You created your clipping mask in Designer, right? I created mine in Photo. Is that significant?

Link to post
Share on other sites
17 minutes ago, sharpart said:

You created your clipping mask in Designer, right? I created mine in Photo. Is that significant?

Yes.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites

 

12 hours ago, sharpart said:

The clipping shape is circular in mine (and yours it appears).  HOWEVER, I do see something I missed in your post with the image of the girl. You created your clipping mask in Designer, right? I created mine in Photo. Is that significant?

I fail to see any significant difference between a shape/curve being created in Affinity Photo or Affinity Designer and used as a clipping mask.

A shape/curve used to clip an image to that shape/curve is no different whether it was created in Affinity Designer or Affinity Photo, it remains a shape/curve and the image parts that are outside the shape/curve bounds are hidden from view.

The online help files are pretty much the same regarding clipping.

Affinity Photo: https://affinity.help/photo/English.lproj/pages/LayerOperations/clipping.html

Affinity Designer: https://affinity.help/designer/English.lproj/pages/Layers/layerClip.html

iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.