Jump to content

Recommended Posts

Hi,

This is driving me nuts...

I do a text frame, then move it around for a while to place it where I want, then I create a rectangle and try to snap to the baseline grip of the text frame. It won't snap.

If I don't move the text frame maybe it snaps for a while but then when one move the rectangle it doesn't snap.

I attach a screenshot and the file itself for someone to try. Hope I'm doing something wrong and that this is not a bug.

The systems I use: 

Affinity Publisher 1.9.1

Mac OS: 11.2.3 (20D91)

iMac (Retina 5K, 27-inch, Late 2015)

 

Captura de Pantalla 2021-03-12 a la(s) 15.33.25.png

Baseline Grid on Text Frame.afpub

Link to post
Share on other sites

I am fairly certain the Baseline Grid in the Text Frame is for text only, and anything that is pasted into the text stream. Snapping to the baseline grid works on the Page's baseline grid for your rectangle.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites
5 minutes ago, Old Bruce said:

I am fairly certain the Baseline Grid in the Text Frame is for text only, and anything that is pasted into the text stream. Snapping to the baseline grid works on the Page's baseline grid for your rectangle.

Thanks for your reply @Old Bruce. But objects should be able to snap to the baseline grid of a text frame.

Please have a look at the post below that confirms what I'm saying. Before the link though, I leave a screenshot of the post that shows what I'm talking about. 

 

Captura de Pantalla 2021-03-12 a la(s) 17.17.47.png

Link to post
Share on other sites

You'll need to play with the Screen tolerance settings. With settings like this (screen tolerance 4)

1764275292_Screenshot2021-03-12at21_49_29.png.33ad654c80549fbf797fa22b97a9fbd1.png

I can definitely snap to the baseline grid of a text frame but it's not a positive click. Yours is 3, which is probably why you're not getting the snap.

With settings like this (Screen Tolerance 50):

274946475_Screenshot2021-03-12at21_54_48.png.4d70d710334376b454f07e9175cbd384.png 

I get a hard snap to the text frame's baseline grid. 50 may be excessive, you'll have to choose a value that suits your screen.

Cheers,

H

Affinity Photo 1.9.3,  Affinity Designer 1.9.3, Affinity Publisher 1.9.3, Mac OSX 11.2, 2018 MacBook Pro 15"

Betas as they happen... 

Link to post
Share on other sites

Hey @martinfdc

Tried your upload and I see what you mean. I think I probably just got lucky with my original settings.

There are so many conflicting guides/margins/tolerances operating in the app (not your doc) that it's hard to know what to suggest - it seems to vary by zoom as well as by tolerance.

So on reflection my approach would be to set the baseline grid for the document, aligned to the top margin, at a multiple of your default text leading. Don't set a baseline grid for individual text frames, instead use text controls (Leading/Align to baseline grid in the Paragraph panel) to control the vertical alignment of text within the frame. That way you can snap the text frames to the document baseline grid, and your vector shapes, picture boxes, and most importantly text, will all align to the same grid.

All of which leads me to wonder if the baseline grid setting for text frames is meaningless/useless, as baseline grid should be set at page level. Discuss...

 

Affinity Photo 1.9.3,  Affinity Designer 1.9.3, Affinity Publisher 1.9.3, Mac OSX 11.2, 2018 MacBook Pro 15"

Betas as they happen... 

Link to post
Share on other sites

There's something corrupt with the particular text frame. The rectangle snaps to "a" baseline grid, but it's slightly off, not the visible one.
If I create a new text frame, the rectangle snaps correctly to its grid.

Link to post
Share on other sites

Alright, it's a bug. (Surprise, surprise.)

If you move the text frame, its virtual snappable baseline grid remains at its initial position. The rectangle still snaps, but not to the visible grid.
If you align the text frame to the rectangle bounds first, it will snap to the visible grid again.
If you change the grid spacing, you will have to align again because the snappable grid origin is stuck at its initial position and doesn't move with the frame.

Duh.

Link to post
Share on other sites

As loukash has pointed out the bug is obvious after the moving of the text frame.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.