Jump to content

Startup performance 1.8.6 (and 1.9.0, 1.9.1)


Recommended Posts

  • Replies 126
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Updated to Version 1.9.2 hoping that the weird long delay program launch would be resolved. Are you guys running low on capital?  Does your software engineering team not think this is something that i

Readers, From a number of reports it seems the work around of making a copy of your application may have been "blocked" from working by a recent macOS update. If so it's no longer a suitable work

@Patrick Connor Version 1.9.2 is still showing the painfully slow start-up - seen this since November 2020 now... I've made numerous copies of the apps since that was discovered as a workaro

  • Moderators

Hi @MarcV, @GrinningShark, @Pattebaer,
Welcome to Affinity Forums :)
Thank you all for reporting this issue. v1.8.6 does take a lot longer to start than the previous version. Are you all using the Mac App Store version?
Issue logged to be looked at.

Link to post
Share on other sites

Very quick start up for me. Much faster then before, however I am not running the AppStore version, but use the download from the website.

iMac 27” 16 GB,  2 TB fusion. Running Big Sur.

Do have serious problems with the Extensions for Photo’s though. (Posted a topic in this forum about that).

Link to post
Share on other sites
3 hours ago, MEB said:

Hi MacGB,
This issue only affects the Mac App Store version on macOS Big Sur. The Affinity Store version and Betas all start fast as usual.
Will have to take a look at the extensions. Thanks for bringing it up.

Not only on MacOS Big Sur. I have this issue on MacOS Catalina with the Mac App Store version.

Link to post
Share on other sites

I'm seeing the same issue. I counted some 34 bounces of the icon before the UI appears on first launch. It is at least much faster on the second startup. This is on a Mac Pro 3.3Ghz 12 core, 96Gb RAM and 4Tb SSD running Big Sur 11.0.1. And, in common with the mentions above, this is using the Mac App Store version.

Link to post
Share on other sites

Not sure if it will help, but I noticed that this happens consistently after a fresh reboot and so I decided to do a few reboots and then launch Affinity Designer and Photo after the system rebooted.  Both of them were very slow, sometimes taking >10 seconds before the application started up.  Subsequently launches are much faster (1-2 seconds).  As soon as I rebooted, the first launch was really slow again.  I kicked off Activity Monitor and noticed that SYSPOLICYD was chowing on the CPU on that first launch of each and it kicked in right as I clicked on the application in the dock.  Not sure if this will give you another clue to help determine the source of the problem.  Subsequent launches do not appear to trigger SYSPOLICYD like the first launch.

Link to post
Share on other sites

In my case, all three programs start as fast as always (maybe even a bit faster, but that can also be a subjective impression). After initial difficulties with the download from the MAS everything went smoothly today. (iMac 2017, Mac OS Mojave 10.14.6)

Cheers, Puck

(iMac 2017, 16 GB RAM, Intel Iris Plus Graphics 640 1536 MB, MacOS 10.14.6 Mojave)

Link to post
Share on other sites

Is there any chance to step back to AP 1.8.5 or 1.8.4 with the App Store Version and Big Sur? I have to retouch some Pictures for a client and it seems that my retirement will be faster then the end of the project. Also storing/exporting PSD takes 2 up to 5 cups of coffee. 

Thx for your support.

Link to post
Share on other sites
  • Moderators

Hi @Pattebaer,
Welcome to Affinity Forums :)
The Mac App Store doesn't offer any mechanism to revert to an older version. Unless you have a Time Machine backup (or a regular backup), there's no way to step back to a previous version.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.