Jump to content
Sign in to follow this  
Rory Mole

Table of Contents Adds blank spaces and numbers

Recommended Posts

Hi there,
I think I've found a bug in Affinity Publisher's Table of Contents process.
After compiling sections with only Heading 1 entries in a book that I am laying out, when running the Table of Contents it adds a couple of blank spaces in between entries.
I'm not sure why this is happening, but I found this out today in Version 1.9.1.

Share this post


Link to post
Share on other sites
2 hours ago, Rory Mole said:

I'm not sure why this is happening,

If you're using the standard TOC text styles, and other standard Publisher text styles, then:

  • TOC 1: Heading 1 is based on TOC 1: Entry
  • TOC 1: Entry is based on Base
  • Base specifies a "Space After" value of 12 pt.

To fix your issue, you can edit TOC 1: Entry in the Text Styles panel (while your text cursor is in the TOC), and change its Paragraph, Spacing, Space After setting from "No Change" to 0.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.2.1035 and 1.9.2.1005 Beta   / Affinity Designer 1.9.2.1035 and 1.9.2.1005 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Share this post


Link to post
Share on other sites

Hi there Walt,

Thanks very much for your reply.
I thought to take a screen shot of the problem that I am having.  
Maybe you can make something out of this.

 

Screenshot 2021-03-05 at 16.35.40.png

Share this post


Link to post
Share on other sites

Hi again Walt,
I just made a minor adjustment to the headings of one or two of my chapters, but still the two gaps with page numbers are present in the TOC.

Here is a screen shot of my whole UI

Screenshot 2021-03-05 at 16.45.21.png

Share this post


Link to post
Share on other sites

Thanks. Those screenshots help :)

Best guess: You've got a blank Heading 1 on those pages. Find and Replace might help you find it. If you click the cog to the right of the Find box you can choose a paragraph style to search for.

If that doesn't help, I'd need to see at least those two pages as a .afpub file for further diagnosis.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.2.1035 and 1.9.2.1005 Beta   / Affinity Designer 1.9.2.1035 and 1.9.2.1005 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.