Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Affinity Photo Customer Beta (1.9.2.228)


Recommended Posts

  • Moderators

Status: Beta

Purpose: Fixes

Requirements: Purchased Affinity Photo

Mac App Store: Not Submitted

Download ZIP: Download

Auto-update: Available

 

Hello,

We are pleased to announce the immediate availability of the second build of Affinity Photo 1.9.2 for macOS.

If this is your first time using a customer beta of an Affinity app, it’s worth noting that the beta will install as a separate app - alongside your store version. They will not interfere with each other at all and you can continue to use the store version for critical work without worry.

This beta is an incremental update to the 1.9.1 version recently released to all customers (although it still installs parallel to the released version, as described above). We recommend that you use this beta in preference to the store version if you are affected by any of the issues listed below.

Affinity Photo Team  :ph34r:

 

Changes Since 1.9.2.227

 

- Fixed issues introduced in build 227 for users with multiple GPUs.
- Fixed occasional screen corruption introduced in build 227.
- Fixed potential deadlock issue when loading large files.
- Fixed assorted small registration page issues.
- Fixed the size of the “General” section in preferences.
- Fixed localisation issues in preferences.
- Fixed inability to add / rename / delete export presets.
- Fixed issue where UI would remain hidden when a studio page was enabled from the menu.
- Assorted small fixes.
 

Changes Since 1.9.1

 

- Hardware acceleration has been improved to better make use of Metal (specifically to batch commands together into chunks, which gives the driver a better chance to optimise commands and provides a higher degree of abortability). The benchmark has also been tweaked to use multiple command queues for the Single GPU test, which makes it more representative of “real world” use.

This change affects both real-world performance and benchmark score. The benchmark version has been changed to 1920 - this means that results from this build should not be compared to results from previous builds with benchmark version 1900 (other than to measure the improvements which these changes yield). Once the iPad and Windows builds have been validated with these changes and new beta builds produced, a new forum thread will be created for 1920 benchmark results.

- Assorted performance improvements for assets.
- Assorted content download improvements and fixes.
- Added ability to optionally sort brushes by name.
- Improved performance of export and merge visible, especially in documents with Live Filters.

- Fixed a crash when using File -> Share after File -> Export.
- Fixed a bug where some Live Filters would appear to move after save / load.
- Fixed a crash when opening a brush category context menu with no selection.
- Fixed a bug which caused adjustment to fail to apply easily when clicking with a stylus.

- Assorted other small fixes.
- Localisation improvements.

Link to comment
Share on other sites

Thanks for the continued efforts people. 

iMac 27" Late 2019 Fully Loaded and running Monterey 12.6.1, iMac 27" Late 2013 running Catalina 10.15.7 - Affinity Designer, Photo & Publisher V1 & V2, Adobe, Inkscape, Blender, C4D, Sketchup + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to comment
Share on other sites

Thanks for the efforts, indeed! AP became more and more robust over time, linked layers functionaly is just a bomb :) Really cool and time-saving stuff!


Still, some glitches with fill/adjustments masks are really annoying //


I have a template file with many groups with predefined adjustments. I resize this template to "production dimensions" every time i start a new project. And now, with 1.9.1/1.9.2 i have to iterate over every fill & adjustment layer in this file (adjustments masks are also broken sometimes, with the same steps) and reset them back to white manually //

This happens in rgb8 mode too, but not so often. With rgb32 this is 100% reproducable.
 

Link to comment
Share on other sites

v 1.9.2.228 - macOS Big Sur, v11.2.2, 16in MacBook Pro.

A minor interface bug/fault - in the L*a*b* color picker interface, the a* color slider shows a gradient from cyan to magenta, instead of green to magenta.  Using the MacOS Digital Color Meter, the color values on the negative end of the a and b sliders are essentially identical, i.e., cyanish, which is ok for the b* slider, but not for the a* slider.

kirk

EDIT: This fault is also present in the current App Store version, v 1.9.1.

 

Screen Shot 2021-03-08 at 8.14.43 PM.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.