Jump to content

Recommended Posts

Since the 1.9.1 update, launching adjustment (Levels, White Balance, etc.) can require up to 40 clicks before the adjustment box launches. I have tried the rasterize and trim option in layers, constantly saving the document before trying to select an option, but nothing seems to solve this. I am using macOS Big Sur, v. 11.2.2 on an iMac.The issue was happening before Apple did an incremental OS update last week. Having to click up to 40 times per adjustment function has destroyed my productivity. I looked through Affinity preference categories to make sure I haven't changed anything but there aren't any direct options for layer adjustments.

BTW, using the filters via the drop down menu also behaves wonky. Sometimes the selected change/adjustment is ignored and sometimes it works fine. I never had trouble using that filter adjustment portal previously. My usual working approach is to launch Affinity Publisher and then switch back-and-forth between the three personas. Before sending this bug report I tested the problem by launching my document directly with Affinity Photo, instead of within the Publisher suite method, and to my surprise adjustment panels launch either on the first click or second. Good work around but that negates the benefits of the connectivity within Publisher.

Screen Shot 2021-03-02 at 2.46.00 PM.png

Link to post
Share on other sites
  • Moderators

Hi @ricktuma,
Welcome to Affinity Forums :)
You have the studio panels undocked (separated) from the main application window. Can you please attach them back in Affinity Photo (or go to menu View > Studio > Reset to reset the panels to their default locations/docked position) and try clicking the adjustment's presets again please? Do they work for you while docked?

Link to post
Share on other sites

Hello since the 1.9.1 update the adjustment pop up is not showing and when I click on the presets they do nothing as well. Then when returning to layers.. No new layer added. I have tried in single and dual mode and have gone to view studio > reset... nothing happened... 

Link to post
Share on other sites

MEB: That seems to have done the trick. Ironically, getting the combined dock and document window was going to be my next question to the gang. As a 25-year Adobe user until subscriptions became their business model, I was used to Adobe Suite maintaining window shapes until I changed them. I got off on the wrong foot with Affinity and didn't know where to look to regain that control. To add to your docked/undocked credibility, when I opened Affinity Photo as a stand-alone program to test the adjustments issue it was completely docked together, just the way I like it. I wondered how the heck this happened? But ... I didn't make the connection when adjustments panels worked perfectly. Thanks! Feeling better about my switch to Affinity, even though I run into other 'Where the heck have they hidden a function?' moments.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.