Jump to content
thomaso

v1.9.2 Resource Manager – various UI issues

Recommended Posts

EDIT: Title updated "1.9.2 …" since all issues, except 9., continue in v192.
====

Still in 1.9.1 the Resource Manager UI appears buggy in various ways:

  1. When a resource is used more than 1x then RM shows it within a folder. If a resource gets selected on page then the RM doesn't select the according entry but the entire folder instead. Makes it quite cumbersome to detect/select a specif layout item in the RM.
  2. Sorting by name doesn't work consistently.
  3. Expanding the window width widens the "DPI" instead of the "Name" column, maintaining cropped file names but useless empty space instead.
  4. The text layout in the details section insists in wasted space to its left but crops long text entries instead, e.g. profile names or dimensions.
  5. Navigation in the entries via keyboard (up/down) doesn't update the details section and requires to mouse-click the entry instead.
  6. Searching for a missing resource doesn't display the missed file name in the following window's title bar and requires instead window moves to make long or complex file names visible behind.
  7. Re-linking a missing resource via RM > Replace doesn't allow to auto-re-link other missing resources in the same folder but requires to re-open the .afpub + "Yes" instead.
  8. [ Re-linking missing resources when opening an .afpub + choosing "Yes" doesn't re-link all missing files even if in the same folder. ]
  9. [ Replacing a resource of a picture frame doesn't maintain the frame properties  <– is already reported in various threads ]

1. When a resource is used more than 1x then RM shows it within a folder. If a resource gets selected on page then the RM doesn't select the according entry but the entire folder instead. Makes it quite cumbersome to detect/select a specif layout item in the RM:
2144562436_v191ResourceManager_layoutselectionisntRMselectionbutfolderinstead.jpg.a498a42164e14f4b7d0f08259e3b8030.jpg

2. Sorting by name doesn't work consistently:
1129609863_v191ResourceManager_sortnamealphabetical.jpg.a210abecb05c2f7ebb0428f8bc313afc.jpg

3. Expanding the window width widens the "DPI" instead of the "Name" column, maintaining cropped file names but useless empty space instead:
1488530842_v191ResourceManager_windowwidthandcolumns.thumb.jpg.0611a37b3fd4b1d7878e255a37f162af.jpg

4. The text layout in the details section insists in wasted space to its left but crops long text entries instead, e.g. profile names or dimensions:
1463716155_v191ResourceManager_croppeddetailstext.jpg.bef7ab5da6a30db1ec720645b482933e.jpg

5. Navigation in the entries via keyboard (up/down) doesn't update the details section and requires to mouse-click the entry instead:
1303672499_v191ResourceManager_selectionvsdetails.thumb.jpg.c37a631196e2e405215e6615b3c25d59.jpg

6. Searching for a missing resource doesn't display the missed file name in the following window's title bar and requires instead window moves to make long or complex file names visible behind:
1660491946_v191ResourceManager_searchwindow1.jpg.2c1db16d31bb48a999b3ff001a8cb246.jpg

1529336020_v191ResourceManager_searchwindow2.thumb.jpg.e354951257b5b91820c5438d5004419b.jpg


7. Re-linking a missing resource via RM > Replace doesn't allow to auto-re-link other missing resources in the same folder but requires to re-open the .afpub + "Yes" instead.
8. Re-linking missing resources when opening an .afpub + choosing "Yes" doesn't re-link all missing files even if in the same folder.
–> see https://forum.affinity.serif.com/index.php?/topic/136142-resource-manger-missing-images-bug/&do=findComment&comment=750650

9. Replacing a resource of a picture frame via RM > Replace doesn't maintain the frame properties  <– is reported for v1.9.1 already in various threads


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Share this post


Link to post
Share on other sites
On 3/2/2021 at 8:09 AM, thomaso said:

Re-linking a missing resource via RM > Replace doesn't allow to auto-re-link other missing resources in the same folder

This one's a big hassle and grinds work to a crawl when dealing with multiple instances of the same resource. Gotta have batch updating/relinking!

Share this post


Link to post
Share on other sites

Does one know what "missing content" means? (appears at a .PDF and a .SVG)

945232968_resourcemanager-missingcontent.jpg.97ca4e7ba6848917869e297ebf6809bd.jpg

Also I want to add a suggestion to the topic's panel improvement list: The column "Status" appears to be redundant if the column "Placement" would be used instead. As far I understand  an Embedded resource never can be Missing + every Modified resource must be a Linked resource.

So it could work to have in "Placement" 4 variables/entries:
_ Embedded (= 'OK')
_ Linked (= 'OK')
   _ Modified (linked)
   _ Missing (linked)

EDIT: "– Modified" added to the variables


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Share this post


Link to post
Share on other sites
On 3/2/2021 at 8:09 AM, thomaso said:

1. When a resource is used more than 1x then RM shows it within a folder. If a resource gets selected on page then the RM doesn't select the according entry but the entire folder instead. Makes it quite cumbersome to detect/select a specif layout item in the RM:

That's not quite right. If you Place an image more than once, they have separate entries in the Resource Manager, and they are separate objects.

You only get the "folder" when you Place the image on a page, and then:

  1. Select it on the page, copy it, and paste it somewhere else; or
  2. Duplicate the page.

In those two cases you have one object, and if you use the Resource Manager to Replace it, or change it from embedded to Linked, etc.,  you affect all the copies because there's really just one object.


-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.2.1005 Beta   / Affinity Designer 1.9.2.1035 and 1.9.2.1005 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Share this post


Link to post
Share on other sites
17 minutes ago, walt.farrell said:

That's not quite right.

To me it is. – Mac only? Can you show your experience on Windows?
In this clip you also see the problem of object selection within the manager: not the selected layout object is accordingly selected in the manager but its folder 'only'.


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Share this post


Link to post
Share on other sites

My experience is the same as @thomaso as I'm also on a Mac.

And when it does show the correct object selected, in the light UI, the highlight color is a pretty subtle distinction among the alternating colored rows.
On further inspection, that's a result of my system highlight color rather than Affinity

Also…what would be the semantic difference between a linked object that has been placed twice vs being copied/pasted twice? Why would the Resource Manager need to distinguish between the two?

 

Share this post


Link to post
Share on other sites
42 minutes ago, walt.farrell said:

if you use the Resource Manager to Replace it, or change it from embedded to Linked, etc.,  you affect all the copies because there's really just one object.

This sounds even more disturbing. Walt, does it mean you can't replace just 1 of 2 instances?
It is possible for me and I assume this behavior as being imperative. Imagine you start an .afpub with some identical images as placeholders to become individually replaced during the layout process. – Walt, isn't that possible for you?


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Share this post


Link to post
Share on other sites
On 4/9/2021 at 8:35 PM, thomaso said:

Also I want to add a suggestion to the topic's panel improvement list: The column "Status" appears to be redundant if the column "Placement" would be used instead. As far I understand  an Embedded resource never can be missing + every Missing resource must be a Linked resource.

So it could work to have in "Placement" 4 variables/entries:
– Linked
– Modified
– Missing
– Embedded

That is a good point, and condensing two columns down to one seems a good suggestion, since here it would be no loss in the amount of information communicated. That leaves extra room for the other columns.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.