Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Affinity Designer - Screen tearing while moving objects and changing color


Recommended Posts

I'm re-posting this issue here because it seems the bug subforum was not the correct one.

-------------------------

This is a fresh installation, although the video shows a 300 dpi document, the same happens in a 72 dpi one.

Things that I've tried that didn't work, I restarted the program after each of them.

- Changing my VSync setting in the Nvidia control panel > manage 3d settings > program settings > affinity designer. It was on "Use the 3D application settings", I've change it to off.

- Changing the renderer from Nvidia to WARP, the tearing went worse.

- Enabling Open CL

- Changing view quality to "nearest neighbor"

- Enabling "Dither gradients" and "use precise clipping" (I don't even know what those are for, I just wanted to try all the settings lol).

I'm guessing this is not the normal behaviour, that's why I'm posting, maybe there are some setting I'm miss to tweak or something like that, I'm also attaching a capture of my performance settings.

Specs:

- Affinity Designer 1.9.0.932 (90 days trial)

- Windows 10 Pro 64 bits

- I3 7100 3.90 Ghz.

- 24 GB Ram

- Nvidia Geforce GTX 1050 Ti 4 GB

- HDD 1 TB (Affinity is installed in my C partition which have 47 GB free from 145 GB total).

6TW9BNpdgy.png

Link to comment
Share on other sites

35 minutes ago, cayenne said:

I saw something similar in a photo I was editing in affinity photo...subtle tearing lines in mine that wouldn't go away and appeared out of nowhere.

 

I shut down AP, and restarted, and the image came up normal again.

I see, I would understand if it were a document with lots of images but my issue appears even in new documents so I don't know what is happening.

Also when taking a screen capture and putting that image inside a Designer document I'm working on it result in whole document becoming slower, suddenly moving object causes screen tearing to new levels.

Link to comment
Share on other sites

  • 2 months later...
  • Moderators

 Hi @Ghost-Order,

Our sincerest apologies for the delayed response here!

I can see that your bug report was closed as 'By-design', which means the QA agent has confirmed this is not a bug or issue with the application and has explained it is due to how Affinity renders the canvas (in 'tiles').

You may find that updating your GPU driver to the latest version provides a slightly smoother experience, but the redrawing you're seeing when zoomed into the object/document is to be expected and I see the same thing here on Windows 10 using a GTX 1070.

I hope this clears things up :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.