Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Recommended Posts

Hello, I recently purchased your software as all the videos showed how well it works for astrophotography. I was particularly impressed with how fast your stacking process was in your videos.

However, each time I use your Astrophotography Stacking process, once I hit stack the whole programme just crashes. I left the programme alone for over an hour. Not even Deep Sky Stacker takes that long.

This is deeply disappointing and contrasting to what your videos demonstrate.

My laptop has a i7 quad core processor too so it's not exactly slow or lacking power.

Please can you provide me with support on this issue?

I have attached a screenshot here (using my phone as I can't grab a screenshot due to your programme crashing every time).

20210224_201733.jpg

Link to comment
Share on other sites

Thanks,

I think I'm just really disappointed as I purchased this software after seeing these new features in Affinity's YouTube videos. The Astrophotography Stack was demonstrated to work so quickly, literally within seconds. I get that there are always bugs but that one felt like false advertising and disingenuous.

 

Anyway, as for fixing the problem. I never turned on the hardware acceleration so that's not the problem.

I also tried limiting the RAM usage as this has been suggested by other users, but that didn't work either.

Link to comment
Share on other sites

  • Moderators

Hey @ds.johnston apologies it's not working for you (I did the videos you are referring to). My experience on both Mac and Windows has generally been successful with both FIT and RAW files. RAW files take longer to register and stack because they have to be debayered—and are typically higher resolution—but I haven't come across any crashing when stacking. The only crashing I've experienced has been when accidentally mixing up pixel binned data—e.g. Bin1x1 light frames but accidentally adding Bin2x2 dark frames.

Do you have any details about the data you are trying to stack you would be able to share? E.g. pixel resolution, number of light frames and calibration frames. In particular, I see you have selected the Bad Pixel Map Tool and presumably the Detect Bad Pixels stage is taking a while—how many dark frames are you using?

It would be useful to clarify this, however:

Quote

However, each time I use your Astrophotography Stacking process, once I hit stack the whole programme just crashes. I left the programme alone for over an hour. Not even Deep Sky Stacker takes that long.

Does the app actually crash (as in completely exit of its own volition) or do you assume it's crashed because the progress bar is still present after an hour?

We are noticing a non-linear increase in stacking time after a certain threshold of light frames are added, which is also dependent on the quality of the frames. The alignment method used is quite slow but accurate and this may be factoring into the time required.

For example, my largest data set so far has been just over 550 light frames—if I stack all of them, the process can easily take over an hour, which is exacerbated by bad frames with star trailing etc. If I use Select Best Light Frames and set the percentage to around 70-80% which rejects probably around 100-150 of these frames, the stacking time reduces to anywhere between 20-30 minutes.

Worth a try if you're actually stacking all of your frames—filter out the bad ones first? As mentioned above, any more information about your data would be useful as well!

 

Product Expert (Affinity Photo) & Product Expert Team Leader

@JamesR_Affinity for tutorial sneak peeks and more

Link to comment
Share on other sites

Hi James, thanks for your reply.

Happy to share details. To clarify, I haven't tried switching off the Bad Pixel Tool Map feature. I hadn't even touched this when it crashed the first time. I pressed that button during another go and the result was the same. When I hit the stack button, a progress bar for Detect Bad Pixel comes up and at this point everything crashes. I can't even get a crash report as I either have to end the programme via Task Manager or the whole computer freezes (can't even access task manager at that point) so I have to turn it off and restart.

After a few attempts, so far the stacking feature cannot get beyond Detect Bad Pixels. 

 

As for the data I'm using:

Light frames = 22 × 4min @ ISO500

Darks = 17 

Flats = 50

Bias = 50

Frames were taken with a Canon M6 mark II which creates CR3 raw files.

So we're talking a short imaging sessions worth of data, which I chose to use just so I could practice with the new software and follow your tutorials. I have already removed the bad frames so those 22 light frames are my chosen frames (I often do this before stacking as you're right - why waste time and computer power on bad frames).

Having already stacked this data in Deep Sky Stacker (sigma clipping), I have an idea how long it can take but your videos (which are excellent btw) do suggest that the stacking feature will take a very short time to complete - it would have been nice to have known what we should have realistically expected from this feature and how long it usually takes (I have read other posts where users are leaving on their computers overnight to complete this process - this just seems a bit ridiculous to me so I'm hoping that the software doesn't require that amount of time to stack as I've never experienced that with Deep Sky Stacker).

I am genuinely excited for this product as the idea of an all in one stacking and processing programme sounds excellent so I'm happy to work to get this resolved.

 

 

Link to comment
Share on other sites

22 hours ago, ds.johnston said:

Thanks,

I think I'm just really disappointed as I purchased this software after seeing these new features in Affinity's YouTube videos. The Astrophotography Stack was demonstrated to work so quickly, literally within seconds. I get that there are always bugs but that one felt like false advertising and disingenuous.

 

Anyway, as for fixing the problem. I never turned on the hardware acceleration so that's not the problem.

I also tried limiting the RAM usage as this has been suggested by other users, but that didn't work either.

I am sorry but as a visual stargazer with a Dobsonian, I can’t offer any further advice. Did the recent upgrade help? After reading posts on Star Gazers Lounge and Cloudy Nights I suspect more Astrophotographers posting here.

Link to comment
Share on other sites

  • 2 weeks later...

I haven't been able to use the stacking feature either. My progress bar doesn't even get as far as the one shown in the image. 😞
I hit "stack", the progress bar appears, and a fraction of a second later AP crashes.

 

Link to comment
Share on other sites

Hi!

There is another thread going on, where someone has crashes when stacking. I'm also observing crashes sometimes. I've added a post to mentioned thread. Would be helpful if someone could come back to the issue as I haven't seen any responses or progress on these threads.

 

Björn

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I just added a post to this thread. 

I also have problems with stacking. Iface that it are the flat frames that prevent the stacking to progress (mac version 1.9.1). light, dark and bias use is fine. Is anything known about that? I am sure it has nothing to do with binning. I checked that.

It is not really a crash, I still can use navigate through the files. But it will not start stacking again, whatever I try (e.g. adding/deleting files in the set). I did not touch the bad pixel options.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

  Hello,

  My Affinity Photo also crashes whenever I try to use the Astrophotography Stacking mode. I have been using this application for one year, usually with 32-bits images and tons of live adjustment layers. I've used James Ritson's macros and done a lot of intensive operations that make my computer churn at full speed and yet Affinity has NEVER crashed so far. There really is something wrong with this new Astrophotography mode.

  In this case, I can add my light frames (I've tried FITS and TIFF), I can tweak the options, but as soon as start the stacking, or if I just try to hide one of the frames by clicking on the eye icons, Affinity crashes. It just shut down without any error message or doing anything.

Link to comment
Share on other sites

It's sad to see that there has been one official response to this post since it was originally posted on February 24th. The astrophotography stack was advertised as a big thing. Now nobody seems to care that it doesn't seem to work as advertised for some folks. Correction - doesn't work at all for some folks. I have no way of telling how big of a problem it is, but the lack of a response is disheartening. I am so looking forward to all the features that won't work in the next version of Affinity Photo.

Link to comment
Share on other sites

  • 2 months later...

Is there any progress on the Astrophotography Stack problem? It's now not working at all for me since the latest version. It doesn't seem to matter what files I use e.g. TIFF, FITS,PNG etc. When I click the Stack button, nothing happens. This is the same on two computers, using different files on each.

If I then click the Apply button, I just get a blank image

I've tried version 1.9.2.1035 on a Windows 7 PC and a WIndows 10 PC

It's very frustating, as every recent feature in Affinity has been geared towards astrophotography, and this is a show-stopper unfortunately

Please get it working again soon!!

Link to comment
Share on other sites

Hello @VulcanUK, welcome to the forums.

Please try the latest beta version of Affinity Photo. The beta includes many improvements.

 

AMD Ryzen 5 5600G | 32 GB DDR4 3200MHz | Sapphire RX 5600 XT 6 GB | Windows 11 Pro 2022 Update (22621.819)
Affinity Suite V2.0.0
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

Yesterday we were on the precipice. Today we are one step further.

Link to comment
Share on other sites

Hi there

I just downloaded this to see if the New Astrophotography Stack problem in 1.9.2.1035 had been resolved. Unfortunately it now seems worse than ever now

If I try and add ANY file to a new AP stack, the program just crashes and instantly disappears

Can you please try and get this reolved? If it's a problem at my end can you please help?

I'm running this on a WIndows 7 HP desktop pc

There doesn't appear to be a crash log

Many thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.