Jump to content

Recommended Posts

Hello, i have also big problems with my assets in Affinity Designer. Is it OK when i write here too about it?

 

  1. Are you using the latest release version? Yes (1.9.0.932)
  2. Can you reproduce it? Affinity Designer Crashes everytime when: 1. after I have added about 3-5 ; 2. after I renamed about 3-5 ; 3. sometimes after i create a new subgroup. I think everytime when I do something that is related to the assets
  3. Does it happen for a new document? If not do you have a document you can share that shows the problem? the error occurs completely independently of the currently opened document
  4. If you cannot provide a sample document then please give an accurate description of the problem for example it should include most of the following:
  •    What is your operating system and version? Windows 10
  •    What happened for you (and what you expected to happen) Affinity Designer crashes (no feedback) and closes without another error message.
  •    Provide a recipe for creating the problem (step-by-step what you did). I try to add new Assets (mostly i want sort my vector datas). After the first few assets the Program stuck with no feedback and crashes without error message. I restart the Designer. A few times it happened that all assets was away. Where i had first time this problem, i didnt make a export/import data and needed to start againn to create all my assets new. After it happened the first time i made a export/import data, and i made two diffrent of them. I hade  a time no problems, but today i started affinity and all of my assets are away again. I tried to import my safety data, but then i get the Error "Error during import :File cannot be imported". It's the same with both of my safety data's. I'm a little bit frustraded about the missing time i used for sort my vectors.
  •    Screenshots (very handy) or a screen capture/video. in the attachment you can find a screen about the issue with my import data
  •    Any unusual hardware (like tablets or external monitors or drives that may affect things) or relevant other applications like font managers or display managers. no i have just installed the designer and photo software from affinity
  •    Did this same thing used to work and if so have you changed anything recently? It was very slow before version 1.9, but I didn't have these problems to the extent that I do now with the new version.

 

I really hope you can help me with this problem. as it is at the moment, i can't use the assets, and i don't darec to create new ones either.

Please let me know when you need something from me.

 

Best regards

 

Nils

 

screenshot.jpg

Edited by frizzle_Bacon
Link to post
Share on other sites
  • Moderators

Hi @frizzle_Bacon 
I've split this into its own thread as it was completely different to the one you replied to.

Are you able to get a video recording showing the steps you're taking to reproduce this please? Unfortunately your screenshot doesn't give us to much info about the steps you're taking and what your actual process is. A video would help us greatly. 

If you could also attach any other files you're using that would also be helpful to us. 

Link to post
Share on other sites

Hello, i'm sorry for posting my problem in the false topic.

I made two videos. In the first video you can see how i try to import my asset data. In the second Video i prepared a new asset list. Because i noticed that it has something to do with the size of the file.

I saw that the storage is on his limit, maybe there is the fault? The rest of my system are CPU i7 4. gen, 16 GB RAM and a GTX 1080. And in general i dont have problems with my computer parts. In my opinion its crazy.

In second Video you can see how long i need to wait for add new assets, or rename a vector. You can't see any crash on the video yet. I think that happens when a certain size of the whole file is reached. But when it crashed, the program will just close without any message. And in worth case all assets are away after i restart the program. I can prepare more assets that we can see the crash in video in the next day if its needed.

The last time i doesnt had a crash. It was just everything away. I think its too seldom that i can make a video from it, but it happened. I dont know, maybe you can restore my asset file i attached?.

 

greets 

Nils

Assets_Shirtbusiness_Sicherheitskopie.afassets Sicherheitskopie_von_Sicherheitskopie.afassets

Link to post
Share on other sites
  • Moderators

Thanks for those files - 

I don't believe this is an issue with the current size of your assets. These files do not import for me, which sounds as though there is more of a problem with these specific files. I'll pass these files over to development to look into.

Do you have any information on the history of these two files? Were they created by yourself, if they were how long ago were they created? If not where were they downloaded from, have you tried re-downloading them from the original source? Were they stored on any form on NAS drive or Cloud drive at all? We have found that Google File Stream can actually interfere with files themselves and cause corruptions.

Link to post
Share on other sites

Hello, both files are created by myself. The both files should be the same. First i created one of them and after that,  i created the other file. I did it in this way, because i thought, when it gives problems with file number 1, i have file number 2.

Both files was just storaged on my desktop. (C:// partition)

The "Assets_Shirtbusiness_Sicherheitskopie" file was created at 07.02.2021. And the "Sicherheitskopie von Sicherheitskopie" was createt at 11.02.2021

You see, that the files has 228 MB. This Asset file is much bigger than my example you can see in the video. Is it normal that the usability becomes slower and slower? It needed much time to rename a asset, add a new vector or create a subcategory.

I would have thought that the performance only starts to slow down by maybe - i dont know - at 1 - 2 gb size. My system should not have any problems with this. (therefore I would not like to exclude it)

Let me know, when you need something from me.

 

Greets

Nils

 

Edit 27.02.2021 - 11:00 am : I updated my Affinity to the new Version 1.9.1 and all my Created Assets was away. (Maybe normal after a update?) But it worked to Import the Asset File.

I made a Video

 

 

 

Link to post
Share on other sites

Hello, I am sorry about posting here again but  I am just frustrated about.

now i created a Design and saved it normally. After i would open it again i got the message in the attached Photo.

maybe you can recover the file?

Edit: I saw that the file has 0 bytes, so i guess there is nothing to recover. But maybe the file can help to find out maybe a bug. 

 

Edit 28.02.2021: The new Example Asset file i made for you is also broke today. i attached it. It was created 24.02.2021. 

2021-02-27_13h50_23.png

0001 in jedem steckt ein wikinger_r.afdesign

new_data.afassets

Link to post
Share on other sites
  • Moderators

Hi frizzle_Bacon,

We're still looking into this but its tricky without your user data. You said the application crash and you restarted and all your assets were gone - do you remember exactly what you were doing when it crashed? Was you adding some objects as an asset or was you exporting your assets to a new file?

Do you now have your Assets Panel repopulated? If so can you go to %AppData%\Affinity\Designer\ and zip up the 1.0 folder  and attach it to our internal Dropbox using the link below:

https://www.dropbox.com/request/sBgyWLdY8APdr3gTUExF

It is important we get this after you've re-added the content. It feels like there is something very specific in your assets that is causing them to export incorrectly and create files that cannot be important. And also possibly causing crashes when attempting to add content corrupting the Assets Panel. Again if you have a specific document that is causing a crash when using 'Add from Selection' to add it to your assets that would be very helpful to get.

Link to post
Share on other sites

The bigger the library gets, the slower all functions around the assets become. Dragging and dropping takes longer and longer, creating a sub-category takes longer and longer. Renaming assets takes longer and longer.
The larger the file gets, the more likely it is that a crash will occur no matter what action is performed on the assets. After this crash the assets are often still there, but after every 10th crash or after a reboot of the system everything is completely gone. The exported assets cannot be imported again in 2/3 cases. I don't think it's a corrupt file because I used completely different vectors just for the example file I created for you. It seems to me that Affinity is overwhelmed with the amount of data. But it also seems to me that I am the only one with such serious problems. I can't shake the feeling that it might be my hard drive, since it's older. On the other hand, I don't have such problems with other applications.
The file "New Data" is exactly the file I created for the video for you. I haven't changed anything since then. In the very last video you can see the first start of Affnity after my example video. Everything was still working at that point. I really didn't do anything more to the assets. I left the file completely alone and the problem still occurred. I can't explain it, but if I'm honest I also almost don't have the nerve anymore about creating a new library for the 5th time by now because it takes a lot of time. I for my part will wait willy-nilly until the system of assets is completely relaunched at Affinity or I just had bad luck. So far few weekends of work have disappeared just like that. Don't hold it against me, but I need to get somewhere else as well.
I like to put my "1.0" folder in your "Dropbox". There are only the extension I bought from Affinity. But the Same error has already happened even with the purchased extensions. So that all the assets from the extensions were suddenly gone after a restart of Affinity, and I had to re-download them. 

Link to post
Share on other sites
  • Moderators

Hi frizzle_bacon,

I appreciate the time you've been putting into this and understand that you just need to get stuff done.

I wanted to update you to let you know what whilst I haven't been able to reproduce exactly the issues you were getting (crashes, empty assets, exporting invalid assets), we have discovered an issue with assets containing lots of raster content that was causing Affinity to eat up a lot of RAM (around 11GB here on my machine) whilst importing, renaming, deleting or re-arranging assets.

This meant that some assets were taking a really long time to rename as you've mentioned, and also when importing some assets, it would hang (as it ate all the memory), so I have a feeling it is this behaviour that was the root cause of the problems you were seeing.

I would appreciate it when you get a moment if you could try importing, renaming and re-arranging your assets with the current 1.9.2 beta available below and see if this has improved the situation for you?

Kind Regards,

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.