Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts

An oddly specific bug I just discovered in Photo - unsure of whether this shows up in Designer too. 

While sketching out an ornate frame design, I used the symmetry tool with a brush, and everything proceeded as usual.
I then used Shift to create a straight line and noticed that the stroke automatically coloured certain parts red - screenshot attached.
I tried a few different brushes and ended up with the same result (as you can see), but only when using my tablet pen/stylus - this didn't happen when clicking with the mouse and holding Shift.
The layers I worked on didn't have any FX applied, and red was not a colour I had selected (my foreground and background colours were black and white).
I've done a quick screen recording for reference: https://youtu.be/blPZMQsAhNQ

It's not embedded as a glitch into the document/file though, as I can easily use a "Colour Overlay" effect to change it back to black.

Screen Shot 2021-02-24 at 12.27.42.png

Link to comment
Share on other sites

5 hours ago, Gabe said:

Hi @ChristiduToit

Sorry for the delayed reply. I think I know what's going on. Can you try and brush with green only (R:0, G:255, B:0) and see if it turns yellow instead of red? 

@Gabe No problem at all - I'm sure you guys are super busy. I appreciate the reply, no matter how delayed. 
Replicating it in a new document was actually quite tricky, but after some tinkering I managed to get it. 

You're 100% right, the green turned yellow. I didn't use the exact RGB green you mentioned though, but it's much of a muchness I suppose.

Screen Shot 2021-03-03 at 22.40.53.png

Link to comment
Share on other sites

  • Staff

Cheers. We seem to be on the right track. The issue we're aware only seemed to have affected the pixel brush. But you were using just the normal Paint Brush tool in your video. Any chance you can export a few brushes that have the same issue and upload them on dropbox: https://www.dropbox.com/request/ZTGwHSbHHyptU1dXwtzi ? I could only replicate it with a very specific brush, and having multiple example would narrow the issue down a bit. My guess is that it's something to do with its image/intensity texture. 

Link to comment
Share on other sites

@Gabe Sure thing! I've just uploaded the brushes via the link and titled them 'Red Line Brushes'.
The first two brushes both have textures, however, the third does not. 
I'm sure it will happen with more than just those three, but those are just the first ones I managed to replicate it with. 
I have noticed that it only seems to happen with intensity brushes, and round and square brushes (at least in my experience) don't seem to reproduce it.

Also, important to note, I've realised that this is actually not related to the symmetry tool at all. 
I clicked around pretty sporadically while holding shift (with the symmetry tool off), and eventually got the red line as you can see below.

(these screenshots are starting to look more and more like modern art pieces 😂)

Screen Shot 2021-03-04 at 10.49.13.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.