Jump to content

Recommended Posts

I created some assets in Affinity Designer. I exported these from Designer, saved to disk, and imported the assets file into Publisher. When I try to use/drag an asset in Publisher, Publisher immediately force crashes. I am using both Affinity Designer and Publisher 1.9 on Apple Silicon (M1).

If I switch to the Designer persona, it still crashes when trying to use/drag an asset. However, if I open the file in Designer, Designer does not crash. If I then try to open the same file in Publisher, Publisher immediately crashes and does not open (!!!).

Update/fix:

I think I figured it out. My assets included artboards (first imported to the asset pane as part of a category and then exported as an assets file). Knowing that Publisher doesn't support artboards, I created a test assets file consisting only of regular Affinity objects--not artboards--such as grouped items. These imported just fine into Publisher without issue. It seems to me that Publisher is trying (and obviously failing) to import an artboard without properly handling that inability, thus resulting in a crash.

Edited by JLAustin
Providing updates

Affinity Designer 1.9 | Affinity Publisher 1.9

Running on Apple Silicon

Link to post
Share on other sites
  • 1 month later...

Hi @SPaceBar, as requested, I have uploaded both the exported asset file as well as the Designer file used to create it. I was able to replicate the issue. In short, trying to use (e.g. drag in) an asset that contains an artboard instantly crashes Publisher. In the case of the files uploaded, I put a piece of text grouped under an artboard, exported that artboard as an asset, and tried to use the asset in Publisher. Instant crash.

It's my understanding that Publisher does not support artboards. I suspect this issue is tied to that.

Affinity Designer 1.9 | Affinity Publisher 1.9

Running on Apple Silicon

Link to post
Share on other sites

Thanks for the files @JLAustin I have now managed to recreate the issue on my Intel iMac and my M1 laptop. I was originally creating my document with a default Master and that wasn't crashing but on your document you didn't have a Master and when I recreated this mine also crashed. 

I will get the issue logged and pass it on to the development team.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.