Jump to content

Recommended Posts

Hi,

I'm new user with affinity photo, so I didn't use previous version of the program.

I'm triying to open a file (.psd) with smart objetc inside. In all cases, when I open the file in Affinity Photo, the smart object appears with a problem like here:

248453605_Capturadepantalla2021-02-15alas8_07_55.thumb.png.a65418791722e66d7fb9f31122298945.png

603016442_Capturadepantalla2021-02-15alas8_05_44.thumb.png.90b6ee9133513c28a439cbe65dbb371f.png

Apparently, the program does not respect the proportions and display of the smart object. That is why it is not possible to modify it and work with the document.

As you can see, the problem is the same with Affinity photo files , where the original document modifies the smart object as well:

616854830_Capturadepantalla2021-02-15alas8_19_45.thumb.png.c0e98ba2ecade58d6f85f28fcbf748f1.png

I suppose that the option should be work, like this https://affinity.serif.com/es/tutorials/photo/desktop/video/393648146/

I tried with different kind of files with smart objects, and always appears the problem.

I can see that other people have the same issue:

In Windows too:

Could be possible to fix that?

Thanks and have a nice day!

Share this post


Link to post
Share on other sites

Hi!

Thanks for your reply.

I attach the document.

However, in my case, the issue appear in every case that I'm trying to open a psd. file with a smart object, not just with that file. I tried to open differents documents using different computers (mac) but always happen the same problem.

Have a nice day!

example_issue_mockup.psd

Share this post


Link to post
Share on other sites
On 2/19/2021 at 4:23 PM, Gabe said:

Hi @Mgn,

Sorry for the delayed reply.

We are aware of an issue caused by the Perspective filter. Can you attach the Psd in question so we can add it to the list?

Hey @Gabe

I am having the same problem. After saving a changed version, I changed my settings back to not open with smart objects to see if it might get rid of the problem, but it made it look even worse.

Have nice!

Share this post


Link to post
Share on other sites

I'm having the same problem after a recent update...  I used to be able to edit PSD mockup images with smart objects perfectly OK in Affinity Photo, but not any more -  this is really annoying since I publish low-content books and always need mockups!    I hope this will be fixed very soon... 
 attached  a couple of psds and screenshots

MAGAZINE COVER MOCKUP.png

SOFTCOVER BOOK MOCKUP.png

09_Book_Mockup.psd

Share this post


Link to post
Share on other sites

Hi!

first of all, thanks for the job! Now is much better.

As you can see, now there is not problem in the same file I sent previously:

1711315272_Capturadepantalla2021-02-26alas10_26_20.thumb.png.8b9f4538e26835c2db9d6de4391fdbec.png

I tried with more files with smart objetc and in a lot of cases now is working without problem.

 - However, in other cases, appears some small problems like these:

1715518782_Capturadepantalla2021-02-26alas10_38_51.thumb.png.65ced7646051eb90591b34efb4628ce9.png

1553315190_Capturadepantalla2021-02-26alas10_52_26.thumb.png.d52ff56b6117092effd83c267f862bb1.png

But it is possible to try to readjust the document or remove the effect / layer causing the error by hand. In these cases I can see that the file has perspective + mask (or effect) into the same layer.

 - Or in others, is not possible to work with the file at all, because appears like strange mix of layers:

1601299452_Capturadepantalla2021-02-26alas10_42_30.thumb.png.6ebf9a78745951acfbd7523834be3c26.png

It should be look like:

Captura_de_pantalla_2021-02-26_a_las_10_42_55.thumb.png.a25d05aeb5611ebee153cb95a8fcaea1.png

54904861_Capturadepantalla2021-02-26alas10_56_28.thumb.png.c51b7f42278d097eaef3dba8755d22e8.png

It should be look like:

1333991501_Capturadepantalla2021-02-26alas10_42_42.thumb.png.2dbcb7e8fded1a971e2892c087aced43.png

Let me know if you want the psd file to check it.

Thanks again and have a nice day.

Share this post


Link to post
Share on other sites

out of curiosity, I downloaded one of these free templates.

I tried to open it in my old Photoshop CS5, which worked fine(-ish) as this version barely works today in Mojave...

 

What surprised me, was that upon first opening in APhoto it displayed OK and when saved as .afphoto and re-opened the perspective is off.

You can also see that in AfPhoto the smart-layers have an additional perspective applied, which they do not need and have in Photoshop. (see screenshots)

 

aPhoto191.png.f8f7fd308b5db158950145d223b88c0b.pngps_cs5.png.a85622907269c84525968395254ab451.png


  • Main machine: iMac (21,5-inch, Late 2013), 16GB RAM, 1TB nvme + 2TB ssd, running on 10.14.6 Mojave;
  • Display setup: 27" Thunderbolt Display (primary) + 21,5" iMac-Display for studio panels (secondary);
  • Keyboard layout: german apple extended keyboard (aluminium);

 

Share this post


Link to post
Share on other sites

Hi. I've tried to use mockups with the last 2 updates, version 1.9.2 and 1.9.3, and I have a lot of problems with mockups and smart objects.  It's true that sometimes the file works fine, but time to time it's not possible to work with files with smart objets. Is it known if it will be fixed in future 1.9 updates ...? Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.