Jump to content
You must now use your email address to sign in [click for more info] ×

"Open Recent" still not working.

Recommended Posts

I'm not sure why I keep mentioning this bug in all your software (it's been there since 2018). "Open Recent" still doesn't work, and after clearing it the same recents have been coming up since the first time I launched the software three years ago. This is Mac and Windows. Why am I still marked as a newbie here if I've been posting for three years?

Link to comment
Share on other sites

@Chosen Idea

To answer your second question first: designation as a Newbie is because of your limited number of posts, not because of your length of time as a member.

As to the first problem you list: I certainly don't see the "Open Recent" as showing anything other than precisely that: the most recent files I have been working on.  Clearly, you are seeing something different but that does not make the problem a "bug"!  By definition, I think, a bug must be reproducible by at least a considerable number of users to be labelled as such. 

My computer spec etc., is in my signature, in case you want to know about mys system.


Win 10 Pro, i7 6700K, 32Gb RAM, NVidia GTX1660 Ti and Intel HD530 Graphics

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher, version 1 and now version 2.

iPad Pro (11") running Affinity Photo and Designer (iOS 16.5) version 1 and all three version 2 apps.

Link to comment
Share on other sites

6 hours ago, Chosen Idea said:

I'm not sure why I keep mentioning this bug in all your software (it's been there since 2018).

You have already been answered, and you have not responded to it.



Affinity Store (MSI/EXE): Affinity Suite (ADe, APh, APu) 2.1.1.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080, Windows 11 Pro, Version 22H2, Build 22621.2215.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080, Windows 11 Pro, Version 22H2, Build 22621.2215.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200, Windows 10 Pro, Version 21H1, Build 19043.2130.

Link to comment
Share on other sites

  • 1 month later...
15 minutes ago, Chosen Idea said:

Really? Why are only Serif applications affected? No permissions issues or cleanup applications here. Someone get on this, it's been five years of new versions (and even system reinstalls for general maintenance on my end).

Hm. Since it seems like you're the only one still affected by this "bug", I guess the only solution would be sending in your whole system (hard- and software) to Serif so they could see what's happening. As it's hard to fix a bug, which seems to happen only on a unique setup.

»A designer's job is to improve the general quality of life. In fact, it's the only reason for our existence.«
Paul Rand (1914-1996)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.