Jump to content

Recommended Posts

Nested pixel layers don't show any strokes I make -- regardless of color or brush type/size. 

I've tried adjusting settings; closing & reopening Affinity; restarting PC. Nothing fixes it.

Please help!

Share this post


Link to post
Share on other sites

We might need to see the layout of your document layers to help further.
It helps if we can see what you are working on and how the layers are arranged.
A full-screen screen-grab showing your Layers Panel expanded so we can see the layer(s) in question usually helps.
In the meantime, check your brush Opacity is not 0% and make sure you are not painting onto an Adjustment layer.

Share this post


Link to post
Share on other sites

Thanks for the responses, guys. 

While I appreciate your suggestions, the items you mentioned are not the problem.
The layer is not locked, nor transparent, nor alpha protected.

My ability to paint on pixel layers has never been an issue prior to yesterday.
I'm truly flummoxed, and frustrated at being stalled out. 

I have taken/included a screenshot, as requested.

Affinity Designer -- program screenshot.jpg

Share this post


Link to post
Share on other sites

From the screenshot, your pixel layer is clipped inside the "fingers hand R" Curve layer.

Where are you trying to paint?  You can only paint within the bounds of that layer due to the clipping. (Maybe you know that, of course, but when things aren't working it can help to review the basics, sometimes.)

According to the pixel layer's thumnail you have painted along the lower edge of that hand. Also, what brush are you using? You might try one of the solid basic brushes as a start.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.2.1035 and 1.9.2.1005 Beta   / Affinity Designer 1.9.2.1035 and 1.9.2.1005 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Share this post


Link to post
Share on other sites

Hi, Walt.

I appreciate the suggestion. I am a seasoned digital artist, and have used Affinity Designer since its' inception. 
(Actually used Serif's "DrawPlus", before that. 😊)

I tried a multitude of brushes, even though I fully suspected that wasn't the issue. None work.
Even if I add a pixel layer outside of any shape, it doesn't show what I paint with my brush.

This has occurred after I updated to the newer software release, so it would make sense that it's some kind of bug in the 1.9v.

I figured I'd try to install the prior (stable/non-beta) 1.8.5 version, but it gave me a 'this is an older version' error upon doing so.
I really don't want to uninstall then reinstall, since it would mean having to import all my brushes again.

Share this post


Link to post
Share on other sites

There are a couple of things you could try

a.is protect alpha selected on context bar
b. check brush opacity/layer opacity
c. are you painting with the same colour of the parent object (this one catches me out!)
d. are you trying to paint with a background colour
e. is the layer you are trying to paint selected
f. sometimes I get caught out by trying to paint in an object only to find out its not selected and I am painting somewhere else on the page
g. is there something selected?


AD 1.9.1.979+ Beta AD 1.9.2.1035 | APh 1.9.1.979 + Beta AP 1.9.2.1035
APu 1.9.2.1035 +Beta Apu 1.9.2 2024

OS:Windows 10 Pro 20H2 OS Build 19042.789 + Windows Feature Experience Pack 120.2212.551.0
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 20.11.2 
Radeon Settings Version 2020
20.1.03) + Wacom Intuous 4M with driver 6.3.41-1

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.