Jump to content

Affinity Photo Windows Customer Beta - 1.9.1.952


Recommended Posts

  • Moderators

Click here to download the latest beta

Status: Customer Beta
Purpose: Fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Changes

  • Fixed Affinity registration showing in English for some supported locales
  • Fixed EMFs not rendering on non-RGBA documents
  • Fixed performance of Posterise when hardware acceleration is enabled
  • Fixed inability to disable hardware acceleration, or a crash at startup if the hardware acceleration option hadn't been written to the settings file (introduced in 944 beta)
  • Fixed mirroring objects to transform individually based on tool settings
  • Improved performance of snapping by restricting inner bound snapping to objects with no more than two curves (ie, single holes)
  • Fixed being unable to create custom export presets for PDF export
  • Fixed scaled text frame increasing text size when grouped 
  • Fixed Copy As SVG preventing Affinity data being added to the clipboard 
  • Fixed performance problems when Paragraph Panel was visible 
  • Fixed PDF passthrough failing to work on multi-page documents
  • Fixed Panorama Erase from Source Mask tool artifacts
  • Fixed TGA import to allow loading of large files
  • Fixed crash when loading specific CR3 file

1.9.1.944 release notes

Link to comment
Share on other sites

4 hours ago, Umiama said:

Still wait for a fix about raster brush accumulation issue.

I do not see any posts about a raster brush accumulation issue, from a quick forum search. Do you have a pointer to the topic where this is discussed?

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

Hi Mark, read your reply now a couple of beta versions back, in short order.

Impressive work by you guys.  Now, about links and CDNs...

- The CDN move really works. It was able to saturate a decent cable internet (is there such a thing...)
with peaks of up to 50Mbit/sec, in California.  This is great, and things even the size of Affinity updates arrive rapidly.

- the links. I clicked today first on the Publisher update. Bingo, took right off downloading as expected
  Then I tried here, for Photo.  As before, no joy. I had to right-click-open-in-tab, to get it
  What's the difference?  The Publisher link is https, and the Photo one still isn't

We are likely big boys and girls here amongst the betas, and can figure this out,
but it doesn't feel good, or of the enormous design, quality, and advances level we know of Affinity

Don't mean the loud pedal, just saying a feeling, and with a smile. Can't forget all the things you guys do do, either,
as you can see :)

Best,
Clive

Link to comment
Share on other sites

7 hours ago, Mark Ingram said:

and it seems Chrome is taking a dislike to navigating from the HTTPS forum, to the HTTP download.

It's deliberate

Explained here

https://www.ghacks.net/2020/10/08/chrome-is-blocking-downloads-here-is-why/

and here

https://www.ghacks.net/2020/02/07/google-chrome-will-block-all-insecure-downloads-in-the-near-future/

R.I.P

Link to comment
Share on other sites

On 2/12/2021 at 6:14 AM, carl123 said:

No issues with Microsoft Edge Chromium here...

Asus ROG Strix G17 Notebook:
AMD Ryzen 7 5800H 3.80 GHz with Radeon Vega Graphics | 32GB DDR4 3200mHz RAM
Nvidia GeForce RTX 3060 Ti 8GB Gfx | 2x 2TB SSD NVMe PCIe M.2 3x4 | Windows 11 Version 22H2 Build 22622.601

Link to comment
Share on other sites

On 2/11/2021 at 5:36 PM, aji said:

It's clear in the video that brush accumulation doesn't work  

https://forum.affinity.serif.com/index.php?/topic/131655-there-is-no-pressure-on-the-brush/

Hey aji! I already asked the developers two times over the distance of a few months. @Gabe told me they still have it in their to-do list and didn't forget it. I think it might be a little bit of a deeper problem that can't be fixed quickly. I submitted bugs a few times and they usually fixed it quite fast, I do trust the developers to not let us down on this. It will take time, but they will fix it. :)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.