Jump to content
Andy Somerfield

Affinity Photo Customer Beta (1.9.1.219)

Recommended Posts

Status: Beta

Purpose: Fixes

Requirements: Purchased Affinity Photo

Mac App Store: Not submitted

Download ZIP: Download

Auto-update: Pending

 

Hello,

We are pleased to announce the immediate availability of the first build of Affinity Photo 1.9.1 for macOS.

If this is your first time using a customer beta of an Affinity app, it’s worth noting that the beta will install as a separate app - alongside your store version. They will not interfere with each other at all and you can continue to use the store version for critical work without worry.

This beta is an incremental update to the 1.9.0 version recently released to all customers (although it still installs parallel to the released version, as described above). We recommend that you use this beta in preference to the store version if you are affected by any of the issues listed below.

Affinity Photo Team  :ph34r:

 

Changes Since 1.9.0

 

- Fixed crash exporting LUTs.
- Fixed some icons being very small.
- Fixed incorrect cursor issues.
- Fixed crash loading large TGA files.
- Fixed bug when erasing from a panorama source mask.
- Fixed CR3 bugs.
- Fixed monochromatic iconography option not working.
- Fixed alignment issues with pixel tool.
- Fixed marquee selection issues on Apple Silicon devices.
- Fixed loading of 16bit LAB TIFF.
- Fixed assorted live filter issues.
- Fixed live stack with live perspective issues when the source images have differing orientations.
- Assorted other small fixes.

Share this post


Link to post
Share on other sites

 

OK, so just tried to use this new beta and as soon as the app’s interface is on screen it consistently crashes.
Crash report attached and my system specs are in my signature bellow.

Affinity Photo Beta_2021-02-10-104335.crash

 


macOS 10.14.6  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Share this post


Link to post
Share on other sites

According to your crash report it seems to crash at a state, where for a HTTP connection, it's trying to check whether a readable stream has data that can be read without blocking ...

Quote

Thread 1 Crashed:: Dispatch queue: com.apple.CFNetwork.HTTP2.HTTP2Stream
0   com.apple.CoreFoundation          0x00007fff48ac6043 CFReadStreamHasBytesAvailable + 19
1   com.apple.CFNetwork               0x00007fff47a9c1e9 RequestBodyStreamProvider::readBodyStream(bool) + 139
...

... so all in all during an HTTP protocol connection.


☛ Affinity Designer 1.9.2 ◆ Affinity Photo 1.9.2 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites
4 hours ago, v_kyr said:

According to your crash report it seems to crash at a state, where for a HTTP connection, it's trying to check whether a readable stream has data that can be read without blocking ...

... so all in all during an HTTP protocol connection.

Thanks for the reply @v_kyr 🙂 That all probably means something to someone, but alas not to me😟
Am I the only one for whom this new beta is crashing on launch?


macOS 10.14.6  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Share this post


Link to post
Share on other sites
6 minutes ago, markw said:

Thanks for the reply @v_kyr 🙂 That all probably means something to someone, but alas not to me😟

I don't know where it tries to connect via HTTP or HTTPS at that stage in order to fetch something, I've just looked what your crash report tells for the cause of the crash. - Though I assume, it's probably during connection to Serif for loading/showing up the registration or the like.

21 minutes ago, markw said:

Am I the only one for whom this new beta is crashing on launch?

I don't think so, but I don't have installed and run the betas (thus I don't see a crash). - Further if the whole might be dependent on the new registration service, that one isn't supported on my old MacOS version.


☛ Affinity Designer 1.9.2 ◆ Affinity Photo 1.9.2 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites
43 minutes ago, markw said:

Am I the only one for whom this new beta is crashing on launch?

We think that so far you are the only one on macOS 10.14.x which would crash for anyone else on it too. 


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Share this post


Link to post
Share on other sites

FWIW, I am running macOS Catalina 10.15.7 & (so far) not seeing any crashes. I had already registered in an early 1.9.0.x beta version which this beta replaced, so I can't test if clicking on the "Register" button would crash it, but the "Browse the Store" button & the content download link buttons I tested all work fine.


Affinity Photo 1.9.2, Affinity Designer 1.9.2, Affinity Publisher 1.9.2;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.9.1.225 & Affinity Designer 1.9.1 (showing 1.9.7) for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.4 (18D52)

Share this post


Link to post
Share on other sites

On startup it crashes unless I switch off the internet connection.

Having started up without internet connection, it crashes as soon as I connect to internet again.

MacOS Mojave

Share this post


Link to post
Share on other sites
13 hours ago, Patrick Connor said:

We think that so far you are the only one on macOS 10.14.x which would crash for anyone else on it too. 

Affinity Photo Customer Beta (1.9.1.219) also crashes on my computer when I launch the program. 

Crash Report 1.9.1 (1.9.1.219).rtf


(iMac 2017, 16 GB RAM, Intel Iris Plus Graphics 640 1536 MB, MacOS 10.14.6 Mojave)

Share this post


Link to post
Share on other sites

I have experienced quite some crashes myself with the official 1.9 version. But as I was experiencing crashes with some other programs at the same time, I forgot to look into that. Most issues with 1.9 disappeared when I logged out of my account. Startup of AP 1.9 was indeed so excruciating slow that I got a 'not responding' even before the program was open, and I had to Force-Quit.
But after I was able to launch 1.9 successfully, and had logged out of my account, I have not experienced similar issues again.


CANON cameras (7D, 350D, G9), lenses ranging from 10 to 400mm, and Speedlite 580EX II -  Intel iMac (27" late 2012) 3,4GHz 16GB RAM - 2TB HD (0S 10.15.7 Catalina) - iPhone XR (iOS 14.4) + iPad 6,11 (iOS 14.4)

Share this post


Link to post
Share on other sites
11 hours ago, Puck said:

Affinity Photo Customer Beta (1.9.1.219) also crashes on my computer when I launch the program.

Same error as for user @markw (see above) and you both run MacOS 10.14.6 here!


☛ Affinity Designer 1.9.2 ◆ Affinity Photo 1.9.2 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites
19 hours ago, pruus said:

And grouping text with different styles are working, as original, great! Icon -again- good size. Thanks! But clicking on Register, crash!174364463_Schermafbeelding2021-02-10om18_43_49.png.766063d6241a5fd25ba09583449d413f.png

 

19 hours ago, markw said:

Thanks for the reply @v_kyr 🙂 That all probably means something to someone, but alas not to me😟
Am I the only one for whom this new beta is crashing on launch?

can confirm as well. macOS 10.13.6

Share this post


Link to post
Share on other sites

I can confirm, Photo 1.9.1 immediately quits after showing the splash screen.

(the new Publisher beta works, thou)


  • Main machine: iMac (21,5-inch, Late 2013), 16GB RAM, 1TB nvme + 2TB ssd, running on 10.14.6 Mojave;
  • Display setup: 27" Thunderbolt Display (primary) + 21,5" iMac-Display for studio panels (secondary);
  • Keyboard layout: german apple extended keyboard (aluminium);

 

Share this post


Link to post
Share on other sites
3 minutes ago, woefi said:

I can confirm, Photo 1.9.1 immediately quits after showing the splash screen.

(the new Publisher beta works, thou)

The Publisher macOS beta 1.9.1.952 includes a fix for crashes on macOS 10.14 and earlier, so this makes sense. I think you will be able to run the next Photo beta, sorry for the inconvenience.


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Share this post


Link to post
Share on other sites

Thanks for the update Patrick. New Publisher beta launches just fine😎
Looking forward to the next Photo beta!


macOS 10.14.6  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Share this post


Link to post
Share on other sites

BTW related to the com.apple.CFNetwork.Connection crashing, I recall seeing somewhere this statement which was related to such crashes ...

Quote

We also found a fix. - In our application we are loading a lot of images. These URLs all had that HTTP protocol, while it expected HTTPS. The system seemed to handle the redirect for us, since we could see the images being loaded after another call to the same url, but with HTTPS protocol. Older OS versions apparently have problems with the large amount of extra requests/redirects. After defaulting to using HTTPS for our images the crash disappeared.

 


☛ Affinity Designer 1.9.2 ◆ Affinity Photo 1.9.2 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

I've noticed that the Brushes now sort themselves alphabetically. This seems to be live, as well, since renaming a brush category causes the list to re-alphabetize. Although I think it's only a partial solution to a true brush "organizer," it's a nice addition. I may spend some time renaming my brushes to things like: 01-Brush Name, 02-Other Brush Name, and so forth. That way, I can group them and organize them in a more appropriate manner.

Share this post


Link to post
Share on other sites
6 minutes ago, smadell said:

I've noticed that the Brushes now sort themselves alphabetically.

Well spotted! All three of the 1.9.1 Mac betas do this now, including in both AD's Designer & Pixel personas, & in APub's Designer & Photo personas.

Renaming ignores leading spaces so something like " Basic" will not sort first before Acrylics" but "-Basic" would.


Affinity Photo 1.9.2, Affinity Designer 1.9.2, Affinity Publisher 1.9.2;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.9.1.225 & Affinity Designer 1.9.1 (showing 1.9.7) for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.4 (18D52)

Share this post


Link to post
Share on other sites

I just installed the Photo Beta 1.9.1.219 as I was hoping to see the Export Preset Greyed out as reported by a number of people who reported that the issue was on all three products.  I was encouraged to see it listed as fixed in Affinity Publisher but I see it is not fixed in Photo.

Also, FWIW, my install crashed the first time I accessed the Export option but it recovered and I did not have an issue afterwards.  I have not used it more than a few minutes though as I need the Export Preset issue fixed so I can set up the various outputs I need to work with.  I am on iOS 10.14.6 Mojave like markw.

Share this post


Link to post
Share on other sites
1 hour ago, Survant said:

but I see it is not fixed in Photo.

Which was built a few days prior to this fix, the next build it will get this fix.

1 hour ago, Survant said:

Also, FWIW, my install crashed the first time I accessed the Export option but it recovered and I did not have an issue afterwards.

We will need to find this recipe it probably depends on your selection when you choose export


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.