Jump to content

Recommended Posts

Changing 0 has no effect with the object coordinates.

AD is as 0 has never moved.

For me, it's a drama because I use it a lot for symmetry.

PS : I've sent you an email (contact@…) because since I've installed this new release, I can't use beta (bought with Apple AppStore).

 

AD point 0.jpg

Link to post
Share on other sites
  • Moderators

Hi Lenogre,

Does this only happen for Lines, are other objects ok? If you notice the Transform Panel now shows Line Objects (much less anchors), the skew is also been replaced by length which means you can alter the length of the line without it needing to be horizontal or vertical. 

It seems to be just these objects that are displaying incorrect X/Y values when the origin point has been moved. I'll get this passed on to development.

With regards to the beta not working - that is expected and happens after every major release. The Betas look for detect known versions to ensure they run up, however when we release the next versions they do not know to look for this version and so will not run up. Please don't worry about that.

Link to post
Share on other sites

You're right : It only happens with lines.

About betas, all my 3 affinity software are registred (the little green silhouette top right) but only one has been bought with your store. Key product is easy to find with your store but with Apple AppStore, I have the software installed without asking me anything (no key product…).

Restarting my computer has no effect, Affinity ask me for my key product…

Link to post
Share on other sites
  • Moderators
1 hour ago, lenogre said:

Another little thing I've noticed about the UI of this new release.

Is it normal ? In previous releases or betas, it's bigger.

Capture d’écran 2021-02-09 à 10.26.32.png

That has been a commonly reported issue in the bugs forum and is with development to be fixed. Unfortunately it crept right in at the very end! :( 

Link to post
Share on other sites
  • Moderators
1 hour ago, lenogre said:

You're right : It only happens with lines.

About betas, all my 3 affinity software are registred (the little green silhouette top right) but only one has been bought with your store. Key product is easy to find with your store but with Apple AppStore, I have the software installed without asking me anything (no key product…).

Restarting my computer has no effect, Affinity ask me for my key product…

This is to be expected, and is by design. (Older) Beta builds cannot see detect any (Newer) App Store release and will ask for the product key. This has been mentioned many times in the beta forums and is intentional. 

Link to post
Share on other sites
  • Moderators
44 minutes ago, lenogre said:

Let me understand : If I want to use beta, I must re-buy the softwares with your store ?

If it's right, I've never seen that anywhere !

That is not what I'm saying.

The betas we currently have available for macOS are OLDER than the current App Store release. This means they do not know about that release and will flag up asking you to register. When we release a new macOS beta it WILL detect this version and you will not be asked to buy the software. We prefer you to not run older betas because it is out of date. 

Please see this post from @Patrick Connor explaining the behaviour:


 

Link to post
Share on other sites
  • Moderators

I wish that the beta gave a different message in this common use case. Prompting for a key because the beta pre-dates the current mac-app store release is the wrong thing to do (it's just accidentally falling through to code designed for a different use case)

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
15 hours ago, lenogre said:

Changing 0 has no effect with the object coordinates.

AD is as 0 has never moved.

 

Works for me on OS 10.14.6

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites
  • Moderators
8 hours ago, Old Bruce said:

Works for me on OS 10.14.6

Lenogre's issue is specific to Line objects - if you notice they now appear differently in the Transform Panel and allow you to specify their length. These are currently ignoring the modified origin point. :)

Link to post
Share on other sites

About beta, I was thinking that betas (the last was 1.9.0.23) were more recent than official release (1.9.0). We consider that the official 1.9.0 is like 1.9.0.24 but by simplicity we call it 1.9.0.

It's clear for me now.

Link to post
Share on other sites
7 hours ago, Sean P said:

Lenogre's issue is specific to Line objects - if you notice they now appear differently in the Transform Panel and allow you to specify their length. These are currently ignoring the modified origin point. :)

Ah, I see it is messed up for straight lines. I had a bit of a curve on mine.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites

Same issue here. I use line segments as crop marks and also rely on them for measurements, but they are all tied to the document origin instead of ruler. I'm using rectangles for now, but I'm hoping this will be resolved quickly. Thanks.

= Designer & Programmer =

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.