Jump to content

Anyone else had problems with Affinity Photo 1.9 crashing?


Recommended Posts

So what now, do some of us have to stay on 1.8.5 for good? Or are any of the Serif team reading this thread, taking on board the amount of concerns and passing the news on to the guys at the top? I don't wish to blunt but it's a bit of a cock up chaps......lovely graphics though when starting up

Link to post
Share on other sites

Don't know if this is helpful. I've had no problems with Affinity 1.9 until today, and today was the first time for me to use my graphics pen with Affinity Photo. My editing is usually minimal and I have been using Affinity a lot recently, but today I wanted to go in on some fine detail to do changes  and my pen sent the whole thing odd. Zooming using the pen sent the display crazy, and trying to do a selection just hangs Affinity.

I'm currently looking to see if I can get updated drivers for my pen/ graphics tablet, but it seems to work ok when navigating menus, or if I use it outside of Affinity.

Link to post
Share on other sites
On 2/16/2021 at 12:43 PM, AITCH said:

So what now, do some of us have to stay on 1.8.5 for good? Or are any of the Serif team reading this thread, taking on board the amount of concerns and passing the news on to the guys at the top? I don't wish to blunt but it's a bit of a cock up chaps......lovely graphics though when starting up

I'm sure they're working on fixes as quickly as they can.  It's to their advantage to have a product that works as it should.  In the meantime, be grateful for 1.8.5.

Link to post
Share on other sites
  • Moderators

The beta forums contain fixes for most of the issues brought to our attention since 1.9.0 was released.

The most helpful thing would be to install the beta parallel to your current release build and confirm whether or not your particular problem is fixed or not.

The betas are being tested at the moment to see if they can be released as 1.9.1

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites

I always ignore the update screen for about a month after the updates show up....just to avoid this situation. I probably don't really need the update since I use about 20% of what AP can do. I don't heavily edit my shots, trying to keep everything in camera as much as possible. If I take more than ten minutes editing an image I feel I have failed in getting the right image to begin with.

Link to post
Share on other sites

I updated all the Windows apps to 1.9 (exactly 1.9.0.932). I had no problems with a couple of projects. However, now, when Photo starts up, the interface looks normal. I create a new document, or load as saved one, the canvas loads, displaying blank, if new, or the artwork if loading an existing one. At this point, the interface freezes. The CPU goes higher for the app (< 50%), and it becomes unresponsive. I have to kill the app.

At the start, the menus work; at the Preferences section, I reset all tools to their factory defaults and disabled the hardware acceleration. No success, same behaviour.

I also tried Beta 1.9.1.963 unsuccessfully. When loading an existing document, the canvas is never loads, and a message remains at the top-right corner of the main window saying "Loading 1 document..." and it's stuck for good. I cannot close the window as it pops up a message to wait because a document is loading. I have to kill the program.

I'm running a Lenovo X1 G3 [all updates applied] on Windows 10 Pro (Build 19042.804)

I'll wait for an update before I downgrade to the previous version.

Link to post
Share on other sites
1 hour ago, Patrick Connor said:

The beta forums contain fixes for most of the issues brought to our attention since 1.9.0 was released.

The most helpful thing would be to install the beta parallel to your current release build and confirm whether or not your particular problem is fixed or not.

The betas are being tested at the moment to see if they can be released as 1.9.1

Thank you Patrick, it seems a lot of people have had issues but no doubt it will get resolved :) 

I reinstalled 1.9 about half hour ago and ran the benchmark test, I haven't a clue what these figures mean. Can you shed some light please. All my drivers are up to date on my HP 8GB laptop

Benchmark test.PNG

Link to post
Share on other sites
1 hour ago, hank schoch said:

I'm sure they're working on fixes as quickly as they can.  It's to their advantage to have a product that works as it should.  In the meantime, be grateful for 1.8.5.

 In the meantime, be grateful for 1.8.5.
 

Yes, which I reposted a few days ago along with Designer and Publisher 👍

Link to post
Share on other sites

This program is absolute garbage. Crashes when using just about any tool I try.

Unless one of you kind folks has a solution, I will try to get a refund (just bought it today) because I do not need this kind of headache.

Seeing how bad their program is, however, I have little hope of even being able to reach customer service. What a disappointment after all the rave reviews. So much for doing my due diligence.

Link to post
Share on other sites
2 hours ago, Mike Long said:

This program is absolute garbage. Crashes when using just about any tool I try.

Unless one of you kind folks has a solution, I will try to get a refund (just bought it today) because I do not need this kind of headache.

Seeing how bad their program is, however, I have little hope of even being able to reach customer service. What a disappointment after all the rave reviews. So much for doing my due diligence.

You don't say what you are running it on. A lot of  the problems are due to OpenCL acceleration. Try going into preferences and Performance and turning that off.

Link to post
Share on other sites
6 hours ago, RichardMH said:

You don't say what you are running it on. A lot of  the problems are due to OpenCL acceleration. Try going into preferences and Performance and turning that off.

I'm not a computer whiz.  If I disable CL acceleration, what performance factors and other programs unrelated to Affinity might be affected?

Link to post
Share on other sites
  • Moderators
3 minutes ago, hank schoch said:

If I disable CL acceleration, what performance factors and other programs unrelated to Affinity might be affected?

You are being asked to disable it in Affinity's own "Preferences >Performance" dialog. It will not affect any other application and Affinity itself will simply go back to drawing how it did for 1.8.5

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
  • 2 weeks later...

i had problems in updates of affinity designer/photo both on Windows10 desktop and on my iPad. Also after correct password they demand product i.d. Is it new way by Serif to extort from customers?

 

Link to post
Share on other sites

After using the 1.9 Beta and updating to the latest 1.9 official release, I'm still having issues with the program. It launches, but when I'm trying to do anything (opening, creating a new document, etc.) the program freezes up. Windows will pop-up a message saying the program is not responding, and the only solution is killing the task.

However, I noticed that this behaviour is only happening when I'm using multiple monitors. I can use the program perfectly well when I'm using only the laptop display. Interestingly, it works on multiple screens if I start the application before connecting the computer to my dock.

My computer is up-to-date with all drivers, including the Thunderbolt dock.

 

Link to post
Share on other sites

For Windows users:

If you are able to reach the Preferences settings before crashing, switch there to the Performance settings and disable the hardware acceleration settings. Afterwards restart and retry. 

Or you can try out one of the latest 1.9.2.xxx Beta builds which should have addressed many issues related to these OpenCL issues!

If all above mentioned doesn't help, look for possible Affinity crash reports, which should then hopefully tell the cause of all evil ...

☛ Affinity Designer 1.9.3 ◆ Affinity Photo 1.9.3 ◆ OSX El Capitan

Link to post
Share on other sites

Being new to this program, I thought I was doing something wrong. I can't open 2 photos and a new document at the same time. Opening a jpg took forever. I uninstalled and installed. I finally uninstalled 1.9 and went back to 1.8. No problems. Thank you to all for the help.

Link to post
Share on other sites
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.