Jump to content

Affinity Designer: PDF Export hangs

Recommended Posts

I'm running in problems when I'm trying to export a fairly complex (and huge) Affinity Designer document as PDF: whenever I try that, AD hangs during the export, using up to 700% CPU. The symptoms of the problem actually seem to be very similar to those described here. However, for me exporting to bitmap formats (JPEG, PNG, TIFF) works fine – just the PDF export is problematic.


I could export an older version of my document to PDF without problems earlier, but now even the export of this older version hangs. I'm not 100% certain if it was the same version of AD (1.3.5) back then, or if there was an update in between.


I'm running Affinity Designer under OS X 10.10.5.


Share this post

Link to post
Share on other sites

Hello Janichsan,

Welcome to Affinity Forums :)

Can you attach the .afdesign file here so we can take a look?

Alternatively you can sent it to support@seriflabs.com along with a small description and a link to this thread.

All files will be deleted after being inspected.


I'll sent an email with a link to the file. With now ~230 MB, it's a bit too big for the forum or email…


I'm sorry you've been having this problem. Can I suggest you try it with the Customer Beta of Designer? It has a different code path for PDF export, and generally has a lot of bugs fixed which may help. The Beta is available from elsewhere in this forum.

I tried the beta and I can in fact export and PDF of my document with it. However, the resulting PDF is quite problematic: not only do the rasterised parts stand clearly out (which they don't on the PDF of the older version of my document), something with the PDF causes OS X's preview to freeze when zooming in (again, that does not happen with the equivalent older PDF).


That said, I think I could narrow down the problems I have to the rasterisation. When I turn off the rasterisation in the export settings, I can also produce a PDF with AD 1.3.5., unfortunately with some huge blank holes where objects where supposed to be.

Share this post

Link to post
Share on other sites

Not really. The main reason the rasterised areas look different is that Preview draws the thin lines of the grid too thick when zoomed out. That's not something we can do anything about (and I doubt it changed with the beta).


Nor do I know why Preview crashes. The PDF appears to be valid, loads into other apps (including Acrobat Pro), and even Preview itself can understand and render it when zoomed out. I plan to stop using some of the more advanced PDF features, which may help. PDF Export is still being worked on.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.