Jump to content

[By Design] Snapping tool issue


Recommended Posts

4 hours ago, NevraArts said:

I am probably very stupid this time, but it has been ages since I am having this issue with affinity designer iPad, and I have tried everything inside the snapping options, but I can't sort this out... how can I fix this crazy thing?

thank you!

 

Are those Shapes or strokes? Are there any groups?

Link to post
Share on other sites
5 hours ago, NevraArts said:

how can I fix this crazy thing?

Documents menu, SnappingForce pixel alignment on. Move by whole pixels off.

IPad Pro 10.5/512GB   lpadOS 14.4 Apple Pencil (1st gen), Affinity Photo 1.9.0.218,  Affinity Photo beta1.9, Affinity Design 1.9.3, Affinity Designer beta 1.9.20, still waiting for Publisher for iPad

Link to post
Share on other sites
12 hours ago, BarKeegan said:

Are those Shapes or strokes? Are there any groups?

these are shapes, but even if I transform them in curves it just doesn't work, an it has been like this forever, not just this time...

10 hours ago, DM1 said:

Documents menu, SnappingForce pixel alignment on. Move by whole pixels off.

done already, among other hundreds different combinations, nothing changes...

Link to post
Share on other sites

Can you upload that file as afdesign file. Happy to have a look a it.

IPad Pro 10.5/512GB   lpadOS 14.4 Apple Pencil (1st gen), Affinity Photo 1.9.0.218,  Affinity Photo beta1.9, Affinity Design 1.9.3, Affinity Designer beta 1.9.20, still waiting for Publisher for iPad

Link to post
Share on other sites

I got it to work by turning off snapping, aligning and turning snapping back on with force whole pixels. Definitely not working as it should. Note the opposite sides of boundary boxes snap perfectly before fiddling (maybe this means something to devs.?).

IPad Pro 10.5/512GB   lpadOS 14.4 Apple Pencil (1st gen), Affinity Photo 1.9.0.218,  Affinity Photo beta1.9, Affinity Design 1.9.3, Affinity Designer beta 1.9.20, still waiting for Publisher for iPad

Link to post
Share on other sites
39 minutes ago, NevraArts said:

I have made exactly like you now but still not working... :/

You have to turn off the snapping control and also turn off the Force pixel alignment button (in addition to the main snapping control), before aligning the edges,  then you turn the Force pixel alignment and move by whole pixels buttons back on. Not the way it should operate but it snaps back to the aligned position after doing that.

IPad Pro 10.5/512GB   lpadOS 14.4 Apple Pencil (1st gen), Affinity Photo 1.9.0.218,  Affinity Photo beta1.9, Affinity Design 1.9.3, Affinity Designer beta 1.9.20, still waiting for Publisher for iPad

Link to post
Share on other sites
On 2/7/2021 at 11:15 AM, DM1 said:

You have to turn off the snapping control and also turn off the Force pixel alignment button (in addition to the main snapping control), before aligning the edges,  then you turn the Force pixel alignment and move by whole pixels buttons back on. Not the way it should operate but it snaps back to the aligned position after doing that.

I have done it, and I have tried again but nothing, anyway, I gave up by doing it in a different way, bu it is a major flaw in my opinion.
This one and boolean operations are too faulty, in affinity designer  iPad at least.

Link to post
Share on other sites
1 hour ago, NevraArts said:

it is a major flaw in my opinion.

Agree with you there. Still waiting for Mods to chip in here.

IPad Pro 10.5/512GB   lpadOS 14.4 Apple Pencil (1st gen), Affinity Photo 1.9.0.218,  Affinity Photo beta1.9, Affinity Design 1.9.3, Affinity Designer beta 1.9.20, still waiting for Publisher for iPad

Link to post
Share on other sites
  • 2 weeks later...
  • Moderators
On 2/9/2021 at 10:00 AM, DM1 said:

Agree with you there. Still waiting for Mods to chip in here.

This is not a bug, unfortunately its just the way the EPS was made slightly offset, and when imported gets placed on half pixels. 

However what I think you're trying to do cannot be done on an object level (Snapping to nodes inside an object). We only snap to the objects bounding boxes (and midpoints etc) when snapping objects. However if you select the Node Tool you can then highlight all the nodes in the one object and then snap them to the nodes of other objects providing you have Snap to Layer Geometry enabled (if you're using Snapping Candidates then you will need to first ensure they're marked as a candidate). 

I've attached a video showing this process - I've also enabled Show Snapping Candidates - this puts a purple highlight around the object to indicate its a snapping candidate. If an object isn't a candidate that you're trying to snap to then just hovering over it with your selection will make it flash briefly to indicate its now a candidate. This is shown in my video.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.