Jump to content

Recommended Posts

1 hour ago, nodeus said:

Well, I have a solution.

go to %AppData%\Affinity\Publisher\ and rename the "1.0" to "1.0 old ver" and restart Publisher.

This is work for me. 

didn't test for too long, but this fix for the time being. 

Thanks~

Link to post
Share on other sites

Mine too. Before the update to version 1.9 everything was very fast. Since the update, the program starts much slower and everything feels slow. Especially when typing text, there is a big pause until the letters appear. I have also disabled OpenCL, but without improvement.

My System: Ryzen 3700X, 32GB RAM, RADEON RX5700

Link to post
Share on other sites

Fix helped me, but I can see there is still quite a lot of UI jitter going on, especially when dragging elements around. I double checked the settings and the new GPU acceleration is on.

After about 5 minutes of editing it is acting very sluggish again, though not as bad as before. All of the elements on the screen are constantly flickering and refreshing as I make changes.

This is really annoying. I can't even type in a text box without massive lag.

Ryzen 5 3600, 32GB ram, RTX 3070

Win10 - Ryzen 3600 - RTX 3070

Link to post
Share on other sites

The biggest issue I have with 1.9, other than the return of the lag (which happens over an hour), is that the text zoom is horrible.  All my text is jagged and zooming out from documents produces barely legible documents.  I can't stand it.  Using Affinity has been a labor of frustration for me.  It's still no where near as stable as Serif was, even though Serif was clunky with large documents... it was rock solid and never crashed.  

Ryzen 5 5600X, 32 Gb Ram, 2080Ti

Windows 10 x64 (OS Build 19041.630) - AMD 5600X - 32 GB - 2 TB M.2 - 1 TB SSD - GeForce 2080Ti 

Link to post
Share on other sites

I can confirm this issue with the horrible performance after upgrading to 1.9. Also using an AMD Ryzen 3700X.

I can also confirm nodeus' workaround solving the - but I investigated further and found out that it is enough to delete/rename the file WindowProfile.xml in %AppData%\Affinity\Publisher\1.0\Workspaces\Publisher. So all other settings despite of the window positions will be kept. Hope this helps someone as long as the issue is not fixed by affinity.

Edited by stedaho
Link to post
Share on other sites

In my case the workaround/fix suggested by @nodeus didn't work. My impression is that the issue affects AMD powered machines to a larger extend as Intel powered ones.

In particular typing in textframes is a nightmare. Interesstingly APub never consumes more than 4% of the CPU (as per Windows Task Manager) but stutters while typing. Sometimes APub runs two seconds behind my fingers...

Link to post
Share on other sites
  • Moderators

Thanks all. We figured it out. It's actually the Paragraph panel that's causing the slowdown. If this is opened/in view, the app seems to be quite slow. CTRL reset / renaming the app data will start the app with the paragraph panel hidden, so it looks like it fixes the issue (until you open it back up). The workaround for now would be not to have it in view. 

Link to post
Share on other sites
On 2/4/2021 at 10:13 PM, nodeus said:

Well, I have a solution.

go to %AppData%\Affinity\Publisher\ and rename the "1.0" to "1.0 old ver" and restart Publisher.

This is work for me. 

This definitely works, thank you. I have done little looking into the differences between the newly instantiated folders and the prior ones, but there are some differences here and there. Maybe there is a mistake in the update process to update a settings xml files I can see.

 

Hopefully an update fixes this issue, as it is a bit annoying how it clears out a lot in this process.

 

 

UPDATE:

Only works temporarily. Begins lagging again not too long after, despite so few (literally not even 5 text boxes on screen)

Edited by Grimofdoom
status update
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.