Jump to content

Photo 1.9.0 - Procedural Texture dialog missing controls


Recommended Posts

The Procedural Texture dialog in Affinity Photo 1.9.0 does not display the Custom Input value fields or sliders. See uploaded image.

I discovered this using preexisting macros that use PT, but also manually added a PT layer/filter with the same results.

Procedural Texture Dialog.png

Link to post
Share on other sites

Hi @Gabe

I'm running 11.2, about dialog attached.

But even weirder, since reporting this I did a clean install of macOS (after erasing Macintosh HD), and did a fresh install of the apps, (without any TimeMachine or backup/restore) so there should be no weirdness from old data/configs.

I still have the same symptom, based on opening a new raw file and adding a Live PT and destructive PT.

Non-reproducibility is a bugger. Let me know if there is anything else I can do or send you, I use a bunch of Dave's PT macros. Thanks

 

Screen Shot 2021-02-08 at 8.33.51 AM.png

Link to post
Share on other sites
  • 2 weeks later...

I am having the same problem on a MacBook Pro laptop with trackpad and macOS 10.15.7, using either the current or beta versions of Affinity Photo (v1.9.0 or v1.9.1.219).

As shown in the screenshot of the Live Procedural Texture window, every Custom Input is unusable because the interface for the input is not expanding to the width of the window. The slider bars are not visible at all, while the disks for indicating angles and lighting angles are truncated. It did not help to enlarge the window in both directions before adding any Custom Inputs.

210218_Procedural_Texture_UI.jpg

Link to post
Share on other sites
  • Moderators

Hi @Bugfoot,
Thanks for your report. Can you post a screenshot of the specs of you Mac please (with serial number hidden). I'm able to reproduce the issue here on some systems but not on others. I'm not sure this is related with the OS as it's working fine for me on Big Sur but fails on Mojave, whereas it seems to be failing for you and @BeauRX on Big Sur. Thanks.
 

Link to post
Share on other sites

I'm seeing the same problem on 11.2.1 (AF 1.9.0).

Perhaps related:

  • Open document
  • Create PT filter (non-destructive)
  • Add a custom control - either a 0..1 or -1..1
  • Enter a description (one character will do)
  • Click on the X. Note, the X is superimposed over the end of the text box, rather than to the right of it.
  • AF consistently crashes.

I sent a crash report through Apple.

Link to post
Share on other sites

@MEB thanks for logging this. I just tried again with (1.9.1.225 - GM Seed) Mac and still have the same problem as first reported, sure hoping this gets fixed before final release. Since first reporting, I did a clean install of Big Sur (for unrelated reasons) so this should be ideal test conditions. Thanks

Link to post
Share on other sites
1 minute ago, MEB said:

Hi @BeauRX,
This issue wasn't solved yet/log remains open. I believe it will not be ready in time for 1.9.1, sorry.

Thanks MEB, I just discovered it hasn't been fixed yet, hopefully it will be in the next beta as this is a very useful filter

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.