Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

1.9 crashing on start up


Recommended Posts

Photo 1.9 is crashing when opening. Enter product key ok gets to loading fonts and crashes. Have uninstalled it and reinstalled, with the same result. Both Designer 1.9 and Publisher have installed and are working fine.

Anyone else having issues on Windows 10

Link to comment
Share on other sites

I am also having a problem with the new Photo 1.9. It crashes when I try to close the Welcome screen or even try to use one of its tutorials. I can't get out of the Welcome screen without it crashing. Both Publisher and Designer seem to be fine however. I do have one problem with registering the Publisher update.

Link to comment
Share on other sites

I have played a little bit more with Publisher since I posted above  and seem to be having problems with that too. I'll have to work on all three personas for awhile to know better what I'm dealing with (not that I ever really know what I'm doing!)  I just tried opening a project I completed yesterday and while I opens it doesn't open right, doesn't have all the pictures etc. that I put in the project yesterday (the 1.8 version of the program.) I sure hope all that work isn't gone!  And none of the three programs have asked me for the product keys.

 

Link to comment
Share on other sites

Same(?) issue here. Updated Photo, Designer and Publisher from 1.8x to 1.9. Now alle three fail to start (Win 10 x64), but only on one specific machine: The startup screen can be seen, then vanishes and the app never starts. On another machine all three work just fine.

Edited by IkariShinji29
typo
Link to comment
Share on other sites

I am having the same problem with version 1.9 of all three apps on Windows 10. Splash screen appears and then the program ends. Apps appear briefly as an active app in task manager then disappear from the list in task manager.

Link to comment
Share on other sites

17 minutes ago, IkariShinji29 said:

Same(?) issue here. Updated Photo, Designer and Publisher from 1.8x to 1.9. Now alle three fail to start (Win 10 x64), but only on one specific machine: The startup screen can be seen, then vanishes and the app never starts. On another machine all three work just fine.

Same issue happens on my notebook (Surface Pro 4), no problem on my pc.

Link to comment
Share on other sites

Found the solution to my issue with Photo, Designer and Publisher 1.9 refusing to start on a notebook (just briefly showing the startup screen and then closing):

I had to update the drivers for the integrated Intel graphics device. On my machine was an ancient version of the driver (from 2017), supplied by the notebook manufacturer (HP). In order to override that manufacturer's driver version, you have to manually download the driver for your device from the Intel website and install it manually. Intel refuses to meddle with manufacturer supplied drivers automatically.

Link to comment
Share on other sites

There is a major issue with the 1.9 update. For many folks including me, all products are not functioning properly - For instance, I upgraded Photo and Designer to 1.9 in Win 10 pro. Photo is doing fine, but Designer crashes after the splash screen. I couldnt even close the program without using task manager to close it. I uninstalled 1.9 and reinstalled 1.85 and now have the same issue which I did not have before. I found a workaround - if you leave the splash screen open and drop in a previous file you created, it works fine, even in saving files. But if I need a new document of any kind, I cannot do so because Designer will freeze up every time.

Link to comment
Share on other sites

I updated both photo and designer and used my account to add past purchases to the software. I updated publisher and when I try to do add my purchases automatically, it freezes. I've cleaned my computer and checked my drivers. Everything is up to date. I am also getting a weird message when I first open any of the software saying a dll file is missing. c:\windows\system32\nvopencl.dll is the message. it says the procedure entry point fatBinaryCtl could not be located in the dynamic link library. But if I click the x on the message, it opens the program and 2 of the three are working beyond that. Just publisher is freezing. It was the third one I updated.

Link to comment
Share on other sites

It seems that there are a huge variety of issues with this update - some folks are having issue with laptops - but when they download to desktop they have no issues.  Some have issues with all products, some with only one or two.  There doesnt seem to be a pattern that I can see yet, just know that Affinity has a huge headache in their lap because for most folks like me, there was no issues until the update.  I have several project to complete and this update didn't help at all. 

Link to comment
Share on other sites

I upgraded my Affinity Designer from 1.8.5 to 1.9.0.932 today and now when I open a new drawing or load a saved .afdesign file and begin to modify it, the program crashes within about 60 seconds. Without a drawing, it does not crash.

Link to comment
Share on other sites

4 hours ago, Jonjo131 said:

I can't even get to the stage of entering the product key before the programs crash over all three applications,

I am having the same issue. Just updated from 1.8 to 1.9. But non of them can be started.  Only the start image appeared for one second and then nothing appears after that.

Later, I uninstalled 1.9 and re-installed 1.85 and it worked (I only tested for AP)

Edited by ZY Chang
New info
Link to comment
Share on other sites

2 hours ago, ZY Chang said:

I am having the same issue. Just updated from 1.8 to 1.9. But non of them can be started.  Only the start image appeared for one second and then nothing appears after that.

Later, I uninstalled 1.9 and re-installed 1.85 and it worked (I only tested for AP)

Where can I find the previous versions? I must be overlooking it

Link to comment
Share on other sites

8 hours ago, IkariShinji29 said:

Found the solution to my issue with Photo, Designer and Publisher 1.9 refusing to start on a notebook (just briefly showing the startup screen and then closing):

I had to update the drivers for the integrated Intel graphics device. On my machine was an ancient version of the driver (from 2017), supplied by the notebook manufacturer (HP). In order to override that manufacturer's driver version, you have to manually download the driver for your device from the Intel website and install it manually. Intel refuses to meddle with manufacturer supplied drivers automatically.

Tks, problem solved.

Link to comment
Share on other sites

  • Moderators

Hi @Ginblue, @Jonjo131, @FrankAPerry, @cid69, @IkariShinji29, @Rich MN, @Claudio60, @jt49, @fadmedia, @Keilah, @Jeffl, @ZY Chang, @KAROS, @Loyalty Is Key

We're sorry to hear you're having trouble with the latest update.

Unfortunately trying to deal with 14+ separate issues on one thread is logistically challenging and this gets confusing, quickly. For this reason, I'll be including some information and suggestions below, alongside links to our relevant FAQs.

Please try all of these necessary steps provided on your system to resolve the issue you're having. If for any reason this doesn't solve the issue, please create a new thread, providing as much information as possible for our team.

 

Version 1.9 introduces OpenCL Hardware Acceleration to Windows. As some users have found, their Graphics Card (GPU) drivers are  out of date and this is causing Affinity to crash.

Please visit the manufactures website for your GPU and download the latest drivers manually from there, as installing them through Windows Updates will likely not use the latest version.

Once updated, restart your PC and try launching Affinity again.

 

If you're seeing 'Setup Failed', we need a copy of your installer log. Please open Windows Run (Windows Key + R) then paste the following string and press OK:

%temp%\AffinitySetup

In the window that opens, please select the most recently created folder, then upload SetupUI.log to a new thread, with any additional information.
 

Please see our below FAQs regarding Windows installation -

Installer Errors, Setup Failed & Installer Windows UI Issues

What to do if Affinity is failing to start, crashes on startup or the UI is not displaying correctly

Affinity Installer window not showing

This app can't run on your PC

Supported Windows Version Not Found

Installation failed with error code: (0x00000057), "The parameter is incorrect. "

Affinity apps no longer start after installing the Windows 10 October 2020 (20H2) update

The product key is valid, but there was an error writing the licence file

 

If you have followed all necessary steps provided above and the app is still crashing then we're going to need a copy of your crash reports. Please see the below link for how to obtain these -

Where to find Crash Reports

Once you have your crash reports, please attach these to a new thread, with information regarding your system and the issue you're experiencing.

I am locking this thread to prevent further replies, I hope this helps.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.