Jump to content
JoonaJ

All 3 apps crash after updating

Recommended Posts

Hello!

I updated the whole Affinity suite to 1.9 and Publisher, Designer and Photo now crashes right on splash screen. You really should put more effort to testing before publishing. Here are the exact infos of env:

 

Affinity version: Windows 1.9.0.932

CPU: Intel(R) Core(TM) i5-6200U CPU
GPU: Nvidia Geforce 1060
Memory: 8 Gb
OS: Windows 10 Pro 19042.746 / 20H2
EP: 120.2212.551.0

 

 

Share this post


Link to post
Share on other sites

Hey JoonaJ,

Welcome to the forums.

Hundreds if not thousands of hours were put into testing the app both internally and externally by our selfless beta testers. Unfortunately we don't always have access to the plethora of hardware and software combinations that is available on Windows.

Could I kindly ask you to provide us with a crash report. You can find them here:
C:\Users\yourusername\AppData\Roaming\Affinity\Photo\1.0\CrashReports\reports

Share this post


Link to post
Share on other sites

Hi Chris B,

The directory you mentioned stays empty even after Photo crashes. I do have scandinavian alphabets in my user name. Could that be the reason for dump not getting saved?

Edited by JoonaJ

Share this post


Link to post
Share on other sites

 

Hi all,

 

Geeks 3D Caps Viewer 1.50.0.0 crashes as handsomely when OpenCL is enabled so this might have something to do with that. Nvidia driver is the latest R461.40 (r461_36-4) / 27.21.14.6140 (1-22-2021).

 

Share this post


Link to post
Share on other sites
2 hours ago, JoonaJ said:

Hello!

I updated the whole Affinity suite to 1.9 and Publisher, Designer and Photo now crashes right on splash screen. You really should put more effort to testing before publishing. Here are the exact infos of env:

Quite a rough and rude start for a third post... Thousands of users don't have this problem, so maybe.....


-- Window 10 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 6th gen 128 gb - Apple Pencil 1

Share this post


Link to post
Share on other sites

Installed .NET Framework repair tool as suggested

NO luck for me.... Same issue with AF Photo, simply crash while accessing my account to register.

Share this post


Link to post
Share on other sites

Net Framework tool never worked for me either. Crash report below:

Name Size Date modified
08fddd7e-ccf3-4470-8fe3-9fe1ee5c64a8.dmp 833 kB 04/02/2021, 12:09:39
0cbe1608-49f8-49a7-a620-843549caae09.dmp 813 kB 04/02/2021, 13:24:16
172dae9a-bacb-4393-8fc7-7eda5b557aa0.dmp 839 kB 04/02/2021, 12:11:27
1e00a5df-2094-4da0-bd96-2a6d24ba7a95.dmp 835 kB 04/02/2021, 18:14:14
1fb8cf0e-9f92-4520-b752-b826adf5837f.dmp 838 kB 04/02/2021, 18:19:46
27f69643-120d-4c2a-9d42-3bbc2e66eacc.dmp 815 kB 04/02/2021, 13:51:54
2bef674b-d665-4cbf-b1c4-1261ef9319ba.dmp 839 kB 04/02/2021, 12:13:04
4c7db170-1cd9-4c81-8c37-4e09f784574e.dmp 841 kB 04/02/2021, 12:34:00
50880b56-e1e2-4941-bc59-0edf13290b7f.dmp 824 kB 04/02/2021, 13:56:38
5cd41395-4e90-4198-9f20-c23f0c4127a6.dmp 835 kB 04/02/2021, 12:11:30
6f5d3f1d-4145-415d-9b53-df423f7a30b3.dmp 811 kB 04/02/2021, 13:58:30
771bd602-ee1e-48e6-adde-b92e294bc61a.dmp 853 kB 04/02/2021, 13:20:01
7abffcac-f4a1-4def-8538-35c64a188739.dmp 838 kB 04/02/2021, 18:13:59
80d2918d-6095-4f22-a6ef-9b28508fd71d.dmp 837 kB 04/02/2021, 18:29:28
8971480d-9202-4b57-aae9-825b513839ee.dmp 824 kB 04/02/2021, 13:57:09
8bed8cec-6a00-4e67-b4b1-18337ac37d3f.dmp 835 kB 04/02/2021, 12:13:01
8e6848f0-34d8-4a86-8979-8817d19936c9.dmp 811 kB 04/02/2021, 12:07:39
9fa34217-c63b-4714-8ce6-73b396d6b69d.dmp 816 kB 04/02/2021, 13:21:02
b6c2fa5c-8d2f-4be3-8de9-8f011376ffa3.dmp 816 kB 04/02/2021, 13:55:07
be74fd5f-1674-4db6-b597-108cfc76383d.dmp 837 kB 04/02/2021, 18:11:45
d788c6d4-044e-44e6-80cf-8576c945ecab.dmp 814 kB 04/02/2021, 18:08:41
fbcbf004-2a16-46fb-819b-2ce734c4bade.dmp 836 kB 04/02/2021, 12:11:39

Share this post


Link to post
Share on other sites

If you see Photo, Designer and Publisher just briefly show the the startup screens and then crash after updating to 1.9, try updating the graphics drivers, especially if you have a notebook with an integrated Intel graphics card. Solved the issue for me.

Share this post


Link to post
Share on other sites
8 hours ago, IkariShinji29 said:

If you see Photo, Designer and Publisher just briefly show the the startup screens and then crash after updating to 1.9, try updating the graphics drivers, especially if you have a notebook with an integrated Intel graphics card. Solved the issue for me.

Thank you very much , problem solved for me too ☺️

Share this post


Link to post
Share on other sites

As I wrote in your thread about this: Are you sure you're using the latest driver for the HD 630 from Intel - and not the one from your notebook manufacturer? Drivers supplied by the latter may be shown as newest available drivers and still be significantly outdated. Windows Update does not change to newer native Intel drivers automatically, you will have to do that manually.

Share this post


Link to post
Share on other sites
28 minutes ago, IkariShinji29 said:

As I wrote in your thread about this: Are you sure you're using the latest driver for the HD 630 from Intel - and not the one from your notebook manufacturer? Drivers supplied by the latter may be shown as newest available drivers and still be significantly outdated. Windows Update does not change to newer native Intel drivers automatically, you will have to do that manually.

Thank you so much, I downloaded straight from Intel website and it all now works perfectly. Thanks again as I would never have got there on my own 🙂

Share this post


Link to post
Share on other sites
19 hours ago, Alan Shearman said:

 

Hello Alan, 

Würdest Du mir bitte den Link zu diesem Treiber Intel 630 senden, habe Probleme, den richtigen zu finden.

Wie ist die aktuelle Versionsnummer?
 
Would you please send me the link for this Intel 630 driver, but I am having trouble finding the right one.
 
 What is the current version number?

Share this post


Link to post
Share on other sites

Hello Alan,

Danke für den Link, hat aber bei mir nicht funktioniert, weil mein Treiber die Hersteller-Version und nicht direkt  Intel kommt.

Thanks for the link, but it didn't work for me because my driver comes from the manufacturer's version and not directly from Intel.

 

Wolfgang

Share this post


Link to post
Share on other sites
2 hours ago, wolboe said:

Hello Alan,

Danke für den Link, hat aber bei mir nicht funktioniert, weil mein Treiber die Hersteller-Version und nicht direkt  Intel kommt.

Thanks for the link, but it didn't work for me because my driver comes from the manufacturer's version and not directly from Intel.

 

Wolfgang

Original Intel DCH drivers can't install over OEM drivers if the OEM drivers are old and not "signed/certified/WHQL"  (you'll get an error); if this is your problem first you have to uninstall all Intel drivers related to your graphic card until you see "Microsoft Basic Display Adapter" in device manager, reboot, then install the latest Intel drivers from their web site. Hope it helps

Share this post


Link to post
Share on other sites

Danke für den Hinweis – aber ich bin kein Profi und habe Bedenken, dass der Intel-Originaltreiber mit dem Chipsatz des Herstellers nicht richtig arbeitet.

Thanks for pointing this out - but I'm not a professional and I am concerned that the original Intel driver will not work properly with the manufacturer's chipset.

Wolfgang

Share this post


Link to post
Share on other sites
1 hour ago, wolboe said:

Danke für den Hinweis – aber ich bin kein Profi und habe Bedenken, dass der Intel-Originaltreiber mit dem Chipsatz des Herstellers nicht richtig arbeitet.

 

Thanks for pointing this out - but I'm not a professional and I am concerned that the original Intel driver will not work properly with the manufacturer's chipset.

Wolfgang

 

👍

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.