Jump to content

Affinity Designer Windows Customer Beta - 1.9.0.911 (RC3)


Recommended Posts

  • Moderators

Click here to download the latest beta

Status: Customer Beta - Release Candidate 3
Purpose: Features, Improvements, Fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Changes

  • Fixed crash when loading an OpenAsset document with no internet connection 
  • Fixed resource manager displaying cache location
  • [Beta] Changed crash report email submission to be optional
  • Fixed Freehand Selection Tool cursor failing to update when using shortcuts
  • Fixed handling of TIFF orientation tag
  • Fixed Export Preview scaling in high DPI

1.9.0.903 (RC2) release notes

Link to post
Share on other sites
  • Moderators

Please can users of this beta look at the My Account feature (top right of the main toolbar) even if you have already done so recently in another beta, as we are still making last minute changes

We have added the ability to link your Affinity app to your Affinity account through a new app registration process. This will have the advantages of you being able to stream any content you have purchased (or received for free from the Affinity store) directly to all your apps without having to manually install them. This is of particular use to customers who have more than one of our apps, or run our apps on different devices and operating systems as all your content will automatically be available across all of them.

If you register the beta app you will initially receive a free brush kit (the luminance brush kit) for testing purposes. This might be a kit you already have, but if you don’t you will get it for free. Over the next few weeks this will be expanded to include all of the store content you may already own.

 

There have been lots of behind the scene improvements and more of the purchasable and (historical) free claimable content is being added. PLEASE report anything you find using "My Account" IN THAT THREAD

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites

I am still getting the problem of rendering the rectangle to which the Contour tool is applied.

How to reproduce the bug.

1. Create a rectangle.

2. Apply the Contour tool.

3. Ctrl + G place our rectangle in a group.

4. We transform the group.

5. Move the group.

6. Remember the days of Windows XP.

238870329__2021_01_15_01_50_23_339.thumb.gif.725cad49ef6f83effdc3e95caa3c189d.gif

__________________

Windows 10 64-bit,

AMD Ryzen 5 3600 + Nvidia 1660 Super + Nvidia Studio driver + 32 Gb RAM.

Link to post
Share on other sites
8 hours ago, Max N said:

I am still getting the problem of rendering the rectangle to which the Contour tool is applied.

How to reproduce the bug.

1. Create a rectangle.

2. Apply the Contour tool.

3. Ctrl + G place our rectangle in a group.

4. We transform the group.

5. Move the group.

6. Remember the days of Windows XP.

I can't reproduce this, OpenCL on of off.

-- Window 10 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 6th gen 128 gb - Apple Pencil 1

Link to post
Share on other sites
10 minutes ago, AlainP said:

I can't reproduce this, OpenCL on of off.

In my case, the problem is reproducible with OpenCL on and off.

__________________

Windows 10 64-bit,

AMD Ryzen 5 3600 + Nvidia 1660 Super + Nvidia Studio driver + 32 Gb RAM.

Link to post
Share on other sites

1- Download was cool and fast, no lag, no stop.
2- install went no issue and no alert
3- app launch is fast (have not tried a project with it)
4- font loading is faster compared to previous build.
5- Removal of guide is faster never had this up to now. Please keep this or improve more if possible but I'm fine with it current status.
6- Template loading is faster (i have pixels and vector stuffs in there) it load it just at the speed of a WACS.
7- loaded recent project with even more than what my templates do have and it was much faster loading than AfPhoto did.
8- File>Export (to Dir) is now much better but not as faster as what AfPhoto actually demonstrated to me today but still, it is a bit faster than the action on the previous build, please make it much faster there is no need to wait seconds juts to display the file manager and save my project. This should ne as natural as possible.

This build is good for me except the few I mentioned above.
Thanks to @Mark Ingram and the entire AfDesigner team.

Never be the Same Again !
---
Dell Precision T3500 
Intel Xeon W3530 @2.80GHz with 16GiB 1333 MHz DDR3
Nvidia Quadro K2000 2GB vRAM
Windows 10 Pro N x64 20H2 + LibreOffice 7.1

My well suited Set of Apps [Production only]
* Affinity Suite [Designer + Photo + Publisher]
* Camtasia 2020 + Inkscape 1.0.2 beta + Blender 2.92 Beta

Link to post
Share on other sites
18 hours ago, Powerhorse said:

The vector brush still not functioning correctly.

The problem with the vector brushes occurs at the moment when you use the function of beginning and end limit in the settings of the individual brushes. So it happens that a too short stroke cannot underline the two ends. That is, if you use this function in the brushes to not distort the two ends, you will automatically be limited in the stroke length.
As soon as you remove these two limitations in the settings of the brush, the error is gone on the one hand, but unfortunately the complete stroke is then distorted or repeated.
Almost all of the brushes included in the program have these limitations and thus these faulty strokes occur if the length is not correct.

Link to post
Share on other sites

Thanks for the new update for fixing some bugs in Designer.
Are also a few helpful, new features added, these I like.

But unfortunately some of the long existing bugs are still not fixed. I keep reading that this problem is being passed on and that they are working on a solution, but so far there is no sign that they have addressed these issues.

Bugs and problems that have only arisen since the last update have been fixed after a short time.

Errors and problems that have existed for several years and have been reported very frequently have still not been fixed. These include, for example, the functions under Geometry to combine and split objects. Furthermore, incorrect results when you want to use more than two objects at the same time.

Link to post
Share on other sites
1 hour ago, PaRunk said:

These include, for example, the functions under Geometry to combine and split objects.

Zum Glück habe ich noch ein Macromedia Freehand das mir hilft wo Designer Probleme macht ;-))

I am so Sorry, Google translate for me, I am not liable for Google ;-))

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.