Jump to content

Affinity Photo Windows Customer Beta - 1.9.0.911 (RC3)


Recommended Posts

  • Moderators

Click here to download the latest beta

Status: Customer Beta - Release Candidate 3
Purpose: New features, performance, fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Changes

  • Fixed crash when loading an OpenAsset document with no internet connection 
  • Fixed resource manager displaying cache location
  • [Beta] Changed crash report email submission to be optional
  • Fixed Freehand Selection Tool cursor failing to update when using shortcuts
  • Fixed handling of TIFF orientation tag
  • Fixed Export Preview scaling in high DPI
  • Added New Astrophotography Stack menu item to File menus of all Personas

1.9.0.903 (RC2) release notes

Link to post
Share on other sites
  • Moderators

Please can users of this beta look at the My Account feature (top right of the main toolbar) even if you have already done so recently in another beta, as we are still making last minute changes

We have added the ability to link your Affinity app to your Affinity account through a new app registration process. This will have the advantages of you being able to stream any content you have purchased (or received for free from the Affinity store) directly to all your apps without having to manually install them. This is of particular use to customers who have more than one of our apps, or run our apps on different devices and operating systems as all your content will automatically be available across all of them.

If you register the beta app you will initially receive a free brush kit (the luminance brush kit) for testing purposes. This might be a kit you already have, but if you don’t you will get it for free. Over the next few weeks this will be expanded to include all of the store content you may already own.

 

There have been lots of behind the scene improvements and more of the purchasable and (historical) free claimable content is being added. PLEASE report anything you find using "My Account" IN THAT THREAD

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites

Usability feedback - New pattern layer from selection.

  • Made selection on the only layer I had - an image layer.
  • Selected 'New pattern layer from selection'

Nothing happens. Nothing.

An old timer here I understood it probably was related to the "Image, pixel, raster" complexity in Photo and I was right.

But when the feature cannot create anything - and doesn't - it should trigger an error / info message about why. 

  • "The user interface is supposed to work for me - I am not supposed to work for the user interface."
  • Computer-, operating system- and software agnostic; I am a result oriented professional. Look for a fanboy somewhere else.
  • “When a wise man points at the moon the imbecile examines the finger.” ― Confucius
  • Not an Affinity user og forum user anymore. The software continued to disappoint and not deliver.
Link to post
Share on other sites

1- Download was cool and fast, no lag, no stop.
2- install went no issue and no alert
3- app launch is fast (have not tried a project with it)
4- font loading is quite faster.
5- Removal of guide is a bit faster than previous build but still has lags, well nothing major on this I can live with it.
6- project template  loading is slow while it loaded in less than 3sec on AfPublisher (exact exact template, no change to it); should be fixed in next build.
7- File>Export (to Dir) now works faster, all previous build was lagging a lot when trying to open the windows file manager dialog box but now it's much better.

This build seem to be good at some for me but still some few stuffs need to be resolved or improved for the good.
Thanks to @Mark Ingram and the entire AfPublisher team.

Never be the Same Again !
---
Dell Precision T3500 
Intel Xeon W3530 @2.80GHz with 16GiB 1333 MHz DDR3
Nvidia Quadro K2000 2GB vRAM
Windows 10 Pro N x64 20H2 + LibreOffice 7.1

My well suited Set of Apps [Production only]
* Affinity Suite [Designer + Photo + Publisher]
* Camtasia 2020 + Inkscape 1.0.2 beta + Blender 2.92 Beta

Link to post
Share on other sites

Hi! I'm new in the forum. I have a problem with Affinity Photo on Windows (last stable release): after selecting a brush and using it, the selection highlight is gone, so I no longer know which brush I was using. It's impossible to work this way. Will this be fixed in 1.9? I can't use Photo for digital art because this problem. Thanks! (and forgive my english)

Link to post
Share on other sites
  • Moderators
1 hour ago, Yuli said:

Hi! I'm new in the forum. I have a problem with Affinity Photo on Windows (last stable release): after selecting a brush and using it, the selection highlight is gone, so I no longer know which brush I was using. It's impossible to work this way. Will this be fixed in 1.9? I can't use Photo for digital art because this problem. Thanks! (and forgive my english)

Hey @Yuli - welcome to the Affinity Forums. 

This usually happens when you either a) modify the brush which means it's no longer the brush you initially selected (as it has been modified) or b) you have switched tools.

I have seen numerous reports of this and it was already logged with the developers.

Link to post
Share on other sites
  • Moderators
1 hour ago, Abelnt said:

"New astrophoto stack" crash if i have a previous photo loaded.

On new start with no photo works fine.

Agreed, this will be fixed in a future build, hopefully 1.9.0 or 1.9.1 

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.