Jump to content

Screen flicker in Affinity Designer


Recommended Posts

Hello,

I have quite a weird issue ongoing with my Affinity Designer on Windows 10.

I'm experiencing screen flicering whenever I use Affinity when moving the mouse on my main monitor (2160x1440p, 144Hz) but not on the 2nd monitor (1920x1080p, 60Hz).
I was down to think it was an hardwaire failure, but outside of Affinity, the flickering is completely gone.

I tried to reinstall the app, to no avail. I checked my drivers, all up to date.

As this bug don't reflect directly when recording, I recorded it with my phone.

 

Hope you have a solution, the flicking is killing my eyes for now.

 

Regards

Link to post
Share on other sites

I experience myself a light / faint flicker when moving the mouse from the panels into the canvas and back. Moving the mouse only over the panels do cause no flicker. In my case the flicker is very subtle and my drivers are up-to-date.

------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Link to post
Share on other sites
2 hours ago, Joachim_L said:

I experience myself a light / faint flicker when moving the mouse from the panels into the canvas and back. Moving the mouse only over the panels do cause a flicker. In my case the flicker is very subtle and my drivers are up-to-date.

Yep same, and bigger flicker if I use Artboard in the main composition

Link to post
Share on other sites
  • Moderators

Hi Mykro,

Can you please provide us with some information about your setup, what graphics card are you using and what is your current driver version? Also what is the make and model of your two monitors? Are they using G-Sync or Freesync?

I'm not seeing any flickering or behaviour you're getting. I've been using a Dell U2718Q 4k screen (at 150% Display DPI in Windows) at 60hz and a Benq GW2470H at 1080p (100% Display DPI in Windows) 60hz monitor connected to a Geforce 1080 using the 461.40 Studio Drivers.

Link to post
Share on other sites
31 minutes ago, Sean P said:

Hi Mykro,

Can you please provide us with some information about your setup, what graphics card are you using and what is your current driver version? Also what is the make and model of your two monitors? Are they using G-Sync or Freesync?

I'm not seeing any flickering or behaviour you're getting. I've been using a Dell U2718Q 4k screen (at 150% Display DPI in Windows) at 60hz and a Benq GW2470H at 1080p (100% Display DPI in Windows) 60hz monitor connected to a Geforce 1080 using the 461.40 Studio Drivers.

Hi Sean,

Sure thing. My setup is a RTX 2080Ti with latest NVidia Drivers (461.40 at date of recording, issue still occuring). I'm using an AOC Q27G2G4 1440p screen (at 100% Display DPI) at 144Hz (using G-Sync) and an ACER GN246HL at 1080p (at 100% Display DPI) 60Hz.

Link to post
Share on other sites
  • Moderators

Thanks for that,

We've had a few similar sounding reports and there are a few things in common: namely the 461.40 drivers, 1440p and possibly G-Sync. Could you try disabling G-Sync and see if that helps with the behaviour? If not does setting that monitor to 60hz stop it from happening? 

Unfortunately I don't currently have any G-Sync supported monitors or 1440p screens to try locally as we're all still working from home right now.

 

 

Link to post
Share on other sites

I'll try to see if it change anything.

May I mention that if I swap Affinity window to my 60Hz monitor, the flicker is completely gone, but since they have also 2 different resolution and the 60Hz isn't using any Sync at all, there's still all the culprit in the equation.

 

EDIT : Swapping my 1440p monitor to 60Hz (and let G-sync enabled) fixed it. I'll try the other way around now, Remove Gsync and stay at 144Hz.

EDIT 2 : The other way around fixed it too (remove Gsync and stay at 1440p 144Hz)

No idea why it act like this :/

Link to post
Share on other sites
  • Moderators
7 minutes ago, Mykro said:

I'll try to see if it change anything.

May I mention that if I swap Affinity window to my 60Hz monitor, the flicker is completely gone, but since they have also 2 different resolution and the 60Hz isn't using any Sync at all, there's still all the culprit in the equation.

 

EDIT : Swapping my 1440p monitor to 60Hz (and let G-sync enabled) fixed it. I'll try the other way around now, Remove Gsync and stay at 144Hz.

EDIT 2 : The other way around fixed it too (remove Gsync and stay at 1440p 144Hz)

No idea why it act like this :/

Wonderful thanks for conforming that! It sounds as though something in the new drivers is causing this behaviour - seems suspect to have similar issues from multiple users from newly released drivers! I'll feed that back to development.

Link to post
Share on other sites

Dropping the refresh rate on my MSI Optix G24C down to 60 Hz in Windows 10's Advanced Display Settings (Settings - System - Display - Advanced Display Settings at the bottom of the right panel) corrected the flickering issue for me. (nvidia 461.4 drivers)

2021-02-02 10_58_36-Settings.png

 

I'm just thankful that my monitor isn't dying.

Link to post
Share on other sites
On 1/29/2021 at 4:10 PM, Sean P said:

Hi Mykro,

Can you please provide us with some information about your setup, what graphics card are you using and what is your current driver version? Also what is the make and model of your two monitors? Are they using G-Sync or Freesync?

I'm not seeing any flickering or behaviour you're getting. I've been using a Dell U2718Q 4k screen (at 150% Display DPI in Windows) at 60hz and a Benq GW2470H at 1080p (100% Display DPI in Windows) 60hz monitor connected to a Geforce 1080 using the 461.40 Studio Drivers.

Hi !
It works for me !
- Disable G-sync and stay in 144 Hz solve the problem
- Enable G-sync and put one screen on 60 Hz solve the problem

 

Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...
  • 2 weeks later...
2 hours ago, soapman said:

just updated everything for the BAR upgrade. Latest nvidia drivers. Also having flicker issue

LG cx48 OLED 120hz. < 3080 FTW

 

no flicker with Gsync off.

Did you try nvidia 's studio driver instead of their gaming driver? That's what fixed it for me. 

Link to post
Share on other sites

yep, need to look into if i lose BAR support.

 

Noticing today, in nvidia control panel. if you have it only selected for gsync in fullscreen and not windowed mode it works fine since im not using full screen on my lg cx48.

 

never mind. Its bad after a full day of work.  I left for lunch came back and now its flickering like a bastard.

Link to post
Share on other sites

Sorry to report I am having the same problem on both my LG 27UK650_600 monitors 😞

 

Software: Affinity Designer 1.9.2

OS:

Edition    Windows 10 Pro
Version    20H2
Installed on    ‎3/‎11/‎2021
OS build    19042.867
Experience    Windows Feature Experience Pack 120.2212.551.0

GPU: RTX 2060 Super

Driver: Studio Drivers version 461.92

Monitors: 2 LG 27UK650_600 and 1 HUION KAMVAS PRO 22

Running at 4K Resolution

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.