Jump to content
ManyWeAre

[Designer] Cursor lag with Wacom

Recommended Posts

Cursor lags for a fraction of a second after the pen is put down and then moved.

 

Happens for every tool in both drawing and pixel personas. Most visible when using any of the freehand drawing tools. This creates a noticeable hiccup for every stroke, and makes short strokes with low pressure virtually impossible to make.

 

Different pressure settings

Different Wacom pens

Lower view settings in AD preferences

Closer and further zoom

 

I've searched extensively on the forums and the web at large and found no more reports of this so I'm wondering if it's only happening in my particular set up, specially in El Capitan:

 

OS X 10.11 (El Capitan Public Beta, latest release)

Wacom Intuos Pro touch small (latest drivers)

Affinity Designer 1.3.5 trial (from Serif's website, latest release)

MacBook Pro (Retina, 15", Late 2013)

16GB RAM

 

I really want to buy this program, it's amazing otherwise, but it's unusable with the cursor lag for me.

Thank you.

Share this post


Link to post
Share on other sites

Hi ManyWeAre,

 

I've got the same hardware but a Cintiq instead - and I've had all the betas of El Capitan (and the current GM) and I don't see the stutter at all? Have you set something in the Wacom preferences maybe? What happens if you make a new user in OS X (it's very easy to do and can be deleted again afterwards with no side effects) and then try running the Designer Trial on that instead - does it still happen? (I'm suggesting this in case it's an application installed for your user that is intercepting something...)

 

Let us know how you get on :)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

I tried your suggestions plus a lot more and the initial stutter is still there, unfortunately...

 

New information:

  • The same occurs in Affinity Photo.
  • And with all cursor-based tools (e.g. marquee tools, move tool), not just paintbrushes. 
  • Occurs with the built in trackpad (!!!) not just Wacom tablets.

Here are the additional steps I've taken:

  • Tried several illustration/photo editing programs. None showed the issue. The only issue they showed is being worse than Affinity. :)
  • Cleared Wacom preferences.
  • Removed Wacom driver completely, reinstalled it with default settings.
  • Tried my Cintiq.
  • Cleared all non-system startup items.
  • Cleared preferences for Affinity Designer and Photo.
  • Uninstalled all other image editing applications.

It's a fraction of a second stutter at the beginning of a cursor drag, either with a tablet or the macbook's trackpad. With a large, round, black brush, I can see it flicker to white for a split second when the stutter happens.

 

Short of doing a clean system install (I'm not going to), I don't know what else to do. :(

Share this post


Link to post
Share on other sites

Hi ManyWeAre,

 

Thanks for trying all of that! :) I'm trying to get a handle on what you're seeing and I'm wondering if it's this:

 

Make a new document.

Add a new pixel layer (in the Layers panel)

Go to the brush tool.

Move the mouse/Wacom over the document and you'll see a preview nozzle of what you would get if you clicked.

Hold the mouse button down/press the pen against the tablet.

The preview goes away (because you're not clicking, you're pressing)

Nothing happens until you move somewhere.

 

Is that the source of your problem? It's the only thing I can think of that sounds like what you're describing and if so I can probably try to do something about it... It doesn't show anything for the mouse down because that point's direction will be modified by the subsequent points and it may affect the way the nozzle is supposed to look for that point, but for many brushes it wouldn't matter at all, so it could put them down anyway.

 

Do you think that's likely to be the problem, or is it something else that you're seeing?

 

Thanks again,

Matt

Share this post


Link to post
Share on other sites

Matt,

 

There is a noticeable delay between the moment the mouse button is down/tablet down/pen down and the next time it draws a stroke. The effect is that when doing short quick strokes, I only see the initial point after a fraction of a second, something like 0.2s probably.

 

Like I pointed out initially, this effectively makes drawing short strokes almost impossible since I won't see what I'm doing until the pen has moved enough. In Designer, specifically, when drawing with vectors, that means I can't just tap to make a dot. I have to hold the pen/mouse down and wiggle it a bit until something gets drawn.

 

And just to reiterate: it happens with every tool, not just the brushes. So making very small rectangles or marquee selections is quite challenging.

 

I've been using digital art programs for over 15 years and have never seen this behavior. In fact, none of the other programs I tried the past few weeks behaves like that.  Which is why I thought it was a bug or something on my end.

 

Hopefully that clarifies things.

 

When I have the time, I can make a 60fps video to show you what it looks like compared to another program. My Designer trial has run out, but I still have a few days left in Photo, which behaves exactly the same. If it is indeed working as intended, I would like to suggest revising this behavior as it will deter other artists from using Affinity.

 

Thank you for looking into this and helping me diagnose the issue.

Marcelo

Share this post


Link to post
Share on other sites

Sorry for my bad english!

 

I have exactly the same problem, with OSX 10.10 and with 10.11. I use a small Wacom Intuos and don't have zero problems/latency with Ai & Ps (CS5), Artrage and Mischief, to paint and sketch very fast. Sad, but in Affinity-Designer i can't make fast strokes without getting an awful latency and edgy lines. That's the only reason why i didn't buy this otherwise very good software. So, the trial runs out and i can't try it longer. Really don't now, why the performance is so bad... : (

 

* I use a Mac Mini 2,5 GHz Intel Core i5 / 8GB and AMD Radeon HD 6630M 256 MB

Share this post


Link to post
Share on other sites

I'm experiencing this as well. It happens when I make short strokes with a mouse too, so it's not a tablet issue.

 

OS X: El Capitan

Processor: 2,2 GHz Intel Core i7

Memory: 16 GB 1600 MHz DDR3

Graphics: Intel Iris Pro 1536 MB

 

I posted this bug recently here, not knowing that it has been filed already, so you can close it in favor of this post.

Share this post


Link to post
Share on other sites

I have the same problem.. posted it into another thread by mistake:

 

OS: Mac OS 10.11.2

Tablet: Wacom Bamboo Pen

Affinity Designer: 1.4.1 (Latest Version)

 

Specs:

2,9 Intel Core i5

8 GB 1600 MHz DDR3

NVIDIA GeForce GT 650M 512 MB

 

Video

 

Description:

Whenever I try to draw small lines (hatching) or small circles quickly it takes a while for the line to be drawn which results in small errors like the little dots as seen in the video or the lines not appearing at all. 

Share this post


Link to post
Share on other sites

This company has promising products, but unfortunately seriously lacks user support, which is equally important. In my opinion this bug is very crippling for drawing and the communication from Affinity on this simply stopped. I noticed half-assed support with other issues as well.

Share this post


Link to post
Share on other sites

Hi guys.

I think I might have a solution.

I'm french so my translation of french terms might not be so good.

I had the same issue so I went into the wacom settings. With the stylus selected on the menu, under the first cursor where you can choose the amount of pression you want to use, there is a button named adapt or something like that.

Click on it.

You will see a curve. make sure that the first point is on the y axis. I mean right on it. I did that and it fixed the problem for me.

If I'm not being clear enough because of my english, I might publish a video.

EDIT : here's a picture

 

Good luck everyone.

solution.jpg

Edited by Dyukunker
adding a picture

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×