Jump to content
Sign in to follow this  
avo

Alt+Drag always makes coordinates that are not in whole pixels

Recommended Posts

I use AD for screen design and when i copy an object with alt+Drag i get coordinates of new object that are not whole pixels even though "Force pixel alignment" and "move by whole pixels" buttons are pressed, and snapping (which can result in split pixels too) is turned off. This produces some additional pain when you have to manually fix coordinates for objects, especially if you created a lot of them using alt+drag.


Follow me on Dribbble

https://dribbble.com/g-avoyan

Share this post


Link to post
Share on other sites

Please have in mind, that Option (Alt) also serves as the universal modifier that disables snapping in Affinity Designer. Hold down Command and drag and object to duplicate it without disabling snapping …  :)

 

(I know this takes some time to accustom to, but it’s very useful in many cases … I think it’s great that we have two different ways to handle snapping when we are duplicating objects on the canvas: Option+Drag > snapping off; Command+Drag > snapping on.)

Share this post


Link to post
Share on other sites

That's the way to go.  ;)

 

I'd rather we didn't have Alt to clone, and just went with Cmd.  


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×