Jump to content
You must now use your email address to sign in [click for more info] ×

Serif Labs raw engine not decoding raw file on open

Recommended Posts

Tried with Nikon and Fuji raw, same result, presented with blank screen. If you select develop AP will develop the raw using Serif Lab
First image opened using Serif Lab raw, second using Apple core image raw.

iPad Pro 2018 12.9” model, running iPadOS 14.2




Link to comment
Share on other sites

  • 4 months later...

Hi @Gabe

I'm having the same issue on iPad Pro 2021 when trying to open NEFs using Serif labs engine.

Do you know when this can be fixed?

I was hoping this engine could give better default results (base level corrections) for raw files. The defaults that I get from apple engine aren’t great when comparing eg to those from Nikon NX-D (on MacOS). Unfortunately there is no Nikon editing software for iPad so I have to rely solely on Affinity but that means much more work/corrections to achieve the final results.

Link to comment
Share on other sites

  • 1 month later...

Might be related or not: i got a white canvas while opening a CR2 RAW. After forced-closing  Photo and re-opening it worked ok. 

Mac mini M1 A2348

LG34WK950U-W, calibrated to DCI-P3 with LG Calibration Studio / Spider 5

iPad Air Gen 5 (2022) A2589

Special interest into procedural texture filter, edit alpha channel, RGB/16 and RGB/32 color formats, stacking, finding root causes for misbehaving files, finding creative solutions for unsolvable tasks, finding bugs in Apps.


Link to comment
Share on other sites

Hi Gabe,

Just tried this with a fuji RAF file on the beta version and worked fine using Serif Labs and Apple Core image raw, Nikon Z7 files (uncompressed, lossless compressed and compressed) all in 14bit has the same problem. Also the 12 bit versions of the files and the same result.

Not sure if its just me?

Re iPad model, its the 2018 iPadPro 12.9" model with 256gb storage running iPadOs 14.6




Link to comment
Share on other sites




Sorry for the delay, but re-booting makes no difference. Just an idea thought but I’ve been using the production version tonight and it worked fine for NEF’s from my Z7 with the Nikon 14-30 but failed the same as soon as I tried a NEF taken with the Z7 and the Nikon 24-200. Is this as simple as a lens compatibility issue on the Serif Lab raw decoder?


Link to comment
Share on other sites

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.