Jump to content

Recommended Posts

When creating (and refreshing) a TOC in a text frame inherited in a page from one created in a master page, afpub goes crazy with the text styles defined for the TOC. Including if the text frame isn't connected with the rest of the text flow. Moreover, the app behaves strangely when trying to correct the style errors.

Only apparent solution is to create the TOC in an independent text frame, not from an inherited.

Is this a bug? If not so the app should say that this is not possible (dialog or something similar).

😐

Share this post


Link to post
Share on other sites

I don't seem to have that problem, @eluengo. Of course, I'm on Windows, but I would expect similar behavior there for a problem like that.

Can you provide some screenshots or (even better) a sample document to illustrate the problem?


-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.2.1005 Beta   / Affinity Designer 1.9.2.1035 and 1.9.2.1005 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Share this post


Link to post
Share on other sites

mmmm, i’ll try to recreate the circumstances, but as I discovered the “solution” (putting TOC in an independent text frame) I began tu put more and more text of a long manual, for which I have to complete text and recreate all the graphics (all that in my free time, as I’m physician). I’ll try and send U the file. Thanx !!

Share this post


Link to post
Share on other sites

Dear Walt

I've tried to reproduce the conditions that made my afpub behave crazy.... but oops, now works OK!!!, so I don't understand its previous madness.

Sorry 🤷🏻‍♂️

Emilio

Share this post


Link to post
Share on other sites

Oh, well, that happens sometimes. Thanks for trying.

If you think you'll be reporting a problem it's best to save a copy of the document before you fix it :) (but even that doesn't always help).


-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.2.1005 Beta   / Affinity Designer 1.9.2.1035 and 1.9.2.1005 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.