Jump to content

Recommended Posts

I have "Check Spelling While Typing" selected, but words are not being underlined.

If I try to execute "Check Spelling" I get an error that there's no dictionary installed for Canadian English. I'm happy to use British English, but not sure where I select this.

The folder "C:\ProgramData\Affinity\Common\1.0\Dictionaries" is empty - this can't be right can it?

Thanks

Neel

 

Affinity Designer spelling bug.jpg

Affinity Designer dictionary error.jpg

Link to post
Share on other sites
8 minutes ago, NeelModi said:

The folder "C:\ProgramData\Affinity\Common\1.0\Dictionaries" is empty - this can't be right can it?

Welcome to the Serif Affinity forums.

Yes, that's correct. That folder contains any dictionaries that you have added, and it is empty until you add some. The dictionaries that come pre-installed with Affinity are in a different location.

If you want a Canadian English dictionary you'll need to install it yourself. The FAQ has information on locating and installing dictionaries:

If I remember correctly there is no Canadian English hyphenation dictionary, so in addition to downloading the .aff and .dic files for Canadian English I think you'll need to download the US or UK English hyphenation dictionary and rename it.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

Thanks Walt!

I did actually find the Language setting in the Character studio tab. All my text was set to "(unavailable) EN-CA" which I think AP took from my Windows settings. I had to click inside each text box, select all, then change the language setting to UK English. I wish I could just select all boxes and change this, but it look likes AP needs text actually selected. I only had about 20 boxes, so no big deal.

Then I selected UK English in Preferences, restarted AP, and now new text boxes default to UK English.

Typos and spelling errors are being underlined now.

Neel

Edited by NeelModi
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.