Jump to content

Affinity Designer Windows Customer Beta - 1.9.0.834


Recommended Posts

  • Moderators

Click here to download the latest beta

Status: Customer Beta
Purpose: Features, Improvements, Fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Changes

  • Enable hardware by default, but restrict it to Windows 10.0.19041 (May 2020), and GPUs that support Direct3D 12 Feature Level 12.0 and above (see https://affin.co/WinGPU for further information).
  • Added Save as Package
  • Added ability to open package files
  • Improvements to application registration and content syncing
  • Improved Studio Presets management
  • Fixed import of some PSD files ignoring the alpha channel
  • Fixed ALT+MouseWheel causing the menubar to highlight
  • Fixed crash when resizing canvas 
  • Fixed Alignment toolbar buttons always being disabled
  • Fixed several bugs relating to using pixel layers as children in symbols

1.9.0.820 release notes

Link to post
Share on other sites

As soon as I try to open a document, Affinity Designer Beta 1.9.0.834 crashed, just the same as the new photo beta does, I am unable to open anything in either program.

Disabling Hardware acceleration allows me to open files, enabling it again crashes

EDIT: Just realised I once again added incorrect log file, I have attached the correct one this morning

 

Log.txt

Link to post
Share on other sites
21 hours ago, Lincsman said:

As soon as I try to open a document, Affinity Designer Beta 1.9.0.834 crashed, just the same as the new photo beta does, I am unable to open anything in either program.

Disabeling Hardware acceleration allows me to open files, enabling it again crashes

Log.txt 5.21 kB · 2 downloads

Same here... same happens with APhoto beta .834 too.

 

Edit: Finally managed to remove all registry entries and reinstall 820! Phew!

Link to post
Share on other sites

I tried but failed to reproduce this on two versions of Windows: 
-- Previous version, Home (10.0.18363), no hardware acceleration
-- October Feature Update (2004) with hardware acceleration both enabled & disabled.
Version1.9.0.834 opened .afdesign files, created in this and earlier versions of the program. Also opened PDF, tif, png & psd files without crashing.

XPS 15, 32GB RAM, Nvidia 1050

Link to post
Share on other sites
19 hours ago, Lincsman said:

As soon as I try to open a document, Affinity Designer Beta 1.9.0.834 crashed, just the same as the new photo beta does, I am unable to open anything in either program.

Disabling Hardware acceleration allows me to open files, enabling it again crashes

EDIT: Just realised I once again added incorrect log file, I have attached the correct one this morning

 

Log.txt 5.63 kB · 0 downloads

Same here

Affinity Designer 1.9.2.1035 & beta 1.9.4.1048   Affinity Photo 1.9.2.1035 beta  1.9.4.1048 Affinity Publisher 1.9.2.1035 beta  1.9.2.1024

Windows 10 Pro 64-bit 2004

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Link to post
Share on other sites
On 11/6/2020 at 4:37 PM, Lincsman said:

As soon as I try to open a document, Affinity Designer Beta 1.9.0.834 crashed, just the same as the new photo beta does, I am unable to open anything in either program.

Disabling Hardware acceleration allows me to open files, enabling it again crashes

 

For me, with Hardware Acceleration enabled (but with no GPU that supports it), I cannot:

  • Create a New document via File > New. The initial dialog opens, but when I click Create the program crashes.
  • Without a document open, I cannot switch to the Pixel Persona and then look at the Brushes panel. As soon as I click on its tab, the program crashes. It works fine in the Designer Persona.

After I disable Hardware Acceleration and restart Designer, both these functions work properly.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
8 hours ago, walt.farrell said:

 

For me, with Hardware Acceleration enabled (but with no GPU that supports it), I cannot:

  • Create a New document via File > New. The initial dialog opens, but when I click Create the program crashes.
  • Without a document open, I cannot switch to the Pixel Persona and then look at the Brushes panel. As soon as I click on its tab, the program crashes. It works fine in the Designer Persona.

After I disable Hardware Acceleration and restart Designer, both these functions work properly.

Thanks so, so much Walt! This is the solution to the problem. You are a star!

 

Affinity: Please default OpenCL acceleration to NO on install. (and I am absolutely sure this will be addressed because Affinity do listen)

Link to post
Share on other sites

This Beta version 1.9.0.834 is buggy. It crashes whenever you want to open a file from the previous beta version or from the public version. Disabling hardware acceleration allows opening files.

Renderer: NVidia GForce GT 640.

6 cœurs Windows 10 pro   Affinity Desktop Publisher, Affinity Desktop Designer, Affinity Desktop Photo.

Mais je vous le demande, peut-on imaginer une police sans sérifs ?

Link to post
Share on other sites
  • Moderators
10 hours ago, walt.farrell said:

 

For me, with Hardware Acceleration enabled (but with no GPU that supports it), I cannot:

  • Create a New document via File > New. The initial dialog opens, but when I click Create the program crashes.
  • Without a document open, I cannot switch to the Pixel Persona and then look at the Brushes panel. As soon as I click on its tab, the program crashes. It works fine in the Designer Persona.

After I disable Hardware Acceleration and restart Designer, both these functions work properly.

I assume that you can't re-enable the option? After you've disabled the option, then restarted the app?

Link to post
Share on other sites
1 hour ago, Mark Ingram said:

I assume that you can't re-enable the option? After you've disabled the option, then restarted the app?

No. If I reenable it the crashes return.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

Instead of being forced to use HW acceleration by default, it would be better to implement a splash screen of sorts (like in many video games) which presents the option to users at the time of startup. I don't want to miss out on using the program just because I have (supposedly) obsolete hardware that is limited to DX11. For all I know, I may never even be using it to create very large, complex pieces of work that demand powerful GPUs. The software/processor based implementation would suffice for my use case 🙂.

Link to post
Share on other sites
  • Moderators
10 hours ago, IndieGuy said:

Instead of being forced to use HW acceleration by default, it would be better to implement a splash screen of sorts (like in many video games) which presents the option to users at the time of startup. I don't want to miss out on using the program just because I have (supposedly) obsolete hardware that is limited to DX11. For all I know, I may never even be using it to create very large, complex pieces of work that demand powerful GPUs. The software/processor based implementation would suffice for my use case 🙂.

You're not, it's on by default if your hardware supports it (or at least it's supposed to work that way...). If you don't have the hardware, the app will work exactly the same as it always has done.

Link to post
Share on other sites

Designer Beta 1.9.0.834

New drawing
Add rectangle (Rectangle Tool)
Rotate from one corner
Bounding box appears with same fill colour as rectangle (attached image)

Additional info.

Zoom clears the bounding box but changing the fill colour of the rectangle restores it.

rotate.png

Link to post
Share on other sites
23 hours ago, XU3E said:

Hardware acceleration is very slow. I have GTX 1070 8GB RAM. Even with snapping disabled i see that pointer is slow and less responsible. With old version Affinity or Hardware acceleration disabled there is no problem.

 

I have a GTX 1070, too and no problems.

Driver: v456.71

Windows 10 (still 2004 no H2)

 

Any special document type or tool type?

 

 

System                                                              Notebook Lenovo P50

CPU: AMD Ryzen 3900x                                 CPU: Intel i7-6700HQ

RAM: 64 GB                                                      RAM: 32 GB

GPU: GTX 1070                                               GPU: NVIDIA Quadro M2000M 4 GB

SSD: Samsung 840 EVO 250 GB                  SSD: Samsung 850 Pro 500GB

OS: Windows 10 Pro x64                               OS: Windows 10 x64

TFT: 1 x Samsung C49RG94SSU                 TFT: 2 x Lenovo

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.