Jump to content

Odd background behavior in Designer

Recommended Posts

This has been happening for a little while: if i create a new document of any specs, I see the outline of the documents border as a grey box, but there appears to be a static portion of the document that is either white, or the transparency checkerboard if I've checked transparent background. The rest of the document background remains black. Zooming in or out or scrolling around  will not change where this visible area appears on my screen; it's always located in the upper left corner of the window. It feels like it might be a screen redraw bug, but I'm not sure. I just tried a document I created in June and I can't seem to replicate it. I'm using 1.8.4 on a new iMac running OS 10.15.6. Thanks.


Link to comment
Share on other sites

I too think it is down to a screen redraw issue. But also you have nothing in the document, nothing is in your layers panel. What happens if you put something in the document?

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 11.6.8

Affinity Designer 1.10.5 | Affinity Photo 1.10.5 | Affinity Publisher 1.10.5 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

Same thing; that was how I actually first noticed it. I thought I had a white box floating around somewhere but as I moved around using the scroll wheel or the Grab tool I noticed how it stuck to the same place on my monitor. While I've been an Illustrator user for more than 20 years, I'm still getting used to Designer so some of its quirks or differences have looked like bugs to me, or just better ways of doing things than Adobe. :) 

I just tried creating a new document on my home iMac that is also running OS 10.15.6 but has 1.8.3 of Designer. It worked fine. So perhaps it's a bug with 1.8.4 I think I'm going to reinstall 1.8.4 with a clean installer and see what happens.

Link to comment
Share on other sites

I've discovered it's definitely a screen redraw issue and not related to 1.8.4. I put 1.8.3 back on the affected iMac and the same issue occurred. After messing around with the Performance preferences in Designer, some combination of using Metal for Display and/or checking "enable Metal compute acceleration" is causing it. Some bug with this video card in this iMac (AMD Radeon Pro 5700 XT 16 GB) is causing it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.