Jump to content

Affinity Photo Windows Customer Beta - 1.9.0.820


Recommended Posts

Click here to download the latest beta

Status: Customer Beta
Purpose: New features, performance, fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

New Feature: Product registration and store content streaming

We have now added the ability to link your Affinity app to your Affinity account through a new app registration process. This will have the advantages of you being able to stream any content you have purchased or received for free from the Affinity store directly to all your apps without having to manually install them. This is of particular use to customers who have more than one of our apps, or run our apps on different devices and operating systems as all your content will automatically be available across all of them.

If you register the beta app you will initially receive a free brush kit (the luminance brush kit) for testing purposes. This might be a kit you already have, but if you don’t you will get it for free. In a couple of weeks this will be expanded to include all of the store content you may already own.

While this is the full scope of what we are implementing for 1.9, the link between your account and your apps will open up the possibility for us to offer other features and services in the future which we think you will like.

Update: Following user feedback we have changed Store content to be (optionally) retained after the user has signed-out

Changes

  • Fixed middle mouse button failing to work after displaying the Registration page
  • Fixed noise rendering in linear fills

1.9.0.815 release notes

Link to post
Share on other sites

Hi Mark, It also seems that downloading Store content then signing out and resetting removes the store content from the application even though it says that the content will remain available in the app, seems to be that Clearing the user Data means the App is no longer registered:

Sign Out:
image.png.cbedc1d53d4017235381e753d1dcffff.png

Clear User Data:
image.png.68fd3eab048d2e235b332c38808d1c9c.png

On Restart:
image.png.e4de31f4a37cac32ef5af2c9fad706bf.png

On Restart after clearing the user data this is the message again asking to sign in even though Reset Brushes (don't know it it is significant) is not selected:

image.png.ca778dea104dc5dd6aad6f29b3c78fee.png

 

Regards Don

Win 10 x64 System with Intuos Pen & Touch
 - Sys : Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), 16GB RAM
 - GPU 1: Intel HD Graphics 630, GPU 2: NVIDIA GTX1050, 4GB

iPad (8th Gen) 2020

 

Link to post
Share on other sites

Don, Thank you that CTRL+run up you describe is the designed behaviour. Resetting the app will clear the registration and remove the downloaded content. We thought that users would expect to be able to clear the registration easily like that, remember that brushes are not the only thing that will be downloadable from your store purchases

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
5 minutes ago, root said:

Dear developers, please check the Resize Canvas option. It crushes crashes the Photo and Designer as well.

Already reported, Cropping in APhoto also crashes the program

Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Link to post
Share on other sites

I'm not sure if this is the right place to raise this, but I've just downloaded the latest version and when I hit "My Account" and try to register it I just get a popup saying "Please wait a moment", but then it just stays there and nothing else happens. (It was the same with the previous version.)

Link to post
Share on other sites
1 hour ago, JokerMartini said:

Where is the Clear User Data dialog? I need to run that

Hold the Ctrl key while starting the application, and keep it held until the dialog shows up. (Note: on my system, the application icon shows up on the Windows taskbar, and I have to click on it before I get the dialog, and then release Ctrl.)

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

@PaulEC & @Dave Quail

We are adding better logging to try to query this sort of event. This is of course very helpful to know, so is there anything unusual you could tell us about your internet access (network, proxy firewall?)

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
19 minutes ago, Patrick Connor said:

@PaulEC & @Dave Quail

We are adding better logging to try to query this sort of event. This is of course very helpful to know, so is there anything unusual you could tell us about your internet access (network, proxy firewall?)

Nothing unusual re internet access etc. I do have Norton 360 installed, but don't know if that could be relevant.

Link to post
Share on other sites
1 minute ago, PaulEC said:

Nothing unusual re internet access. I do have Norton 360 installed, but don't know if that could be relevant.

It could be, depending on the firewall configuration, but the default settings haven't caused any problems for me with this beta function.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
21 minutes ago, walt.farrell said:

It could be, depending on the firewall configuration, but the default settings haven't caused any problems for me with this beta function.

I only mentioned Norton because I know anti-virus software can cause problems, but I haven't had a similar problem with anything else.

Link to post
Share on other sites

Registration worked well on my end.

Best regards!

You'll never know what you can do until you get it up as high as you can go!   

AMD FX 8350 :: Radeon HD 7870 :: Windows 10 ::  http://mithferion.deviantart.com/

Oxygen Icons :: Free Quality Fonts :: Public Domain Pictures :: iOS 11 Design Resources :: iOS App Icon Template :: Hot to do High Quality Art :: Mesh Warp / Distort Tool Considerations

Link to post
Share on other sites
3 hours ago, Patrick Connor said:

@PaulEC & @Dave Quail

We are adding better logging to try to query this sort of event. This is of course very helpful to know, so is there anything unusual you could tell us about your internet access (network, proxy firewall?)

@Patrick Connor @walt.farrellNothing unusual. No proxy, firewall setting identical to the PC which doesn't have the problem. DNS settings identical. Windows Defender settings the same on both. I am a MS insider so know where to poke around looking for differences. And no, the 2 PC's are not running Insider OS's, but the current Windows release: (Insider versions run on other hardware for obvious reasons)
Edition    Windows 10 Pro
Version    20H2
Installed on    ‎2020/10/‎25
OS build    19042.572
Experience    Windows Feature Experience Pack 120.2212.31.0

Link to post
Share on other sites

Latest beta 1.9.0.820, after upgrading, when choosing Sign In Now... I get the horizontal Please Wait a Moment (with neon animated activity) for several seconds, then a crash to desktop (CTD).

Note that I haven't tried the 1.9.0.815 beta, so this is my first time trying this new login approach from within the app: I can't say if it would have also happened with the previous release.

I run BitDefender, but it doesn't report having blocked any network or suspicious activity. When I re-launch AP, I see in my Task Manager that a 'crash-handler' applet also runs (I don't know if it ran the first one or two times). Skipping logging in, everything seems like normal program operation, but if I choose "My Account", and I retry logging in, I get the exact same. Repeatedly. AP and the Crash-handler both terminate every time. The only thing for my system that's not completely up-to-date was the latest "2020-10 Cumulative Update preview for .NET Framework 3.5 and 4.8 for Windows 10 version 1909 x64". I just installed that, but must reboot and if it fixes it, I'll post that back here, but I doubt that's my solution.

Exciting to see the developments.

UPDATE: 2020-10-28

  • Did the "2020-10 Cumulative Update preview for .NET Framework 3.5 and 4.8 for Windows 10 version 1909 x64" update - no resolution to issue.
  • Did the "Clear User Data Dialog" steps (leaving the top default selections checked), and also no impact to the subsequent CTD.
Edited by Wumpus
Updated after trying workarounds
Link to post
Share on other sites
On 10/27/2020 at 4:43 PM, klauspstein said:

YEs, immediate crash on cropping in Photo , also exported HDR JPGs seem to need far more space than before, i.e. 35 Mb instead of 12 , I will try to check if this was a single or general issue. 

The HDR-jpg size is equal in beta and current version, so I take that back.

Link to post
Share on other sites
16 hours ago, Roberto Sdul said:

Hello Mark, 

In preferences, in the tools section,
when selecting the box to zoom with the mouse. It would be necessary to change that the image moves horizontally and does not magnify when pressing the Shift key and using the mouse wheel.

Best regards.

I think this should work too. I will pass this on. Thanks :)

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.