Jump to content

Affinity Designer Windows Customer Beta - 1.9.0.767


Recommended Posts

  • Moderators

Click here to download the latest beta

Status: Customer Beta
Purpose: Features, Improvements, Fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Fixed margin fills not being applied
  • Fixed drag and drop to place deselecting the new layer
  • Fixed hang when font combo contains fonts we can't render and can't find a valid match for
  • Fixed Contour tool Radius text box capping the entry to 50px
  • Fixed Contour tool Radius always being displayed in pixels
  • Fixed Layer panel Auto-Scroll option not being remembered
  • Fixed AltGr+Tab breaking shortcuts 
  • Added Flood Select tool to Pixel workspace
  • Changed non-pixel aligned Artboards to automatically align (fixes unexpected dimensions, and blurred exports)
  • Added Studio Presets and associated Manager (View | Studio Presets) (Coming soon)

1.9.0.734 release notes

Link to post
Share on other sites

I can't find "Studio Presets" in "View" menu.

Dell Inspiron 7559 i7    Windows 10 x64 Pro
Intel Core i7-6700HQ (3.50 GHz, 6M )    16GB Dual Channel DDR3L 1600MHz (8GBx2)    NVIDIA GeForce GTX 960M 4GB GDDR5
1TB HDD + 128 GB SSD Hard drive    UHD (3840 x 2160) Truelife LED - Backlit Touch Display

Link to post
Share on other sites
1 hour ago, Petar Petrenko said:

I can't find "Studio Presets" in "View" menu.

I don't see it, either.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1065 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1065 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
1 hour ago, Mark Ingram said:

Doh! It got added to Photo only. No good reason, should be in Designer too. Will fix for next build.

I thought the theory was that the initial release got enough negative comments from users that the developer was going to rework it, and that Designer and Publisher wouldn't get it until the rework was available.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1065 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1065 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
  • Moderators
1 minute ago, walt.farrell said:

I thought the theory was that the initial release got enough negative comments from users that the developer was going to rework it, and that Designer and Publisher wouldn't get it until the rework was available.

Yep, and the new version is available in the latest build of Photo.

Link to post
Share on other sites

The contour tool does not work properly.
A 50x50mm rectangle is drawn on the screen.
Using the contour tool and the 118.2mm setting is actually 10mm.
And somehow I don't see an improvement in setting the slider with values greater than 50 or -50.
If I design large elements, e.g. 2 meters, and would like to apply a contour shift, what is 50mm?
I know I can type manually, but this is a stupid limitation.
And the reset button for this tool is missing, or at least double-clicking on the dot on the slider could reset to 0.
And yet the scaling of this tool is missing exactly the same as the scaling is missing in Coorner Tool.
I wonder if it would not be better if the original of the object remained when using the contour tool (as in CORELDRAW, for example).

image.thumb.png.c026afa4932e08caf3190efa13791662.png

Link to post
Share on other sites
  • Moderators
10 hours ago, GRAFKOM said:

The contour tool does not work properly.
A 50x50mm rectangle is drawn on the screen.
Using the contour tool and the 118.2mm setting is actually 10mm.
And somehow I don't see an improvement in setting the slider with values greater than 50 or -50.
If I design large elements, e.g. 2 meters, and would like to apply a contour shift, what is 50mm?

This is an issue with the Windows version - it seems to be giving a readout of the actual pixel value, but for whatever reason showing the units as being in mm. The Mac version is currently behaving correctly in this regard (though it is a slightly earlier build). I'll get this passed on to development.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.