Jump to content
Mark Ingram

Affinity Designer Windows Customer Beta - 1.9.0.733

Recommended Posts

Click here to download the latest beta

Status: Customer Beta
Purpose: Features, Improvements, Fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Added initial support for hardware acceleration (must be enabled in Preferences | Performance, "Enable OpenCL compute acceleration")
  • Added Contour tool
  • Added Select Same / Select Object
  • Improved performance with large documents
  • Added a new Divide blend mode
  • Added ability to snap to the bounds of the pixel selection

1.8.5.703 release notes

Share this post


Link to post
Share on other sites
5 minutes ago, MickRose said:

The download link doesn't seem to work on Firefox.

Downloaded it with Firefox within approx. 45 seconds.


------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites

Installed on Win 8.1 but does not run the application. freeze at start.


Serif Software user since 2008 | Not an active forum user since July 4, 2019 after getting a nice response from Developer.

Share this post


Link to post
Share on other sites

When I double click the exe file I get this message. Will this lose the release version 1.8.5.703. I seem to remember previous betas mentioned beta on the splash screen.

image.png.8fc41b517a42c09ae8292f74be285c58.png


Windows 10 Pro, I5 3.3G PC 16G RAM

Share this post


Link to post
Share on other sites
1 minute ago, MickRose said:

When I double click the exe file I get this message. Will this lose the release version 1.8.5.703. I seem to remember previous betas mentioned beta on the splash screen.

image.png.8fc41b517a42c09ae8292f74be285c58.png

Nope - it will only update the Beta version! :)

Share this post


Link to post
Share on other sites

Just noticed, that startup takes approx. 10 seconds longer when acceleration is enabled. This is not the case in the 1.9 beta of AP.


------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites

Just in case anyone wonders where the new Contour Tools is (if not visible by default), go to View > Customize Tools...

image.png.4846d912a4fecfa7b23b218b3511ce83.png

Best regards!


You'll never know what you can do until you get it up as high as you can go!   

AMD FX 8350 :: Radeon HD 7870 :: Windows 10 ::  http://mithferion.deviantart.com/

Oxygen Icons :: Free Quality Fonts :: Public Domain Pictures :: iOS 11 Design Resources :: iOS App Icon Template :: Hot to do High Quality Art :: Mesh Warp / Distort Tool Considerations

Share this post


Link to post
Share on other sites
2 hours ago, Arun Sarkar said:

Installed on Win 8.1 but does not run the application. freeze at start.

For me, it starts and runs without any issue, also on Windows 8.1

 Best regards!


You'll never know what you can do until you get it up as high as you can go!   

AMD FX 8350 :: Radeon HD 7870 :: Windows 10 ::  http://mithferion.deviantart.com/

Oxygen Icons :: Free Quality Fonts :: Public Domain Pictures :: iOS 11 Design Resources :: iOS App Icon Template :: Hot to do High Quality Art :: Mesh Warp / Distort Tool Considerations

Share this post


Link to post
Share on other sites
11 minutes ago, GRAFKOM said:

For me, too, (Windows 10) Hangs on splash screen.

Thanks for letting us know Grafkom - we've identified the cause of this and are currently working on a fix! Hang tight!

Share this post


Link to post
Share on other sites
2 hours ago, Joachim_L said:

Just noticed, that startup takes approx. 10 seconds longer when acceleration is enabled. This is not the case in the 1.9 beta of AP.

Seems to be rendering the default assets (IOS12) is causing the difference. Removing this category makes startup fast as ever.


------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites
2 minutes ago, Joachim_L said:

Seems to be rendering the default assets (IOS12) is causing the difference. Removing this category makes startup fast as ever.

Does it also help if you don't have the Assets panel showing when you start Designer? (That is, if it's hidden, or at least not one of the panels that is actively being displayed?)


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.734 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.734 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.742 Beta.

Share this post


Link to post
Share on other sites
10 minutes ago, walt.farrell said:

Does it also help if you don't have the Assets panel showing when you start Designer?

Yes, it helps, but I have a longer lag when I am going to show the Assets panel again.


------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites

"Select Same" doesn't work. All options are greyed.

"Select Objects" works fine.


Dell Inspiron 7559 i7    Windows 10 x64 Pro
Intel Core i7-6700HQ (3.50 GHz, 6M )    16GB Dual Channel DDR3L 1600MHz (8GBx2)    NVIDIA GeForce GTX 960M 4GB GDDR5
1TB HDD + 128 GB SSD Hard drive    UHD (3840 x 2160) Truelife LED - Backlit Touch Display

Share this post


Link to post
Share on other sites
3 minutes ago, Petar Petrenko said:

"Select Same" doesn't work. All options are greyed.

I assume you have something selected before trying to select same?

The menu items are greyed out as long as nothing is selected in the design 🙂

d.


Affinity Designer 1.8.5 (beta 1.9.0.734)   |   Affinity Photo 1.8.5 (beta 1.9.0.734)   |   Affinity Publisher 1.8.5 (beta 1.9.0.742)
Affinity Designer for iPad 1.8.4   |   Affinity Photo for iPad 1.8.4

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites
1 minute ago, dominik said:

I assume you have something selected before trying to select same?

The menu items are greyed out as long as nothing is selected in the design 🙂

d.

Selected or not -- it doesn't work.


Dell Inspiron 7559 i7    Windows 10 x64 Pro
Intel Core i7-6700HQ (3.50 GHz, 6M )    16GB Dual Channel DDR3L 1600MHz (8GBx2)    NVIDIA GeForce GTX 960M 4GB GDDR5
1TB HDD + 128 GB SSD Hard drive    UHD (3840 x 2160) Truelife LED - Backlit Touch Display

Share this post


Link to post
Share on other sites
1 minute ago, Petar Petrenko said:

Selected or not -- it doesn't work.

Oh, that's bad. It works for me.

Can you perhaps try in a newly created and very simple document? Like three objects, two of them with the same fill color. Just to make sure the problem is not related to the document you are experiencing this.

d.


Affinity Designer 1.8.5 (beta 1.9.0.734)   |   Affinity Photo 1.8.5 (beta 1.9.0.734)   |   Affinity Publisher 1.8.5 (beta 1.9.0.742)
Affinity Designer for iPad 1.8.4   |   Affinity Photo for iPad 1.8.4

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites
3 hours ago, Sam Neil said:

@mark I am having the same loading issue as APhoto with Designer. Hangs on splash screen...

Same OS, build and version -- works great to me.


Dell Inspiron 7559 i7    Windows 10 x64 Pro
Intel Core i7-6700HQ (3.50 GHz, 6M )    16GB Dual Channel DDR3L 1600MHz (8GBx2)    NVIDIA GeForce GTX 960M 4GB GDDR5
1TB HDD + 128 GB SSD Hard drive    UHD (3840 x 2160) Truelife LED - Backlit Touch Display

Share this post


Link to post
Share on other sites
5 minutes ago, dominik said:

Oh, that's bad. It works for me.

Can you perhaps try in a newly created and very simple document? Like three objects, two of them with the same fill color. Just to make sure the problem is not related to the document you are experiencing this.

d.

New document, few objects, same color -- it doesn't work.


Dell Inspiron 7559 i7    Windows 10 x64 Pro
Intel Core i7-6700HQ (3.50 GHz, 6M )    16GB Dual Channel DDR3L 1600MHz (8GBx2)    NVIDIA GeForce GTX 960M 4GB GDDR5
1TB HDD + 128 GB SSD Hard drive    UHD (3840 x 2160) Truelife LED - Backlit Touch Display

Share this post


Link to post
Share on other sites
1 minute ago, Petar Petrenko said:

New document, few object, same color -- it doesn't work.

Thanks for trying. I do admit I am clueless for now. Let's see what others come up with.

Cheers to the south,
d.


Affinity Designer 1.8.5 (beta 1.9.0.734)   |   Affinity Photo 1.8.5 (beta 1.9.0.734)   |   Affinity Publisher 1.8.5 (beta 1.9.0.742)
Affinity Designer for iPad 1.8.4   |   Affinity Photo for iPad 1.8.4

Windows 10 (1809) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.